Welcome! Log In Create A New Profile

Advanced

Centos 5.4, libevent + fpm = проблема

Posted by Maxim Balabaev 
Maxim Balabaev
Centos 5.4, libevent + fpm = проблема
February 26, 2010 04:46AM
Решил тут помучать centos x64, никак не получается собрать fpm с svn.

checking for libevent >= 1.4.11 install prefix... /usr/local
no

libevent скачал 1.4.13 и установил в /usr/local, в lib все либы лежат
Пробовал и --with-libevent-dir=shared,/usr/local и
--with-libevent=/usr/local/lib - ничего
Revision: 295524
Sergey Kobzar
Re: Centos 5.4, libevent + fpm = проблема
February 26, 2010 04:54AM
Friday, February 26, 2010, 11:38:43 AM, Maxim wrote:

> Решил тут помучать centos x64, никак не получается собрать fpm с svn.

> checking for libevent >= 1.4.11 install prefix... /usr/local
> no


> libevent скачал 1.4.13 и установил в /usr/local, в lib все либы лежат
> Пробовал и --with-libevent-dir=shared,/usr/local и
> --with-libevent=/usr/local/lib - ничего
> Revision: 295524

Если мне не изменяет память, то здесь уже готовое должно быть:
http://centos.alt.ru/

--
Sergey
Maxim Balabaev
Re: Centos 5.4, libevent + fpm = проблема
February 26, 2010 02:54PM
хотелось бы, чтоб багу подправили всё-таки

26 февраля 2010 г. 12:48 пользователь Sergey Kobzar
<sergey.kobzar@mail.ru>написал:

> Friday, February 26, 2010, 11:38:43 AM, Maxim wrote:
>
> > Решил тут помучать centos x64, никак не получается собрать fpm с svn.
>
> > checking for libevent >= 1.4.11 install prefix... /usr/local
> > no
>
>
> > libevent скачал 1.4.13 и установил в /usr/local, в lib все либы лежат
> > Пробовал и --with-libevent-dir=shared,/usr/local и
> > --with-libevent=/usr/local/lib - ничего
> > Revision: 295524
>
> Если мне не изменяет память, то здесь уже готовое должно быть:
> http://centos.alt.ru/
>
> --
> Sergey
>
>
mente
Re: Centos 5.4, libevent + fpm = проблема
February 26, 2010 06:48PM
Это может и не бага. Удалите пакет libevent, если он есть в системе, и
оставьте только версию с сорцов.

On Feb 26, 7:39 pm, Maxim Balabaev <balabae...@gmail.com> wrote:
> хотелось бы, чтоб багу подправили всё-таки
>
> 26 февраля 2010 г. 12:48 пользователь Sergey Kobzar
> <sergey.kob...@mail.ru>написал:
>
>
>
> > Friday, February 26, 2010, 11:38:43 AM, Maxim wrote:
>
> > > Решил тут помучать centos x64, никак не получается собрать fpm с svn.
>
> > > checking for libevent >= 1.4.11 install prefix... /usr/local
> > > no
>
> > > libevent скачал 1.4.13 и установил в /usr/local, в lib все либы лежат
> > > Пробовал и --with-libevent-dir=shared,/usr/local и
> > > --with-libevent=/usr/local/lib - ничего
> > > Revision: 295524
>
> > Если мне не изменяет память, то здесь уже готовое должно быть:
> >http://centos.alt.ru/
>
> > --
> > Sergey
Maxim Balabaev
Re: Centos 5.4, libevent + fpm = проблема
February 26, 2010 08:22PM
Тоже самое
checking for libevent >= 1.4.11 install prefix... /usr/local/libevent
no
Саму либу он находит, но ругается на версию, хотя там стоит 1.4.13 из
сорцов. Попробовал ещё с 1.4.11, тоже самое, не признаёт

27 февраля 2010 г. 2:39 пользователь mente <aa.vasilenko@gmail.com> написал:

> Это может и не бага. Удалите пакет libevent, если он есть в системе, и
> оставьте только версию с сорцов.
>
> On Feb 26, 7:39 pm, Maxim Balabaev <balabae...@gmail.com> wrote:
> > хотелось бы, чтоб багу подправили всё-таки
> >
> > 26 февраля 2010 г. 12:48 пользователь Sergey Kobzar
> > <sergey.kob...@mail.ru>написал:
> >
> >
> >
> > > Friday, February 26, 2010, 11:38:43 AM, Maxim wrote:
> >
> > > > Решил тут помучать centos x64, никак не получается собрать fpm с svn.
> >
> > > > checking for libevent >= 1.4.11 install prefix... /usr/local
> > > > no
> >
> > > > libevent скачал 1.4.13 и установил в /usr/local, в lib все либы лежат
> > > > Пробовал и --with-libevent-dir=shared,/usr/local и
> > > > --with-libevent=/usr/local/lib - ничего
> > > > Revision: 295524
> >
> > > Если мне не изменяет память, то здесь уже готовое должно быть:
> > >http://centos.alt.ru/
> >
> > > --
> > > Sergey
>
Antony Dovgal
Re: Centos 5.4, libevent + fpm = проблема
February 26, 2010 09:14PM
On 02/26/2010 12:38 PM, Maxim Balabaev wrote:
> Решил тут помучать centos x64, никак не получается собрать fpm с svn.
>
> checking for libevent >= 1.4.11 install prefix... /usr/local
> no
>
> libevent скачал 1.4.13 и установил в /usr/local, в lib все либы лежат
> Пробовал и --with-libevent-dir=shared,/usr/local и
> --with-libevent=/usr/local/lib - ничего
> Revision: 295524

1) svn up
2) я лично не понимаю, что должны означать обе опции.

--with-<something>=shared - это для экстеншенов, а не для либ, и означает это, что экстеншен должен быть собран, как шаред.
А "/usr/local/lib" - это вообще из другого измерения.
Все известные мне опции configure принимают _префиксы_.
Т.е. поставили вы либу c --prefix=/usr/local - вот это и надо указывать.

--
Wbr,
Antony Dovgal
---
http://pinba.org - realtime statistics for PHP
alekciy
Re: Centos 5.4, libevent + fpm = проблема
February 27, 2010 02:26AM
http://groups.google.ru/group/highload-php-ru/browse_thread/thread/4faf89f52636ad3f?hl=ru
начиная от 6-ого камента.

On 27 фев, 05:11, Maxim Balabaev <balabae...@gmail.com> wrote:
> Тоже самое
> checking for libevent >= 1.4.11 install prefix... /usr/local/libevent
> no
> Саму либу он находит, но ругается на версию, хотя там стоит 1.4.13 из
> сорцов. Попробовал ещё с 1.4.11, тоже самое, не признаёт
>
> 27 февраля 2010 г. 2:39 пользователь mente <aa.vasile...@gmail.com> написал:
>
>
>
> > Это может и не бага. Удалите пакет libevent, если он есть в системе, и
> > оставьте только версию с сорцов.
>
> > On Feb 26, 7:39 pm, Maxim Balabaev <balabae...@gmail.com> wrote:
> > > хотелось бы, чтоб багу подправили всё-таки
>
> > > 26 февраля 2010 г. 12:48 пользователь Sergey Kobzar
> > > <sergey.kob...@mail.ru>написал:
>
> > > > Friday, February 26, 2010, 11:38:43 AM, Maxim wrote:
>
> > > > > Решил тут помучать centos x64, никак не получается собрать fpm с svn.
>
> > > > > checking for libevent >= 1.4.11 install prefix... /usr/local
> > > > > no
>
> > > > > libevent скачал 1.4.13 и установил в /usr/local, в lib все либы лежат
> > > > > Пробовал и --with-libevent-dir=shared,/usr/local и
> > > > > --with-libevent=/usr/local/lib - ничего
> > > > > Revision: 295524
>
> > > > Если мне не изменяет память, то здесь уже готовое должно быть:
> > > >http://centos.alt.ru/
>
> > > > --
> > > > Sergey
Удалили libevent и libevent-devel?

On Feb 27, 3:11 am, Maxim Balabaev <balabae...@gmail.com> wrote:
> Тоже самое
> checking for libevent >= 1.4.11 install prefix... /usr/local/libevent
> no
> Саму либу он находит, но ругается на версию, хотя там стоит 1.4.13 из
> сорцов. Попробовал ещё с 1.4.11, тоже самое, не признаёт
>
> 27 февраля 2010 г. 2:39 пользователь mente <aa.vasile...@gmail.com> написал:
>
>
>
> > Это может и не бага. Удалите пакет libevent, если он есть в системе, и
> > оставьте только версию с сорцов.
>
> > On Feb 26, 7:39 pm, Maxim Balabaev <balabae...@gmail.com> wrote:
> > > хотелось бы, чтоб багу подправили всё-таки
>
> > > 26 февраля 2010 г. 12:48 пользователь Sergey Kobzar
> > > <sergey.kob...@mail.ru>написал:
>
> > > > Friday, February 26, 2010, 11:38:43 AM, Maxim wrote:
>
> > > > > Решил тут помучать centos x64, никак не получается собрать fpm с svn.
>
> > > > > checking for libevent >= 1.4.11 install prefix... /usr/local
> > > > > no
>
> > > > > libevent скачал 1.4.13 и установил в /usr/local, в lib все либы лежат
> > > > > Пробовал и --with-libevent-dir=shared,/usr/local и
> > > > > --with-libevent=/usr/local/lib - ничего
> > > > > Revision: 295524
>
> > > > Если мне не изменяет память, то здесь уже готовое должно быть:
> > > >http://centos.alt.ru/
>
> > > > --
> > > > Sergey
zuzmic@gmail.com
Re: Centos 5.4, libevent + fpm = проблема
March 11, 2010 12:38AM
У кого была проблема решили ?
у меня тоже не получается поставить fpm с svn.

удалял libevent
(yum erase libevent libevent-devel)

скачал версию libevent-1.4.13-stable.tar.gz,

если устанавливать его в дирикторию /opt/my (./configure --prefix=/opt/
my), то возникает ошибка
./configure --enable-fpm --with-libevent=/opt/my

checking for FPM build... yes
checking for libevent >= 1.4.11 install prefix... no
configure: error: libevent >= 1.4.11 could not be found

если устанавливать в дирикторию /usr/local (./configure), то возникает
ошибка
./configure --enable-fpm --with-libevent=/usr/local
checking for FPM build... yes
checking for libevent >= 1.4.11 install prefix... /usr/local
no
configure: error: build test failed. Please check the config.log for
details.

fpm все равно не удается поставить
Re: Centos 5.4, libevent + fpm = проблема
April 10, 2010 02:25PM
Да детка, это настоящий секс когда ты пытаешься поставить php-fpm и видишь сообщение checking for libevent >= 1.4.11 install prefix... /usr/local

Я взял исходник из configure, скомпилил его с аргументам как в там (типа -L/usr/local/lib -levent) и получил ошибку что не может линковщик подгрузить библиотеку т.к. не найдена. Не может быть подумал я - ведь она там есть это факт. Потом долго думал и сделал ldconfig -p|grep libevent - пусто!!! Линкер не знает о существовании библиотеки т.к. ее нет в кэше линкера. запускаем ldconfig без аргументов, повторяем
ldconfig -p|grep libevent - видим что появилось

libevent_extra-1.4.so.2 (libc6) => /usr/local/lib/libevent_extra-1.4.so.2
libevent_core-1.4.so.2 (libc6) => /usr/local/lib/libevent_core-1.4.so.2
libevent-1.4.so.2 (libc6) => /usr/local/lib/libevent-1.4.so.2


Если не появилось (установлено в другом месте о котором не знает линковщик), идем в /etc/ld.so.conf пишем путь до каталога библиотеки и опять ldconfig без аргументов.

Запускаем ./configure --enable-fpm --> работает!

Я кончил, все свободны :)
Re: Centos 5.4, libevent + fpm = проблема
April 11, 2010 03:26PM
On 11 мар, 04:12, "zuz...@gmail.com" <zuz...@gmail.com> wrote:
> У кого была проблема решили ?
> у меня тоже не получается поставить fpm с svn.
>
> удалял libevent
> (yum erase libevent libevent-devel)
>
> скачал версию libevent-1.4.13-stable.tar.gz,
>
> если устанавливать его в дирикторию /opt/my (./configure --prefix=/opt/
> my), то возникает ошибка
> ./configure --enable-fpm --with-libevent=/opt/my
>
> checking for FPM build... yes
> checking for libevent >= 1.4.11 install prefix... no
> configure: error: libevent >= 1.4.11 could not be found
>
> если устанавливать в дирикторию /usr/local (./configure), то возникает
> ошибка
> ./configure --enable-fpm --with-libevent=/usr/local
> checking for FPM build... yes
> checking for libevent >= 1.4.11 install prefix... /usr/local
> no
> configure: error: build test failed. Please check the config.log for
> details.
>
> fpm все равно не удается поставить


Да детка, это настоящий секс когда ты пытаешься поставить php-fpm и
видишь сообщение checking for libevent >= 1.4.11 install prefix... /
usr/local

Я взял исходник из configure, скомпилил его с аргументам как в там
(типа -L/usr/local/lib -levent) и получил ошибку что не может
линковщик подгрузить библиотеку т.к. не найдена. Не может быть подумал
я - ведь она там есть это факт. Потом долго думал и сделал ldconfig -p|
grep libevent - пусто!!! Линкер не знает о существовании библиотеки
т.к. ее нет в кэше линкера. запускаем ldconfig без аргументов,
повторяем
ldconfig -p|grep libevent - видим что появилось

libevent_extra-1.4.so.2 (libc6) => /usr/local/lib/
libevent_extra-1.4.so.2
libevent_core-1.4.so.2 (libc6) => /usr/local/lib/
libevent_core-1.4.so.2
libevent-1.4.so.2 (libc6) => /usr/local/lib/libevent-1.4.so.2


Если не появилось (установлено в другом месте о котором не знает
линковщик), идем в /etc/ld.so.conf пишем путь до каталога библиотеки и
опять ldconfig без аргументов.

Запускаем ./configure --enable-fpm --> работает!

Я кончил, все свободны :)

--
To unsubscribe, reply using "remove me" as the subject.
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 104
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready