Welcome! Log In Create A New Profile

Advanced

Проблема с соединением с mysql через php-fpm

Posted by Михаил Мальцев 
Михаил Мальцев
Проблема с соединением с mysql через php-fpm
September 30, 2014 06:50AM
Приветствую.

Собрал php со следующими параметрами конфигурации

./configure' '--prefix=/usr/local/php-fpm5' '--enable-fpm' '--with-mcrypt'
'--enable-mbstring' '--with-curl' '--disable-debug' '--disable-rpath'
'--enable-inline-optimization' '--with-zlib' '--enable-sockets'
'--enable-sysvsem' '--enable-sysvshm' '--enable-pcntl' '--enable-mbregex'
'--with-mhash' '--enable-zip' '--with-pcre-regex' '--with-gd'
'--with-mysql=mysqlnd' '--with-mysqli=mysqlnd' '--with-pdo-mysql=mysqlnd

Добавил в init.d и прописал настройки в nginx.

Все прекрасно работает за исключением соединения с MySql. При попытке
соединения выдает 2002 ошибку (no File or Directory)

В php.ini прописал путь к сокету, но тоже не помогает.

Исчерпал идеи решения, может быть кто-то подскажет в каком направлении
думать?

Заранее спасибо

--

---
Вы получили это сообщение, поскольку подписаны на группу highload-php-ru.

Чтобы отменить подписку на эту группу и больше не получать от нее сообщения, отправьте письмо на электронный адрес highload-php-ru+unsubscribe@googlegroups.com.
Настройки подписки и доставки писем: https://groups.google.com/d/optout.
On 09/30/2014 01:48 PM, Михаил Мальцев wrote:
> Приветствую.
>
> Собрал php со следующими параметрами конфигурации
>
> ./configure' '--prefix=/usr/local/php-fpm5' '--enable-fpm' '--with-mcrypt' '--enable-mbstring' '--with-curl' '--disable-debug' '--disable-rpath' '--enable-inline-optimization' '--with-zlib' '--enable-sockets' '--enable-sysvsem' '--enable-sysvshm' '--enable-pcntl' '--enable-mbregex' '--with-mhash' '--enable-zip' '--with-pcre-regex' '--with-gd' '--with-mysql=mysqlnd' '--with-mysqli=mysqlnd' '--with-pdo-mysql=mysqlnd
>
> Добавил в init.d и прописал настройки в nginx.
>
> Все прекрасно работает за исключением соединения с MySql. При попытке соединения выдает 2002 ошибку (no File or Directory)
>
> В php.ini прописал путь к сокету, но тоже не помогает.
>
> Исчерпал идеи решения, может быть кто-то подскажет в каком направлении думать?

Сокет для FPM доступен?
Через порт всё работает?

--
Wbr,
Antony Dovgal
---
http://pinba.org - realtime profiling for PHP

--

---
Вы получили это сообщение, поскольку подписаны на группу highload-php-ru.

Чтобы отменить подписку на эту группу и больше не получать от нее сообщения, отправьте письмо на электронный адрес highload-php-ru+unsubscribe@googlegroups.com.
Настройки подписки и доставки писем: https://groups.google.com/d/optout.
Не оно?
http://stackoverflow.com/questions/1676688/php-mysql-connection-not-working-2002-no-such-file-or-directory

30 сентября 2014 г., 13:51 пользователь Antony Dovgal <tony@daylessday.org>
написал:

> On 09/30/2014 01:48 PM, Михаил Мальцев wrote:
>
>> Приветствую.
>>
>> Собрал php со следующими параметрами конфигурации
>>
>> ./configure' '--prefix=/usr/local/php-fpm5' '--enable-fpm'
>> '--with-mcrypt' '--enable-mbstring' '--with-curl' '--disable-debug'
>> '--disable-rpath' '--enable-inline-optimization' '--with-zlib'
>> '--enable-sockets' '--enable-sysvsem' '--enable-sysvshm' '--enable-pcntl'
>> '--enable-mbregex' '--with-mhash' '--enable-zip' '--with-pcre-regex'
>> '--with-gd' '--with-mysql=mysqlnd' '--with-mysqli=mysqlnd'
>> '--with-pdo-mysql=mysqlnd
>>
>> Добавил в init.d и прописал настройки в nginx.
>>
>> Все прекрасно работает за исключением соединения с MySql. При попытке
>> соединения выдает 2002 ошибку (no File or Directory)
>>
>> В php.ini прописал путь к сокету, но тоже не помогает.
>>
>> Исчерпал идеи решения, может быть кто-то подскажет в каком направлении
>> думать?
>>
>
> Сокет для FPM доступен?
> Через порт всё работает?
>
> --
> Wbr,
> Antony Dovgal
> ---
> http://pinba.org - realtime profiling for PHP
>
> --
>
> --- Вы получили это сообщение, поскольку подписаны на группу
> highload-php-ru.
>
> Чтобы отменить подписку на эту группу и больше не получать от нее
> сообщения, отправьте письмо на электронный адрес
> highload-php-ru+unsubscribe@googlegroups.com.
> Настройки подписки и доставки писем: https://groups.google.com/d/optout.
>

--

---
Вы получили это сообщение, поскольку подписаны на группу highload-php-ru.

Чтобы отменить подписку на эту группу и больше не получать от нее сообщения, отправьте письмо на электронный адрес highload-php-ru+unsubscribe@googlegroups.com.
Настройки подписки и доставки писем: https://groups.google.com/d/optout.
Михаил Мальцев
Re: Проблема с соединением с mysql через php-fpm
September 30, 2014 07:54AM
Сокет нет, через порт работает php. Но mysql в любом случае не коннектится
. Интересно что через php модуль apache все прекрасно соединяется.

вторник, 30 сентября 2014 г., 14:51:28 UTC+4 пользователь tony2001 написал:
>
> On 09/30/2014 01:48 PM, Михаил Мальцев wrote:
> > Приветствую.
> >
> > Собрал php со следующими параметрами конфигурации
> >
> > ./configure' '--prefix=/usr/local/php-fpm5' '--enable-fpm'
> '--with-mcrypt' '--enable-mbstring' '--with-curl' '--disable-debug'
> '--disable-rpath' '--enable-inline-optimization' '--with-zlib'
> '--enable-sockets' '--enable-sysvsem' '--enable-sysvshm' '--enable-pcntl'
> '--enable-mbregex' '--with-mhash' '--enable-zip' '--with-pcre-regex'
> '--with-gd' '--with-mysql=mysqlnd' '--with-mysqli=mysqlnd'
> '--with-pdo-mysql=mysqlnd
> >
> > Добавил в init.d и прописал настройки в nginx.
> >
> > Все прекрасно работает за исключением соединения с MySql. При попытке
> соединения выдает 2002 ошибку (no File or Directory)
> >
> > В php.ini прописал путь к сокету, но тоже не помогает.
> >
> > Исчерпал идеи решения, может быть кто-то подскажет в каком направлении
> думать?
>
> Сокет для FPM доступен?
> Через порт всё работает?
>
> --
> Wbr,
> Antony Dovgal
> ---
> http://pinba.org - realtime profiling for PHP
>

--

---
Вы получили это сообщение, поскольку подписаны на группу highload-php-ru.

Чтобы отменить подписку на эту группу и больше не получать от нее сообщения, отправьте письмо на электронный адрес highload-php-ru+unsubscribe@googlegroups.com.
Настройки подписки и доставки писем: https://groups.google.com/d/optout.
Михаил Мальцев
Re: Проблема с соединением с mysql через php-fpm
September 30, 2014 07:54AM
Оно. Попробовал вчера - не помогает.

вторник, 30 сентября 2014 г., 14:54:24 UTC+4 пользователь user0ff написал:
>
> Не оно?
>
> http://stackoverflow.com/questions/1676688/php-mysql-connection-not-working-2002-no-such-file-or-directory
>
> 30 сентября 2014 г., 13:51 пользователь Antony Dovgal <
> to...@daylessday.org <javascript:>> написал:
>
>> On 09/30/2014 01:48 PM, Михаил Мальцев wrote:
>>
>>> Приветствую.
>>>
>>> Собрал php со следующими параметрами конфигурации
>>>
>>> ./configure' '--prefix=/usr/local/php-fpm5' '--enable-fpm'
>>> '--with-mcrypt' '--enable-mbstring' '--with-curl' '--disable-debug'
>>> '--disable-rpath' '--enable-inline-optimization' '--with-zlib'
>>> '--enable-sockets' '--enable-sysvsem' '--enable-sysvshm' '--enable-pcntl'
>>> '--enable-mbregex' '--with-mhash' '--enable-zip' '--with-pcre-regex'
>>> '--with-gd' '--with-mysql=mysqlnd' '--with-mysqli=mysqlnd'
>>> '--with-pdo-mysql=mysqlnd
>>>
>>> Добавил в init.d и прописал настройки в nginx.
>>>
>>> Все прекрасно работает за исключением соединения с MySql. При попытке
>>> соединения выдает 2002 ошибку (no File or Directory)
>>>
>>> В php.ini прописал путь к сокету, но тоже не помогает.
>>>
>>> Исчерпал идеи решения, может быть кто-то подскажет в каком направлении
>>> думать?
>>>
>>
>> Сокет для FPM доступен?
>> Через порт всё работает?
>>
>> --
>> Wbr,
>> Antony Dovgal
>> ---
>> http://pinba.org - realtime profiling for PHP
>>
>> --
>>
>> --- Вы получили это сообщение, поскольку подписаны на группу
>> highload-php-ru.
>>
>> Чтобы отменить подписку на эту группу и больше не получать от нее
>> сообщения, отправьте письмо на электронный адрес highload-php-...@
>> googlegroups.com <javascript:>.
>> Настройки подписки и доставки писем: https://groups.google.com/d/optout.
>>
>
>

--

---
Вы получили это сообщение, поскольку подписаны на группу highload-php-ru.

Чтобы отменить подписку на эту группу и больше не получать от нее сообщения, отправьте письмо на электронный адрес highload-php-ru+unsubscribe@googlegroups.com.
Настройки подписки и доставки писем: https://groups.google.com/d/optout.
On 09/30/2014 03:52 PM, Михаил Мальцев wrote:
> Сокет нет

Тогда как оно может работать?

> через порт работает php

Что?

> Но mysql в любом случае не коннектится.

Тут я вообще перестал понимать.

> Интересно что через php модуль apache все прекрасно соединяется.

PHP может ходить через unix socket, при обращении к "localhost" это происходит по-дефолту.
В этом случае сокет (который прописан в php.ini) должен быть ему доступен, конечно.

PHP может ходить через порт - это происходит, например, при обращении к 127.0.0.1 или др. IP-адресу.
Какой из вариантов не работает?
Какой в phpinfo() сокет? Что показывает echo `ls -l /path/to/socket` из PHP?

--
Wbr,
Antony Dovgal
---
http://pinba.org - realtime profiling for PHP

--

---
Вы получили это сообщение, поскольку подписаны на группу highload-php-ru.

Чтобы отменить подписку на эту группу и больше не получать от нее сообщения, отправьте письмо на электронный адрес highload-php-ru+unsubscribe@googlegroups.com.
Настройки подписки и доставки писем: https://groups.google.com/d/optout.
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 80
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready