Welcome! Log In Create A New Profile

Advanced

Установка двух и более версий PHP работающих как FPM/FastCGI

Posted by Anonymous User 
Что имеем: Ubuntu Server 12.04
установлен PHP 5.3.10 в связке fastcgi + php-fpm все из репов, в phpinfo
получаем
Server API FPM/FastCGI
Далее собираю из сорцов 5.2.17 с --enable-fpm, нактаываю патч 0.5.14
Получаю phpinfo
Server API CGI/FastCGI
но при этом:
php-fpm active
php-fpm version 0.5.14

как заставить работать с Server API FPM/FastCGI
P.S. И еще вопрос: в php5.3.10 конфиг пхп-фпм создан по типу ini файлов, в
версии 5.2.17 по типу xml. Как сделать конфиг файл в ini стиле?

--

---
Вы получили это сообщение, поскольку подписаны на группу highload-php-ru.

Чтобы отказаться от подписки на эту группу и перестать получать из нее сообщения, отправьте электронное письмо на адрес highload-php-ru+unsubscribe@googlegroups.com.
Подробнее о функциях можно узнать на странице https://groups.google.com/groups/opt_out.
в 5.2.17 версии php-fpm уже присутствует вроде и патчить не нужно..

5 февраля 2013 г., 15:06 пользователь <infinitum.lab@gmail.com> написал:

> Что имеем: Ubuntu Server 12.04
> установлен PHP 5.3.10 в связке fastcgi + php-fpm все из репов, в phpinfo
> получаем
> Server API FPM/FastCGI
> Далее собираю из сорцов 5.2.17 с --enable-fpm, нактаываю патч 0.5.14
> Получаю phpinfo
> Server API CGI/FastCGI
> но при этом:
> php-fpm active
> php-fpm version 0.5.14
>
> как заставить работать с Server API FPM/FastCGI
> P.S. И еще вопрос: в php5.3.10 конфиг пхп-фпм создан по типу ini файлов, в
> версии 5.2.17 по типу xml. Как сделать конфиг файл в ini стиле?
>
> --
>
> ---
> Вы получили это сообщение, поскольку подписаны на группу highload-php-ru.
>
> Чтобы отказаться от подписки на эту группу и перестать получать из нее
> сообщения, отправьте электронное письмо на адрес
> highload-php-ru+unsubscribe@googlegroups.com.
> Подробнее о функциях можно узнать на странице
> https://groups.google.com/groups/opt_out.
>
>
>

--

---
Вы получили это сообщение, поскольку подписаны на группу highload-php-ru.

Чтобы отказаться от подписки на эту группу и перестать получать из нее сообщения, отправьте электронное письмо на адрес highload-php-ru+unsubscribe@googlegroups.com.
Подробнее о функциях можно узнать на странице https://groups.google.com/groups/opt_out.
Нет, конфиг в ини стиле сделать нельзя.

Нет, в 5.2.17 еще нету fpm в комплекте, начиная с 5.3 сделали.

Для 5.2.17 нету патча чтобы строку Server API патчило, даже с работающим
fpm будет CGI/FastCGI.

И от 5.2.17 нужно отказыватся по мере сил.

2013/2/5 Шардик <dxpsite@gmail.com>

> в 5.2.17 версии php-fpm уже присутствует вроде и патчить не нужно..
>
> 5 февраля 2013 г., 15:06 пользователь <infinitum.lab@gmail.com> написал:
>
>> Что имеем: Ubuntu Server 12.04
>> установлен PHP 5.3.10 в связке fastcgi + php-fpm все из репов, в phpinfo
>> получаем
>> Server API FPM/FastCGI
>> Далее собираю из сорцов 5.2.17 с --enable-fpm, нактаываю патч 0.5.14
>> Получаю phpinfo
>> Server API CGI/FastCGI
>> но при этом:
>> php-fpm active
>> php-fpm version 0.5.14
>>
>> как заставить работать с Server API FPM/FastCGI
>> P.S. И еще вопрос: в php5.3.10 конфиг пхп-фпм создан по типу ini файлов,
>> в версии 5.2.17 по типу xml. Как сделать конфиг файл в ini стиле?
>>
>> --
>>
>> ---
>> Вы получили это сообщение, поскольку подписаны на группу highload-php-ru.
>>
>> Чтобы отказаться от подписки на эту группу и перестать получать из нее
>> сообщения, отправьте электронное письмо на адрес
>> highload-php-ru+unsubscribe@googlegroups.com.
>> Подробнее о функциях можно узнать на странице
>> https://groups.google.com/groups/opt_out.
>>
>>
>>
>
> --
>
> ---
> Вы получили это сообщение, поскольку подписаны на группу highload-php-ru.
>
> Чтобы отказаться от подписки на эту группу и перестать получать из нее
> сообщения, отправьте электронное письмо на адрес
> highload-php-ru+unsubscribe@googlegroups.com.
> Подробнее о функциях можно узнать на странице
> https://groups.google.com/groups/opt_out.
>
>
>

--

---
Вы получили это сообщение, поскольку подписаны на группу highload-php-ru.

Чтобы отказаться от подписки на эту группу и перестать получать из нее сообщения, отправьте электронное письмо на адрес highload-php-ru+unsubscribe@googlegroups.com.
Подробнее о функциях можно узнать на странице https://groups.google.com/groups/opt_out.
(y)


2013/2/5 Really Big Bug <bigbug@mafia.lv>

> Нет, конфиг в ини стиле сделать нельзя.
>
> Нет, в 5.2.17 еще нету fpm в комплекте, начиная с 5.3 сделали.
>
> Для 5.2.17 нету патча чтобы строку Server API патчило, даже с работающим
> fpm будет CGI/FastCGI.
>
> И от 5.2.17 нужно отказыватся по мере сил.
>
>
> 2013/2/5 Шардик <dxpsite@gmail.com>
>
>> в 5.2.17 версии php-fpm уже присутствует вроде и патчить не нужно..
>>
>> 5 февраля 2013 г., 15:06 пользователь <infinitum.lab@gmail.com> написал:
>>
>>> Что имеем: Ubuntu Server 12.04
>>> установлен PHP 5.3.10 в связке fastcgi + php-fpm все из репов, в phpinfo
>>> получаем
>>> Server API FPM/FastCGI
>>> Далее собираю из сорцов 5.2.17 с --enable-fpm, нактаываю патч 0.5.14
>>> Получаю phpinfo
>>> Server API CGI/FastCGI
>>> но при этом:
>>> php-fpm active
>>> php-fpm version 0.5.14
>>>
>>> как заставить работать с Server API FPM/FastCGI
>>> P.S. И еще вопрос: в php5.3.10 конфиг пхп-фпм создан по типу ini файлов,
>>> в версии 5.2.17 по типу xml. Как сделать конфиг файл в ini стиле?
>>>
>>> --
>>>
>>> ---
>>> Вы получили это сообщение, поскольку подписаны на группу highload-php-ru.
>>>
>>> Чтобы отказаться от подписки на эту группу и перестать получать из нее
>>> сообщения, отправьте электронное письмо на адрес
>>> highload-php-ru+unsubscribe@googlegroups.com.
>>> Подробнее о функциях можно узнать на странице
>>> https://groups.google.com/groups/opt_out.
>>>
>>>
>>>
>>
>> --
>>
>> ---
>> Вы получили это сообщение, поскольку подписаны на группу highload-php-ru.
>>
>> Чтобы отказаться от подписки на эту группу и перестать получать из нее
>> сообщения, отправьте электронное письмо на адрес
>> highload-php-ru+unsubscribe@googlegroups.com.
>> Подробнее о функциях можно узнать на странице
>> https://groups.google.com/groups/opt_out.
>>
>>
>>
>
> --
>
> ---
> Вы получили это сообщение, поскольку подписаны на группу highload-php-ru.
>
> Чтобы отказаться от подписки на эту группу и перестать получать из нее
> сообщения, отправьте электронное письмо на адрес
> highload-php-ru+unsubscribe@googlegroups.com.
> Подробнее о функциях можно узнать на странице
> https://groups.google.com/groups/opt_out.
>
>
>

--

---
Вы получили это сообщение, поскольку подписаны на группу highload-php-ru.

Чтобы отказаться от подписки на эту группу и перестать получать из нее сообщения, отправьте электронное письмо на адрес highload-php-ru+unsubscribe@googlegroups.com.
Подробнее о функциях можно узнать на странице https://groups.google.com/groups/opt_out.
Спасибо, а как правильно настраивать php-fpm.conf в версии 5.2? Там конфиг
в xml формате и у меня не получается настроить разные пулы для разных
пользователей! В версии php 5.3 в папке pool.d создавал файл и там
прописывал для каждого домена пользователя. В xml формате не получается.

Из документации шаблон выглядит так

<?xml version="1.0" ?>
<configuration>
<section name="global_options">
(Смотрите ниже раздел "Глобальные опции")
</section>

<workers>
<section name="pool"> (одна секция на пул)
(Смотрите ниже раздел "Опции секции")
</section>
</workers>


конструкция

<?xml version="1.0" ?>
<configuration>
<section name="global_options">
(Смотрите ниже раздел "Глобальные опции")
</section>

<workers>
<section name="pool"> (одна секция на пул)
(Смотрите ниже раздел "Опции секции")
</section>

<section name="pool"> (одна секция на пул)
(Смотрите ниже раздел "Опции секции")
</section>

</workers>


не работает.


Помогите разобраться с конфигами чтобы для каждого сайта можно было
создавать пулл и указывать пользователя

вторник, 5 февраля 2013 г., 19:12:42 UTC+6 пользователь Romans Heimanis
написал:
>
> Нет, конфиг в ини стиле сделать нельзя.
>
> Нет, в 5.2.17 еще нету fpm в комплекте, начиная с 5.3 сделали.
>
> Для 5.2.17 нету патча чтобы строку Server API патчило, даже с работающим
> fpm будет CGI/FastCGI.
>
> И от 5.2.17 нужно отказыватся по мере сил.
>
> 2013/2/5 Шардик <dxp...@gmail.com <javascript:>>
>
>> в 5.2.17 версии php-fpm уже присутствует вроде и патчить не нужно..
>>
>> 5 февраля 2013 г., 15:06 пользователь <infini...@gmail.com <javascript:>>написал:
>>
>>> Что имеем: Ubuntu Server 12.04
>>> установлен PHP 5.3.10 в связке fastcgi + php-fpm все из репов, в phpinfo
>>> получаем
>>> Server API FPM/FastCGI
>>> Далее собираю из сорцов 5.2.17 с --enable-fpm, нактаываю патч 0.5.14
>>> Получаю phpinfo
>>> Server API CGI/FastCGI
>>> но при этом:
>>> php-fpm active
>>> php-fpm version 0.5.14
>>>
>>> как заставить работать с Server API FPM/FastCGI
>>> P.S. И еще вопрос: в php5.3.10 конфиг пхп-фпм создан по типу ini файлов,
>>> в версии 5.2.17 по типу xml. Как сделать конфиг файл в ini стиле?
>>>
>>> --
>>>
>>> ---
>>> Вы получили это сообщение, поскольку подписаны на группу highload-php-ru.
>>>
>>> Чтобы отказаться от подписки на эту группу и перестать получать из нее
>>> сообщения, отправьте электронное письмо на адрес
>>> highload-php-...@googlegroups.com <javascript:>.
>>> Подробнее о функциях можно узнать на странице
>>> https://groups.google.com/groups/opt_out.
>>>
>>>
>>>
>>
>> --
>>
>> ---
>> Вы получили это сообщение, поскольку подписаны на группу highload-php-ru.
>>
>> Чтобы отказаться от подписки на эту группу и перестать получать из нее
>> сообщения, отправьте электронное письмо на адрес
>> highload-php-...@googlegroups.com <javascript:>.
>> Подробнее о функциях можно узнать на странице
>> https://groups.google.com/groups/opt_out.
>>
>>
>>
>
>

--

---
Вы получили это сообщение, поскольку подписаны на группу highload-php-ru.

Чтобы отказаться от подписки на эту группу и перестать получать из нее сообщения, отправьте электронное письмо на адрес highload-php-ru+unsubscribe@googlegroups.com.
Подробнее о функциях можно узнать на странице https://groups.google.com/groups/opt_out.
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 54
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready