Welcome! Log In Create A New Profile

Advanced

Разный версии php на pool это возможно ?

Posted by nokors 
Разный версии php на pool это возможно ?
November 08, 2012 09:08AM
Есть установленный и настроенный php 5.2.17 и php 5.3
Php 5.3 идет по умолчанию в ubuntu.Вопрос рода как можно прирутить
отдельную версию php к pooly ??
On 11/08/2012 02:58 PM, Nok Nok wrote:
> Есть установленный и настроенный php 5.2.17 и php 5.3
> Php 5.3 идет по умолчанию в ubuntu.Вопрос рода как можно прирутить
> отдельную версию php к pooly ??
Нет, нельзя.

А вот 2 разных демона - можно, на разных портах и сокетах. Правда на
5.2.17 фпм только в виде патча, с другим синтаксисом и функционалом.
Рекомендую вообще отказаться от 5.2 в пользу 5.3
09.11.2012 0:58 пользователь "Nok Nok" <nokors@gmail.com> написал:

> Есть установленный и настроенный php 5.2.17 и php 5.3
> Php 5.3 идет по умолчанию в ubuntu.Вопрос рода как можно прирутить
> отдельную версию php к pooly ??
>
Под 5.3 например ZendOptimizer не работает :(


2012/11/8 Anatoly Pashin <anatoly.pashin@gmail.com>

> Рекомендую вообще отказаться от 5.2 в пользу 5.3
> 09.11.2012 0:58 пользователь "Nok Nok" <nokors@gmail.com> написал:
>
> Есть установленный и настроенный php 5.2.17 и php 5.3
>> Php 5.3 идет по умолчанию в ubuntu.Вопрос рода как можно прирутить
>> отдельную версию php к pooly ??
>>
>
А ZendGuard Loader разве не оно?

2012/11/8 ColorPrint <cprint@gmail.com>

> Под 5.3 например ZendOptimizer не работает :(
>
>
> 2012/11/8 Anatoly Pashin <anatoly.pashin@gmail.com>
>
>> Рекомендую вообще отказаться от 5.2 в пользу 5.3
>> 09.11.2012 0:58 пользователь "Nok Nok" <nokors@gmail.com> написал:
>>
>> Есть установленный и настроенный php 5.2.17 и php 5.3
>>> Php 5.3 идет по умолчанию в ubuntu.Вопрос рода как можно прирутить
>>> отдельную версию php к pooly ??
>>>
>>
>
>
>
>
>
Скрипты, закодированные ZendOptimizer-ом, не будут работать с ZendGuard...


2012/11/8 Really Big Bug <bigbug@mafia.lv>

> А ZendGuard Loader разве не оно?
>
>
> 2012/11/8 ColorPrint <cprint@gmail.com>
>
>> Под 5.3 например ZendOptimizer не работает :(
>>
>>
>> 2012/11/8 Anatoly Pashin <anatoly.pashin@gmail.com>
>>
>>> Рекомендую вообще отказаться от 5.2 в пользу 5.3
>>> 09.11.2012 0:58 пользователь "Nok Nok" <nokors@gmail.com> написал:
>>>
>>> Есть установленный и настроенный php 5.2.17 и php 5.3
>>>> Php 5.3 идет по умолчанию в ubuntu.Вопрос рода как можно прирутить
>>>> отдельную версию php к pooly ??
>>>>
>>>
>>
>>
>>
>>
>>
>
Alexey V. Karagodov
Re: Разный версии php на pool это возможно ?
November 08, 2012 02:26PM
On 08.11.2012, at 20:37, ColorPrint <cprint@gmail.com> wrote:

> Скрипты, закодированные ZendOptimizer-ом, не будут работать с ZendGuard...
тогда у меня наверное на сайтах скрипты-мутанты
работают, что в гарде, что в оптимайзере

>
>
> 2012/11/8 Really Big Bug <bigbug@mafia.lv>
> А ZendGuard Loader разве не оно?
>
>
> 2012/11/8 ColorPrint <cprint@gmail.com>
> Под 5.3 например ZendOptimizer не работает :(
>
>
> 2012/11/8 Anatoly Pashin <anatoly.pashin@gmail.com>
> Рекомендую вообще отказаться от 5.2 в пользу 5.3
>
> 09.11.2012 0:58 пользователь "Nok Nok" <nokors@gmail.com> написал:
>
> Есть установленный и настроенный php 5.2.17 и php 5.3
> Php 5.3 идет по умолчанию в ubuntu.Вопрос рода как можно прирутить отдельную версию php к pooly ??
>
>
>
>
>
>
>
>
>
Вы немного запутались ZendOptimizer только расшифровывает скрипты сейчас он называется Zend Loader А вот ZendGuard какраз занимается шифрованием и обфускацией притом делает это по разному для php 5.2 и php 5.3 под какую версию шифровать выбирается в проекте ZendGuard. И да, то что зашифровано под 5.2 не будет работать под 5.3. Для того, чтобы заработало нужно перекодировать.
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 76
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready