Welcome! Log In Create A New Profile

Advanced

Произвольно обрывается отдача ответа в php-fpm.

Posted by nagual 
Произвольно обрывается отдача ответа в php-fpm. При этом из апача все
работает. Проблему заметил с 5.2.14, сейчас поставил 5.2.17 но
непомогло ...
Сорри нажал нечайно отправить.
Глюк проявляется в phpMyadmin и phpBB3 форуме. Во всех случаях в логе
код 200 а клиент может не получить ответ до конца ...

Первый открывает нормально:
/phpBB3/i.php HTTP/1.1" 200 48873 "-" "Mozilla/5.0 (Windows; U;
Windows NT 5.1; en-US) AppleWebKit/532.9 (KHTML, like Gecko) Iron/
4.0.280.0 Chrome/4.0.280.0 Safari/532.9"

При обновлении страницы получаю оборванный ответ:
"GET /phpBB3/i.php?=PHPE9568F35-D428-11d2-A769-00AA001ACF42 HTTP/1.1"
200 2158 "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/
532.9 (KHTML, like Gecko) Iron/4.0.280.0 Chrome/4.0.280.0 Safari/
532.9"

В данном случае контент
<?
phpinfo();
?>

On 15 янв, 15:38, nagual <victori...@gmail.com> wrote:
> Произвольно обрывается отдача ответа в php-fpm. При этом из апача все
> работает. Проблему заметил с 5.2.14, сейчас поставил 5.2.17 но
> непомогло ...
Я снифил траф на серве tcpdump и заметил что ответы уходят полностью,
а в опере они недорисованы. Даже незнаю куда копать.
Самое первое предположение о коротких тегах, попробуйте вывести контент
<?php
phpinfo();
?>

17 января 2011 г. 19:10 пользователь nagual <victoriy30@gmail.com> написал:

> Сорри нажал нечайно отправить.
> Глюк проявляется в phpMyadmin и phpBB3 форуме. Во всех случаях в логе
> код 200 а клиент может не получить ответ до конца ...
>
> Первый открывает нормально:
> /phpBB3/i.php HTTP/1.1" 200 48873 "-" "Mozilla/5.0 (Windows; U;
> Windows NT 5.1; en-US) AppleWebKit/532.9 (KHTML, like Gecko) Iron/
> 4.0.280.0 Chrome/4.0.280.0 Safari/532.9"
>
> При обновлении страницы получаю оборванный ответ:
> "GET /phpBB3/i.php?=PHPE9568F35-D428-11d2-A769-00AA001ACF42 HTTP/1.1"
> 200 2158 "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/
> 532.9 (KHTML, like Gecko) Iron/4.0.280.0 Chrome/4.0.280.0 Safari/
> 532.9"
>
> В данном случае контент
> <?
> phpinfo();
> ?>
>
> On 15 янв, 15:38, nagual <victori...@gmail.com> wrote:
> > Произвольно обрывается отдача ответа в php-fpm. При этом из апача все
> > работает. Проблему заметил с 5.2.14, сейчас поставил 5.2.17 но
> > непомогло ...
>



--
С уважением, Максим Камашев
<max.kamashev@gmail.com>
<? ?> специально включены в php.ini
Я во втором после про запросы ерунду написал. Второй запрос то пикча.
Я пробовал снифить tcpdump и выяснилось что уходит запрос полностью,
но опера получает обрывок. Что качается phpBB3 форума то бьются
ссылки. В конце концев ссылка превращается в
http://192.168.0.1/phpBB3/adm/index.php%3Fsid%3D6f488c363821fe92a11554e1864b7920?sid=12359907a32434f6ff528138a6322ea2
и я получаю 404
Вобщем глюк есть он неимеет постоянного характера и проявляется
произвольно.

On 18 янв, 10:06, Max Kamashev <max.kamas...@gmail.com> wrote:
> Самое первое предположение о коротких тегах, попробуйте вывести контент
> <?php
> phpinfo();
> ?>
>
> 17 января 2011 г. 19:10 пользователь nagual <victori...@gmail.com> написал:
>
>
>
>
>
> > Сорри нажал нечайно отправить.
> > Глюк проявляется в phpMyadmin и phpBB3 форуме. Во всех случаях в логе
> > код 200 а клиент может не получить ответ до конца ...
>
> > Первый открывает нормально:
> > /phpBB3/i.php HTTP/1.1" 200 48873 "-" "Mozilla/5.0 (Windows; U;
> > Windows NT 5.1; en-US) AppleWebKit/532.9 (KHTML, like Gecko) Iron/
> > 4.0.280.0 Chrome/4.0.280.0 Safari/532.9"
>
> > При обновлении страницы получаю оборванный ответ:
> > "GET /phpBB3/i.php?=PHPE9568F35-D428-11d2-A769-00AA001ACF42 HTTP/1.1"
> > 200 2158  "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/
> > 532.9 (KHTML, like Gecko) Iron/4.0.280.0 Chrome/4.0.280.0 Safari/
> > 532.9"
>
> > В данном случае контент
> > <?
> > phpinfo();
> > ?>
>
> > On 15 янв, 15:38, nagual <victori...@gmail.com> wrote:
> > > Произвольно обрывается отдача ответа в php-fpm. При этом из апача все
> > > работает. Проблему заметил с 5.2.14, сейчас поставил 5.2.17 но
> > > непомогло ...
>
> --
> С уважением, Максим Камашев
> <max.kamas...@gmail.com>
Тогда надо посмотреть на настройки nginx.

Включено ли сжатие? Попробуйте отключить, точно ли страницы отдаются
правильно, а браузеры их парсят не правильно?
Что указано в заголовках Range и Range-Content? Они вообще есть?

Вообщем нужно больше информации. Сейчас я могу считать что у вас либо опера
не работает (кстати, она контент получает напрямую или через оперную
прокси?), либо сервер не так отдаёт.

19 января 2011 г. 1:19 пользователь nagual <victoriy30@gmail.com> написал:

> <? ?> специально включены в php.ini
> Я во втором после про запросы ерунду написал. Второй запрос то пикча.
> Я пробовал снифить tcpdump и выяснилось что уходит запрос полностью,
> но опера получает обрывок. Что качается phpBB3 форума то бьются
> ссылки. В конце концев ссылка превращается в
>
> http://192.168.0.1/phpBB3/adm/index.php%3Fsid%3D6f488c363821fe92a11554e1864b7920?sid=12359907a32434f6ff528138a6322ea2
> и я получаю 404
> Вобщем глюк есть он неимеет постоянного характера и проявляется
> произвольно.
>
> On 18 янв, 10:06, Max Kamashev <max.kamas...@gmail.com> wrote:
> > Самое первое предположение о коротких тегах, попробуйте вывести контент
> > <?php
> > phpinfo();
> > ?>
> >
> > 17 января 2011 г. 19:10 пользователь nagual <victori...@gmail.com>
> написал:
> >
> >
> >
> >
> >
> > > Сорри нажал нечайно отправить.
> > > Глюк проявляется в phpMyadmin и phpBB3 форуме. Во всех случаях в логе
> > > код 200 а клиент может не получить ответ до конца ...
> >
> > > Первый открывает нормально:
> > > /phpBB3/i.php HTTP/1.1" 200 48873 "-" "Mozilla/5.0 (Windows; U;
> > > Windows NT 5.1; en-US) AppleWebKit/532.9 (KHTML, like Gecko) Iron/
> > > 4.0.280.0 Chrome/4.0.280.0 Safari/532.9"
> >
> > > При обновлении страницы получаю оборванный ответ:
> > > "GET /phpBB3/i.php?=PHPE9568F35-D428-11d2-A769-00AA001ACF42 HTTP/1.1"
> > > 200 2158 "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/
> > > 532.9 (KHTML, like Gecko) Iron/4.0.280.0 Chrome/4.0.280.0 Safari/
> > > 532.9"
> >
> > > В данном случае контент
> > > <?
> > > phpinfo();
> > > ?>
> >
> > > On 15 янв, 15:38, nagual <victori...@gmail.com> wrote:
> > > > Произвольно обрывается отдача ответа в php-fpm. При этом из апача все
> > > > работает. Проблему заметил с 5.2.14, сейчас поставил 5.2.17 но
> > > > непомогло ...
> >
> > --
> > С уважением, Максим Камашев
> > <max.kamas...@gmail.com>




--
С уважением, Максим Камашев
<max.kamashev@gmail.com>
Прежде всего никогда не отключайте сжатие. Некоторые яваскрипты и
прочее подобное получив инфу с серва сразу пытаются ее разжать. В
пхпадмине именно они. При включении сжатия глюк вроде проходит.
продолжаю тестирование.

On 19 янв, 09:35, Max Kamashev <max.kamas...@gmail.com> wrote:
> Тогда надо посмотреть на настройки nginx.
>
> Включено ли сжатие? Попробуйте отключить, точно ли страницы отдаются
> правильно, а браузеры их парсят не правильно?
> Что указано в заголовках Range и Range-Content? Они вообще есть?
>
> Вообщем нужно больше информации. Сейчас я могу считать что у вас либо опера
> не работает (кстати, она контент получает напрямую или через оперную
> прокси?), либо сервер не так отдаёт.
>
> 19 января 2011 г. 1:19 пользователь nagual <victori...@gmail.com> написал:
>
>
>
>
>
> > <? ?> специально включены в php.ini
> > Я во втором после про запросы ерунду написал. Второй запрос то пикча.
> > Я пробовал снифить tcpdump и выяснилось что уходит запрос полностью,
> > но опера получает обрывок. Что качается phpBB3 форума то бьются
> > ссылки. В конце концев ссылка превращается в
>
> >http://192.168.0.1/phpBB3/adm/index.php%3Fsid%3D6f488c363821fe92a1155...
> > и я получаю 404
> > Вобщем глюк есть он неимеет постоянного характера и проявляется
> > произвольно.
>
> > On 18 янв, 10:06, Max Kamashev <max.kamas...@gmail.com> wrote:
> > > Самое первое предположение о коротких тегах, попробуйте вывести контент
> > > <?php
> > > phpinfo();
> > > ?>
>
> > > 17 января 2011 г. 19:10 пользователь nagual <victori...@gmail.com>
> > написал:
>
> > > > Сорри нажал нечайно отправить.
> > > > Глюк проявляется в phpMyadmin и phpBB3 форуме. Во всех случаях в логе
> > > > код 200 а клиент может не получить ответ до конца ...
>
> > > > Первый открывает нормально:
> > > > /phpBB3/i.php HTTP/1.1" 200 48873 "-" "Mozilla/5.0 (Windows; U;
> > > > Windows NT 5.1; en-US) AppleWebKit/532.9 (KHTML, like Gecko) Iron/
> > > > 4.0.280.0 Chrome/4.0.280.0 Safari/532.9"
>
> > > > При обновлении страницы получаю оборванный ответ:
> > > > "GET /phpBB3/i.php?=PHPE9568F35-D428-11d2-A769-00AA001ACF42 HTTP/1.1"
> > > > 200 2158  "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/
> > > > 532.9 (KHTML, like Gecko) Iron/4.0.280.0 Chrome/4.0.280.0 Safari/
> > > > 532.9"
>
> > > > В данном случае контент
> > > > <?
> > > > phpinfo();
> > > > ?>
>
> > > > On 15 янв, 15:38, nagual <victori...@gmail.com> wrote:
> > > > > Произвольно обрывается отдача ответа в php-fpm. При этом из апача все
> > > > > работает. Проблему заметил с 5.2.14, сейчас поставил 5.2.17 но
> > > > > непомогло ...
>
> > > --
> > > С уважением, Максим Камашев
> > > <max.kamas...@gmail.com>
>
> --
> С уважением, Максим Камашев
> <max.kamas...@gmail.com>
2011/2/21 nagual <victoriy30@gmail.com>

> Некоторые яваскрипты и
> прочее подобное получив инфу с серва сразу пытаются ее разжать.
>

То есть вы хотите сказать, что кто-то реализовал gunzip/inflate на
яваскрипте да еще и использовал это в живом проекте? Крайне маловероятно.

Скорее уж у вас имеет место несоответствие заголовка Content-Length длине
ответа.

--
Best regards,
Bruce Weirdan mailto:
weirdan@gmail.com
Глюки начинаются с gzip off; в nginx.conf это факт.

On 21 фев, 23:55, Weirdan <weir...@gmail.com> wrote:
> 2011/2/21 nagual <victori...@gmail.com>
>
> > Некоторые яваскрипты и
> > прочее подобное получив инфу с серва сразу пытаются ее разжать.
>
> То есть вы хотите сказать, что кто-то реализовал gunzip/inflate на
> яваскрипте да еще и использовал это в живом проекте? Крайне маловероятно.
>
> Скорее уж у вас имеет место несоответствие заголовка Content-Length длине
> ответа.
>
> --
>   Best regards,
>       Bruce Weirdan                                     mailto:
> weir...@gmail.com
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 95
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready