Welcome! Log In Create A New Profile

Advanced

Собрать deb-пакет php-fpm

Posted by ArtRay 
ArtRay
Собрать deb-пакет php-fpm
October 15, 2009 05:48AM
Добрый день!

Нашел интересную статью, как собрать php-fpm.deb-пакет. Ссылка -
http://nomadrain.org/ru/node/35

Решил попробовать, но есть вопросы по поводу debian/rules-файл. Если
кто в курсе, подскажите pls.

Итак, все понятно, когда компилируешь через configure, make, make
install.

В моем случае configure_my файл будет выглядеть следующим образом (см.
ниже):
Примечания:
1. Строки, помеченные, как ## - опции, которые есть в debian/rules, но
которые мне не нужны)
2. CXXFLAGS присутствует на всякий случай, т.к. я не знаю применяется
ли с++ или нет для компиляции php.
3. Комент после после строки "--with-mysqli=/usr/bin/mysql_config",
"почему /usr/bin/mysql_config - ведь это sh-файл?" остается
актуальным. Если кто-то пояснит, скажу спасибо :)

== begin of file configure_my ==

#!/bin/sh

PROG_SENDMAIL=/usr/sbin/sendmail
CFLAGS="-O2 -march=native -fsigned-char -fexceptions -fstack-protector
\
--param=ssp-buffer-size=4 -fasynchronous-unwind-tables -fno-strict-
aliasing"
CXXFLAGS="-O2 -march=native -fsigned-char -fexceptions -fstack-
protector \
--param=ssp-buffer-size=4 -fasynchronous-unwind-tables"
DEB_HOST_GNU_TYPE=`dpkg-architecture -qDEB_HOST_GNU_TYPE`
DEB_BUILD_GNU_TYPE=`dpkg-architecture -qDEB_BUILD_GNU_TYPE`
MAGIC_MIME=/usr/share/file/magic.mime

COMMON_CONFIG="--build=$DEB_BUILD_GNU_TYPE \
--host=$DEB_HOST_GNU_TYPE \
--mandir=/usr/share/man \
--enable-memory-limit \
--disable-debug \
--with-regex=php \
--disable-rpath \
--disable-static \
--with-pic \
--with-layout=GNU \
--with-pear=/usr/share/php \
--enable-calendar \
--enable-sysvsem \
--enable-sysvshm \
--enable-sysvmsg \
--enable-trans-sid \
--enable-bcmath \
--with-bz2 \
--enable-ctype \
--with-db4 \
--without-gdbm \
--with-iconv \
--enable-exif \
--with-gettext \
--enable-mbstring \
--with-pcre-regex=/usr \
--enable-shmop \
--enable-sockets \
--with-libxml-dir=/usr \
--with-zlib \
--with-zlib-dir=/usr \
--with-openssl=/usr \
--enable-soap \
--enable-zip \
--with-mime-magic=$MAGIC_MIME \
--with-exec-dir=/usr/lib/php5/libexec \
--with-system-tzdata \
--enable-suhosin \
--disable-safe-mode \
\
--prefix=/usr \
\
--without-mm \
--without-sybase-ct --without-mssql --without-sqlite \
--sysconfdir=/etc/php5 \
--with-gd \
--enable-gd-native-ttf \
--with-jpeg-dir=/usr/lib \
--with-png-dir=/usr/lib \
--with-freetype-dir=/usr/lib \
--with-mhash=shared,/usr/lib \
--with-mysql=/usr/lib/mysql/lib \
--with-mysqli=/usr/bin/mysql_config \
## почему /usr/bin/mysql_config - ведь это sh-файл?
--enable-shared \
"

FPM_SUHOSIN_CONFIG="--enable-fastcgi --enable-fpm \
--with-fpm-conf=/etc/php-fpm.conf \
--with-fpm-log=/var/log/php-fpm.log \
--with-fpm-pid=/var/run/php-fpm.pid \
"

## - --enable-wddx \
## - --enable-ftp \
## - --enable-dbx \
## - --with-kerberos=/usr \
## - --enable-filepro \
## - --enable-track-vars \
## - --with-gmp=shared,/usr \
## --with-config-file-path=/etc/php5/cgi \
## --with-config-file-scan-dir=/etc/php5/cgi/conf.d \
## - --with-xpm-dir=shared,/usr/X11R6 \
## - --with-ttf # do not enable support for FreeType 1.x
## - --with-t1lib=shared,/usr # Postscript Type 1 fonts \
## - --with-ldap-sasl=/usr \
## - --with-pspell
## - --with-recode=shared,/usr \
## - --with-snmp=shared,/usr \
## - --with-sqlite=shared,/usr \
## - --with-mssql=shared,/usr \
## - --with-tidy=shared,/usr \
## - --with-xmlrpc=shared \
## - --with-pgsql=shared,
## /usr PGSQL_INCLUDE=`pg_config --includedir` \
## - --enable-pdo=shared \
## - --with-xsl=/usr/lib \
## - --without-pdo-dblib \
## - --with-pdo-mysql=shared,/usr \
## - --with-pdo-odbc=shared,unixODBC,/usr \
## - --with-pdo-pgsql=shared,/usr/bin/pg_config \
## - --with-pdo-sqlite=shared,/usr \
## - --with-pdo-dblib=shared,/usr
## - my -
## - --enable-pdo=shared \
## - --with-pdo-mysql=shared \
## - --with-pdo-sqlite=shared \
## - --with-unixODBC=/usr/lib \
## - --with-ncurses=/usr \
## - --with-config-file-scan-dir=/etc/php5/apache2/conf.d \
## - --with-apxs2=/usr/bin/apxs2 \

PHP_CONFIG=${COMMON_CONFIG}${FPM_SUHOSIN_CONFIG}

CXXFLAGS=$CXXFLAGS CFLAGS=$CFLAGS PROG_SENDMAIL=$PROG_SENDMAIL ./
configure $PHP_CONFIG

== end of file configure_my ==

Идем дальше и пробуем сделать deb, как написано http://nomadrain.org/ru/node/35

Делаем, все, как там написано, но опции нужно включить только те,
которые нужны (см. выше).

Вопрос - в каком месте и прописать в файле debian/rules?

В файле есть несколько секций, где задаются опции компиляции:

1. COMMON_CONFIG

С этой секцией все понятно, туда можно прописать общие опции
компиляции, в моем случае до опции --disable-safe-mode включительно.

2. Секция configure-apache2-stamp
Вопрос - что такое apache2-stamp. Можно ли ее вообще выбросить, если
вместо apache используется nginx?

3. Секция configure-apache2filter-stamp
Вопрос - чем отличается от configure-apache2-stamp, можно ли без нее
обойтись?

4. Секция configure-cgi-stamp
Похоже, это то, что нам больше всего нужно.
К опциям этой секции логично добавляем:
--enable-fastcgi --enable-fpm \
--with-fpm-conf=/etc/php-fpm.conf \
--with-fpm-log=/var/log/php-fpm.log \
--with-fpm-pid=/var/run/php-fpm.pid \
Дальше идет $(COMMON_CONFIG) \
А дальше не понятно:
В опциях ниже стоит --without-mysql? Mysql мне нужен!

Кто собирал deb-пакеты, проясните пожалуйста ситуацию в следующих
моментах:

1. Можно ли обойтись без секций configure-apache2-stamp и configure-
apache2filter-stamp?

2. Как их исключить из пакета?

3. Если их исключить, то куда правильнее дописать оставшиеся опции
компиляции, в моем случае следующие:
--prefix=/usr \
\
--without-mm \
--without-sybase-ct --without-mssql --without-sqlite \
--sysconfdir=/etc/php5 \
--with-gd \
--enable-gd-native-ttf \
--with-jpeg-dir=/usr/lib \
--with-png-dir=/usr/lib \
--with-freetype-dir=/usr/lib \
--with-mhash=shared,/usr/lib \
--with-mysql=/usr/lib/mysql/lib \
--with-mysqli=/usr/bin/mysql_config \

3. Если их оставлять, то не придется ли потом устанавливать не нужный
apache?

4. Если их оставлять, то куда прописывать правильнее оставшиеся опции
компиляции (см. выше)?

Заранее спасибо!
Re: Собрать deb-пакет php-fpm
October 17, 2009 03:42PM
Hello,

Here is my GIT repository with /debian changes.
Its for ubuntu ppa (9.10 karmic). To add the fpm-build target.

Do this:

mkdir tmp && cd tmp
git clone git://github.com/dreamcat4/php5-5.2.10.dfsg.1.git
cp -Rf php5-5.2.10.dfsg.1 php5-dreamcat4
cd php5-5.2.10.dfsg.1
git checkout 93a7d8b2cddb4ddb9ebe7fdc5432cca75e460de8
cd ..
cp -Rf php5-5.2.10.dfsg.1 php5-clean
rm -rf php5-5.2.10.dfsg.1

aptitude install -y meld
meld "php5-clean/" "php5-dreamcat4/"



Best regards,

dreamcat4
dreamcat4@gmail.com


2009/10/15 ArtRay <tvword@gmail.com>:
> Добрый день!
>
> Нашел интересную статью, как собрать php-fpm.deb-пакет. Ссылка -
> http://nomadrain.org/ru/node/35
>
> Решил попробовать, но есть вопросы по поводу debian/rules-файл. Если
> кто в курсе, подскажите pls.
>
> Итак, все понятно, когда компилируешь через configure, make, make
> install.
>
> В моем случае configure_my файл будет выглядеть следующим образом (см.
> ниже):
> Примечания:
> 1. Строки, помеченные, как ## - опции, которые есть в debian/rules, но
> которые мне не нужны)
> 2. CXXFLAGS присутствует на всякий случай, т.к. я не знаю применяется
> ли с++ или нет для компиляции php.
> 3. Комент после  после строки  "--with-mysqli=/usr/bin/mysql_config",
> "почему  /usr/bin/mysql_config - ведь это sh-файл?" остается
> актуальным. Если кто-то пояснит, скажу спасибо :)
>
> == begin of file configure_my ==
>
> #!/bin/sh
>
> PROG_SENDMAIL=/usr/sbin/sendmail
> CFLAGS="-O2 -march=native -fsigned-char -fexceptions -fstack-protector
> \
> --param=ssp-buffer-size=4 -fasynchronous-unwind-tables -fno-strict-
> aliasing"
> CXXFLAGS="-O2 -march=native -fsigned-char -fexceptions -fstack-
> protector \
> --param=ssp-buffer-size=4 -fasynchronous-unwind-tables"
> DEB_HOST_GNU_TYPE=`dpkg-architecture -qDEB_HOST_GNU_TYPE`
> DEB_BUILD_GNU_TYPE=`dpkg-architecture -qDEB_BUILD_GNU_TYPE`
> MAGIC_MIME=/usr/share/file/magic.mime
>
> COMMON_CONFIG="--build=$DEB_BUILD_GNU_TYPE \
>                --host=$DEB_HOST_GNU_TYPE \
>                --mandir=/usr/share/man \
>                --enable-memory-limit \
>                --disable-debug \
>                --with-regex=php \
>                --disable-rpath \
>                --disable-static \
>                --with-pic \
>                --with-layout=GNU \
>                --with-pear=/usr/share/php \
>                --enable-calendar \
>                --enable-sysvsem \
>                --enable-sysvshm \
>                --enable-sysvmsg \
>                --enable-trans-sid \
>                --enable-bcmath \
>                --with-bz2 \
>                --enable-ctype \
>                --with-db4 \
>                --without-gdbm \
>                --with-iconv \
>                --enable-exif \
>                --with-gettext \
>                --enable-mbstring \
>                --with-pcre-regex=/usr \
>                --enable-shmop \
>                --enable-sockets \
>                --with-libxml-dir=/usr \
>                --with-zlib \
>                --with-zlib-dir=/usr \
>                --with-openssl=/usr \
>                --enable-soap \
>                --enable-zip \
>                --with-mime-magic=$MAGIC_MIME \
>                --with-exec-dir=/usr/lib/php5/libexec \
>                --with-system-tzdata \
>                --enable-suhosin \
>                --disable-safe-mode \
>                \
>                --prefix=/usr \
>                \
>                --without-mm \
>                --without-sybase-ct --without-mssql --without-sqlite \
>                --sysconfdir=/etc/php5 \
>                --with-gd \
>                --enable-gd-native-ttf \
>                --with-jpeg-dir=/usr/lib \
>                --with-png-dir=/usr/lib \
>                --with-freetype-dir=/usr/lib \
>                --with-mhash=shared,/usr/lib \
>                --with-mysql=/usr/lib/mysql/lib \
>                --with-mysqli=/usr/bin/mysql_config \
> ## почему /usr/bin/mysql_config - ведь это sh-файл?
>                --enable-shared \
>                "
>
> FPM_SUHOSIN_CONFIG="--enable-fastcgi --enable-fpm \
>                --with-fpm-conf=/etc/php-fpm.conf \
>                --with-fpm-log=/var/log/php-fpm.log \
>                --with-fpm-pid=/var/run/php-fpm.pid \
>                "
>
> ## -            --enable-wddx \
> ## -            --enable-ftp \
> ## -            --enable-dbx \
> ## -            --with-kerberos=/usr \
> ## -            --enable-filepro \
> ## -            --enable-track-vars \
> ## -            --with-gmp=shared,/usr \
> ##              --with-config-file-path=/etc/php5/cgi \
> ##              --with-config-file-scan-dir=/etc/php5/cgi/conf.d \
> ## -            --with-xpm-dir=shared,/usr/X11R6 \
> ## -            --with-ttf # do not enable support for FreeType 1.x
> ## -            --with-t1lib=shared,/usr # Postscript Type 1 fonts \
> ## -            --with-ldap-sasl=/usr \
> ## -            --with-pspell
> ## -            --with-recode=shared,/usr \
> ## -            --with-snmp=shared,/usr \
> ## -            --with-sqlite=shared,/usr \
> ## -            --with-mssql=shared,/usr \
> ## -            --with-tidy=shared,/usr \
> ## -            --with-xmlrpc=shared \
> ## -            --with-pgsql=shared,
> ##              /usr PGSQL_INCLUDE=`pg_config --includedir` \
> ## -            --enable-pdo=shared \
> ## -            --with-xsl=/usr/lib \
> ## -            --without-pdo-dblib \
> ## -            --with-pdo-mysql=shared,/usr \
> ## -            --with-pdo-odbc=shared,unixODBC,/usr \
> ## -            --with-pdo-pgsql=shared,/usr/bin/pg_config \
> ## -            --with-pdo-sqlite=shared,/usr \
> ## -            --with-pdo-dblib=shared,/usr
> ## -            my -
> ## -            --enable-pdo=shared \
> ## -            --with-pdo-mysql=shared \
> ## -            --with-pdo-sqlite=shared \
> ## -            --with-unixODBC=/usr/lib \
> ## -            --with-ncurses=/usr \
> ## -            --with-config-file-scan-dir=/etc/php5/apache2/conf.d \
> ## -            --with-apxs2=/usr/bin/apxs2 \
>
> PHP_CONFIG=${COMMON_CONFIG}${FPM_SUHOSIN_CONFIG}
>
> CXXFLAGS=$CXXFLAGS CFLAGS=$CFLAGS PROG_SENDMAIL=$PROG_SENDMAIL ./
> configure $PHP_CONFIG
>
> == end of file configure_my ==
>
> Идем дальше и пробуем сделать deb, как написано http://nomadrain.org/ru/node/35
>
> Делаем, все, как там написано, но опции нужно включить только те,
> которые нужны (см. выше).
>
> Вопрос - в каком месте и прописать в файле debian/rules?
>
> В файле есть несколько секций, где задаются опции компиляции:
>
> 1. COMMON_CONFIG
>
> С этой секцией все понятно, туда можно прописать общие опции
> компиляции, в моем случае до опции --disable-safe-mode включительно.
>
> 2. Секция configure-apache2-stamp
> Вопрос - что такое apache2-stamp. Можно ли ее вообще выбросить, если
> вместо apache используется nginx?
>
> 3. Секция configure-apache2filter-stamp
> Вопрос - чем отличается от  configure-apache2-stamp, можно ли без нее
> обойтись?
>
> 4. Секция configure-cgi-stamp
> Похоже, это то, что нам больше всего нужно.
> К опциям этой секции логично добавляем:
>               --enable-fastcgi --enable-fpm \
>                --with-fpm-conf=/etc/php-fpm.conf \
>                --with-fpm-log=/var/log/php-fpm.log \
>                --with-fpm-pid=/var/run/php-fpm.pid \
> Дальше идет  $(COMMON_CONFIG) \
> А дальше не понятно:
> В опциях ниже стоит --without-mysql? Mysql мне нужен!
>
> Кто собирал deb-пакеты, проясните пожалуйста ситуацию в следующих
> моментах:
>
> 1. Можно ли обойтись без секций configure-apache2-stamp и configure-
> apache2filter-stamp?
>
> 2. Как их исключить из пакета?
>
> 3. Если их исключить, то куда правильнее дописать оставшиеся опции
> компиляции, в моем случае следующие:
>                --prefix=/usr \
>                \
>                --without-mm \
>                --without-sybase-ct --without-mssql --without-sqlite \
>                --sysconfdir=/etc/php5 \
>                --with-gd \
>                --enable-gd-native-ttf \
>                --with-jpeg-dir=/usr/lib \
>                --with-png-dir=/usr/lib \
>                --with-freetype-dir=/usr/lib \
>                --with-mhash=shared,/usr/lib \
>                --with-mysql=/usr/lib/mysql/lib \
>                --with-mysqli=/usr/bin/mysql_config \
>
> 3. Если их оставлять, то не придется ли потом устанавливать не нужный
> apache?
>
> 4. Если их оставлять, то куда прописывать правильнее оставшиеся опции
> компиляции (см. выше)?
>
> Заранее спасибо!
>
>
>
ArtRay
Re: Собрать deb-пакет php-fpm
October 17, 2009 04:08PM
> Here is my GIT repository with /debian changes.
Thank you, dreamcat!
Re: Собрать deb-пакет php-fpm
October 17, 2009 04:40PM
You are welcome.

2009/10/17 ArtRay <tvword@gmail.com>:
>
>> Here is my GIT repository with /debian changes.
> Thank you, dreamcat!
>
>
kay
Re: Собрать deb-пакет php-fpm
October 22, 2009 05:16AM
Собрали deb пакет? Можете в репозиторий выложить?
Vladislav Vladimirovich
Re: Собрать deb-пакет php-fpm
October 22, 2009 05:38AM
>
> Собрали deb пакет? Можете в репозиторий выложить?


В репозиторий, думаю, мой deb-пакет не потянет, но зато могу подробно
рассказать, как я его сделал.

А сделал я его через checkinstall. Положительный момент в том, что 1) к
этому php-fpm-пакету применены все debian-патчи по безопасности и ошибкам 2)
и что его можно устанавливать и удалять через dpkg, а также смотреть список
файлов, которые вошли в пакет. Минус в том, что это все-таки checkinstall и
автоматизировать обновления пакета через apt-get install пока невозможно,
разве что через специальные скрипты-надстройки.

Последовательность действий:

1. Получаем все, что нужно для компиляции debian-php - исходники и
вспомогательные файлы

# $apt-get build-dep php5
# $apt-get source php5
(применяйте команду dpkg-source -x php5-вер-си-я.dsc, если все файлы уже
есть, но нужно заново распаковать все архивы с наложением dsc-файла)

# $cd php5-вер-си-я

2. Скачиваем php-fpm-патч для соответствующей вер-си-и php с
http://php-fpm.org/Download

В моем случае - php-5.2.6-fpm-0.5.9.diff.gz

3. Скачиваем suhosin-патч для соответствующей вер-си-и php с
http://www.hardened-php.net/suhosin/download.html

В моем случае - suhosin-patch-5.2.6-0.9.6.2.patch.gz

4. Разархивируем патчи и переместим их в специальную папку всех
debian'овский патчей debian/patches:

# gunzip php-5.2.6-fpm-0.5.9.diff.gz suhosin-patch-5.2.6-0.9.6.2.patch.gz

# mv {php-5.2.6-fpm-0.5.9.diff,suhosin-patch-5.2.6-0.9.6.2.patch}
debian/patches/

5. Нужно подкорректировать файл, со списком всех патчей -
debian/patches/series. Вместо строки suhosin.patch нужно вставить названия
наших двух патчей - php-5.2.6-fpm-0.5.9.diff и
suhosin-patch-5.2.6-0.9.6.2.patch.

# vi debian/patches/series
команды vi:
/suhosin
dd
O
php-5.2.6-fpm-0.5.9.diff
suhosin-patch-5.2.6-0.9.6.2.patch
:wq

Получим примерно следующий debian/patches/series-файл:

001-libtool_fixes.patch
002-static_openssl.patch
004-ldap_fix.patch
006-debian_quirks.patch
013-force_getaddrinfo.patch
017-pread_pwrite_disable.patch
019-z_off_t_as_long.patch
029-php.ini_paranoid.patch
#033-we_WANT_libtool.patch
034-apache2_umask_fix.patch
036-fd_setsize_fix.patch
043-recode_size_t.patch
044-strtod_arm_fix.patch
045-exif_nesting_level.patch
047-zts_with_dl.patch
052-phpinfo_no_configure.patch
053-extension_api.patch
056-mime_magic_liberal.patch
057-no_apache_installed.patch
100-recode_is_shared.patch
101-sqlite_is_shared.patch
107-reflection_is_ext.patch
108-64_bit_datetime.patch
112-proc_open.patch
113-php.ini_securitynotes.patch
disable_dl_by_default.patch
libdb_is_-ldb
php-5.2.6-fpm-0.5.9.diff
suhosin-patch-5.2.6-0.9.6.2.patch
fix_broken_upstream_tests.patch
use-specific-libdb-version.patch
use_embedded_timezonedb.patch
manpage_spelling.patch
force_libmysqlclient_r.patch
119-sybase-alias.patch
CVE-2008-2829.patch
libedit_is_editline.patch
fix-pecl-libtool.patch
bad_whatis_entries.patch
gentoo/freetds-compat.patch
snmp_leaks.patch
CVE-2008-3658.patch
CVE-2008-3659.patch
CVE-2008-3660.patch
BG-initializing-fix.patch
CVE-2008-5557.patch
pdo-fetchobject-prototype-error.patch
zend_object_handlers-invalid-write.patch
dba-inifile-truncation.patch
gentoo/010_ticks-zts-crashes.patch
gentoo/019_new-memory-corruption.patch
gentoo/009_array-function-crashes.patch
gentoo/015_CVE-2008-2665-wrapper-safemode-bypass.patch
gentoo/017_xmlrpc-invalid-callback-crash.patch
gentoo/007_dom-setAttributeNode-crash.patch
gentoo/006_PDORow-crash.patch
gentoo/005_stream_context_set_params-crash.patch
CVE-2008-5658.patch
fix-autoconf-ftbfs.patch
fix-segfault-in-openssl.patch
CVE-2008-5625.patch
CVE-2009-0754.patch
CVE-2008-5814.patch
CVE-2009-1271.patch
CVE-2009-2687.patch

6. Накладываем все патчи

# export QUILT_PATCHES=debian/patches
# quilt push -a
(если нет программы quilt, предварительно ставим ее - sudo apt-get install
quilt)

7. Выходим на стандартную последовательность configure, make, make install,
где вместо make install выполняем checkinstall -D

# ./configure_my
# make
# sudo checkinstall -D

Файл configure_my:

== begin of configure_my file ==
#!/bin/sh

PROG_SENDMAIL=/usr/sbin/sendmail
CFLAGS="-O2 -march=native -fsigned-char -fexceptions -fstack-protector \
--param=ssp-buffer-size=4 -fasynchronous-unwind-tables -fno-strict-aliasing"
CXXFLAGS="-O2 -march=native -fsigned-char -fexceptions -fstack-protector \
--param=ssp-buffer-size=4 -fasynchronous-unwind-tables"
DEB_HOST_GNU_TYPE=`dpkg-architecture -qDEB_HOST_GNU_TYPE`
DEB_BUILD_GNU_TYPE=`dpkg-architecture -qDEB_BUILD_GNU_TYPE`
MAGIC_MIME=/usr/share/file/magic.mime

COMMON_CONFIG="--build=$DEB_BUILD_GNU_TYPE \
--host=$DEB_HOST_GNU_TYPE \
--with-config-file-path=/etc/php5 \
--mandir=/usr/share/man \
--enable-memory-limit \
--disable-debug \
--with-regex=php \
--disable-rpath \
--disable-static \
--with-pic \
--with-layout=GNU \
--with-pear=/usr/share/php \
--enable-calendar \
--enable-sysvsem \
--enable-sysvshm \
--enable-sysvmsg \
--enable-trans-sid \
--enable-bcmath \
--with-bz2=/usr/lib \
--enable-ctype \
--without-gdbm \
--with-iconv \
--enable-exif \
--with-gettext \
--enable-mbstring \
--with-pcre-regex=/usr \
--enable-shmop \
--enable-sockets \
--with-libxml-dir=/usr/lib \
--with-zlib \
--with-zlib-dir=/usr/lib \
--with-openssl=/usr \
--enable-soap \
--enable-zip \
--with-mime-magic=$MAGIC_MIME \
--with-exec-dir=/usr/lib/php5/libexec \
--with-system-tzdata \
--enable-suhosin \
--disable-safe-mode \
\
--prefix=/usr \
\
--without-mm \
--without-sybase-ct --without-mssql --without-sqlite \
--sysconfdir=/etc/php5 \
--with-gd \
--enable-gd-native-ttf \
--with-jpeg-dir=/usr/lib \
--with-png-dir=/usr/lib \
--with-freetype-dir=/usr/lib \
--with-mhash=shared,/usr/lib \
--with-mysql=/usr/lib/mysql/lib \
--with-mysqli=/usr/bin/mysql_config \
--enable-shared
"
## почему /usr/bin/mysql_config - ведь это sh-файл?

FPM_SUHOSIN_CONFIG="--enable-fastcgi --enable-fpm \
--with-fpm-conf=/etc/php5/php-fpm.conf \
--with-fpm-log=/var/log/php-fpm.log \
--with-fpm-pid=/var/run/php-fpm.pid \
"

## - --enable-wddx \
## - --enable-ftp \
## - --enable-dbx \
## - --with-kerberos=/usr \
## - --enable-filepro \
## - --enable-track-vars \
## - --with-gmp=shared,/usr \
## --with-config-file-path=/etc/php5/cgi \
## --with-config-file-scan-dir=/etc/php5/cgi/conf.d \
## - --with-xpm-dir=shared,/usr/X11R6 \
## - --with-ttf # do not enable support for FreeType 1.x
## - --with-t1lib=shared,/usr # Postscript Type 1 fonts \
## - --with-ldap-sasl=/usr \
## - --with-pspell
## - --with-recode=shared,/usr \
## - --with-snmp=shared,/usr \
## - --with-sqlite=shared,/usr \
## - --with-mssql=shared,/usr \
## - --with-tidy=shared,/usr \
## - --with-xmlrpc=shared \
## - --with-pgsql=shared,
## /usr PGSQL_INCLUDE=`pg_config --includedir` \
## - --enable-pdo=shared \
## - --with-xsl=/usr/lib \
## - --without-pdo-dblib \
## - --with-pdo-mysql=shared,/usr \
## - --with-pdo-odbc=shared,unixODBC,/usr \
## - --with-pdo-pgsql=shared,/usr/bin/pg_config \
## - --with-pdo-sqlite=shared,/usr \
## - --with-pdo-dblib=shared,/usr
## - my -
## - --enable-pdo=shared \
## - --with-pdo-mysql=shared \
## - --with-pdo-sqlite=shared \
## - --with-unixODBC=/usr/lib \
## - --with-ncurses=/usr \
## - --with-config-file-scan-dir=/etc/php5/apache2/conf.d \
## - --with-apxs2=/usr/bin/apxs2 \
## - --with-db4 \

PHP_CONFIG=${COMMON_CONFIG}${FPM_SUHOSIN_CONFIG}

CFLAGS=$CFLAGS CXXFLAGS=$CXXFLAGS PROG_SENDMAIL=$PROG_SENDMAIL ./configure
$PHP_CONFIG

== end of configure_my file ==

Не забываем chmod +x configure_my

Примечания:
1. Опция -march=native в CFLAGS - только для GCC >= 4.2 автоматически
определяет возможности процессора по /proc/cpuinfo
2. Некоторые ошибки, которые могут возникнуть по выполнению configure и
способы их устранения -

-- error: xml2-config not found.
# sudo apt-get install libxml2-dev

-- error: Cannot find OpenSSL's <evp.h>
# sudo apt-get install libcurl4-openssl-dev
в configure_my файл должна быть опция --with-openssl=/usr (без продолжения
после /usr)

--error: Please reinstall the BZip2 distribution
# sudo apt-get install libbz2-dev

--error: libjpeg.(a|so) not found.
# sudo apt-get install libjpeg62-dev

--error: freetype.h not found.
# sudo apt-get install libfreetype6-dev

--error: libmhash - I cannot find mhash.h
# sudo apt-get install libmhash-dev

Не знаю почему, но после успешного выполнения configure появляются следующие
предупреждения:

Notice: Following unknown configure options were used:
--enable-memory-limit
--enable-trans-sid
--with-system-tzdata
--enable-suhosin

Просто пропускаем их.

В результате выполнения команды sudo checkinstall -D будет собран и СРАЗУ
установлен deb-пакет, который в моем случае называется
php5_5.2.6.dfsg.1-1_i386.deb.

Удалить пакет можно командой -
# sudo dpkg -r php5

Посмотреть содержимое deb пакета -
# dpkg -c php5_5.2.6.dfsg.1-1_i386.deb

Посмотреть список файлов, установленных в систему из пакета -
# dpkg -L php5
kay
Re: Собрать deb-пакет php-fpm
October 22, 2009 05:52AM
Большое спасибо за инструкцию

On Oct 22, 1:36 pm, Vladislav Vladimirovich <tvw...@gmail.com> wrote:
> > Собрали deb пакет? Можете в репозиторий выложить?
>
> В репозиторий, думаю, мой deb-пакет не потянет, но зато могу подробно
> рассказать, как я его сделал.
> ...
kay
Re: Собрать deb-пакет php-fpm
October 22, 2009 05:56AM
Кстати, как правильно создавать пакет именно для репозитория? Что же
касается последнего патча 0.6.0, то он требует обновленной библиотеки
libevent для debian. Как её прикрутить к репозиторию?

On Oct 22, 1:36 pm, Vladislav Vladimirovich <tvw...@gmail.com> wrote:
> > Собрали deb пакет? Можете в репозиторий выложить?
>
> В репозиторий, думаю, мой deb-пакет не потянет, но зато могу подробно
> рассказать, как я его сделал.
Re: Собрать deb-пакет php-fpm
October 22, 2009 09:50AM
BTW the 0.6 FPM are all tested for at least php version 5.2.10. We
don't know if it works for previous versions (php-5.2.6). But you are
welcome to try.

For libevent you can either:

1) compile statically the libevent. This is the default setting.
2) Write in the control file a package dependancy for libevent (ubuntu
9.10 karmic)


2009/10/22 kay <kay.diam@gmail.com>:
> Кстати, как правильно создавать пакет именно для репозитория? Что же
> касается последнего патча 0.6.0, то он требует обновленной библиотеки
> libevent для debian. Как её прикрутить к репозиторию?
>
> On Oct 22, 1:36 pm, Vladislav Vladimirovich <tvw...@gmail.com> wrote:
>> > Собрали deb пакет? Можете в репозиторий выложить?
>>
>> В репозиторий, думаю, мой deb-пакет не потянет, но зато могу подробно
>> рассказать, как я его сделал.
>
kay
Re: Собрать deb-пакет php-fpm
October 24, 2009 05:00AM
Could you please make a workable repository for Debian Lenny? Not
Ubuntu, as we don't use Ubuntu for production servers.

On Oct 22, 3:32 pm, dreamcat four <dreamc...@gmail.com> wrote:
> BTW the 0.6 FPM are all tested for at least php version 5.2.10. We
> don't know if it works for previous versions (php-5.2.6). But you are
> welcome to try.
>
> For libevent you can either:
>
> 1) compile statically the libevent. This is the default setting.
> 2) Write in the control file a package dependancy for libevent (ubuntu
> 9.10 karmic)
>
> 2009/10/22 kay <kay.d...@gmail.com>:
>
>
>
> > Кстати, как правильно создавать пакет именно для репозитория? Что же
> > касается последнего патча 0.6.0, то он требует обновленной библиотеки
> > libevent для debian. Как её прикрутить к репозиторию?
>
> > On Oct 22, 1:36 pm, Vladislav Vladimirovich <tvw...@gmail.com> wrote:
> >> > Собрали deb пакет? Можете в репозиторий выложить?
>
> >> В репозиторий, думаю, мой deb-пакет не потянет, но зато могу подробно
> >> рассказать, как я его сделал.
Re: Собрать deb-пакет php-fpm
October 24, 2009 08:46AM
No because thats the job for a debian package maintainer and we are
the upstream project here. You are welcome to use our mailinglist to
discuss such efforts however.

2009/10/24 kay <kay.diam@gmail.com>:
> Could you please make a workable repository for Debian Lenny? Not
> Ubuntu, as we don't use Ubuntu for production servers.
>
> On Oct 22, 3:32 pm, dreamcat four <dreamc...@gmail.com> wrote:
>> BTW the 0.6 FPM are all tested for at least php version 5.2.10. We
>> don't know if it works for previous versions (php-5.2.6). But you are
>> welcome to try.
>>
>> For libevent you can either:
>>
>> 1) compile statically the libevent. This is the default setting.
>> 2) Write in the control file a package dependancy for libevent (ubuntu
>> 9.10 karmic)
>>
>> 2009/10/22 kay <kay.d...@gmail.com>:
>>
>>
>>
>> > Кстати, как правильно создавать пакет именно для репозитория? Что же
>> > касается последнего патча 0.6.0, то он требует обновленной библиотеки
>> > libevent для debian. Как её прикрутить к репозиторию?
>>
>> > On Oct 22, 1:36 pm, Vladislav Vladimirovich <tvw...@gmail.com> wrote:
>> >> > Собрали deb пакет? Можете в репозиторий выложить?
>>
>> >> В репозиторий, думаю, мой deb-пакет не потянет, но зато могу подробно
>> >> рассказать, как я его сделал.
ssv
Re: Собрать deb-пакет php-fpm
October 30, 2009 10:15AM
Почитав данную тему, а также:
www.debian.org/doc/maint-guide/index.ru.html#contents
nomadrain.org/ru/node/35

Поступил следующим образом:

1) $apt-get build-dep php5
2) переходим в созданную нами заранее папку для сборки пакетов, после чего
$apt-get source php5, или dpkg-source -x php5-вер-си-я.dsc (читаем выше в этой теме)
3) cd php5-вер-си-я
4) Куда нибудь скачиваем отсюда http://php-fpm.org/downloads/ патч для нужной версии, распаковываем, перемещаем в debian/patches/
Правим debian/patches/series - добавляем туда строку с названием патча, например, php-5.2.6-fpm-0.5.9.diff. Suhosin уже успешно добавлен мейнтейнерами debian'a, так что его я не трогал.
5) Правим:
debian/rules
Меня хватило на добавления строки --enable-fpm в цели configure-cgi-stamp
В цели install можно добавить установку php-fpm.conf и rc-скрипта(как это сделать написано у nomadrain), я этого не делал (следовательно после установки пакета нужно самостоятельно позаботится о них).
6) dch -i
7) dpkg-buildpackage -sa
Если все пройдет успешно, у меня случилось именно так, то в ../ вы получите примерно следующую картину:
ssv@XXX:~/debian/php5-fpm/php5-5.2.6.dfsg.1$ ls -alh ../
total 35M
drwxr-xr-x 4 ssv ssv 4.0K 2009-10-29 14:53 .
drwxr-xr-x 4 ssv ssv 4.0K 2009-10-30 11:39 ..
-rw-r--r-- 1 ssv ssv 2.5M 2009-10-29 14:32 libapache2-mod-php5_5.2.6.dfsg.1-1+lenny4_amd64.deb
-rw-r--r-- 1 ssv ssv 2.5M 2009-10-29 14:32 libapache2-mod-php5filter_5.2.6.dfsg.1-1+lenny4_amd64.deb
drwxr-xr-x 23 ssv ssv 4.0K 2009-10-29 14:31 php5-5.2.6.dfsg.1
-rw-r--r-- 1 ssv ssv 157K 2009-05-04 23:35 php5_5.2.6.dfsg.1-1+lenny3.diff.gz
-rw-r--r-- 1 ssv ssv 2.5K 2009-05-04 23:35 php5_5.2.6.dfsg.1-1+lenny3.dsc
-rw-r--r-- 1 ssv ssv 1.1K 2009-10-29 14:32 php5_5.2.6.dfsg.1-1+lenny4_all.deb
-rw-r--r-- 1 ssv ssv 12K 2009-10-29 14:32 php5_5.2.6.dfsg.1-1+lenny4_amd64.changes
-rw-r--r-- 1 ssv ssv 441K 2009-10-29 14:08 php5_5.2.6.dfsg.1-1+lenny4.diff.gz
-rw-r--r-- 1 ssv ssv 2.3K 2009-10-29 14:08 php5_5.2.6.dfsg.1-1+lenny4.dsc
-rw-r--r-- 1 ssv ssv 12M 2008-11-29 22:32 php5_5.2.6.dfsg.1.orig.tar.gz
-rw-r--r-- 1 ssv ssv 5.0M 2009-10-29 14:32 php5-cgi_5.2.6.dfsg.1-1+lenny4_amd64.deb
-rw-r--r-- 1 ssv ssv 2.5M 2009-10-29 14:32 php5-cli_5.2.6.dfsg.1-1+lenny4_amd64.deb
-rw-r--r-- 1 ssv ssv 358K 2009-10-29 14:32 php5-common_5.2.6.dfsg.1-1+lenny4_amd64.deb
-rw-r--r-- 1 ssv ssv 25K 2009-10-29 14:32 php5-curl_5.2.6.dfsg.1-1+lenny4_amd64.deb
-rw-r--r-- 1 ssv ssv 8.0M 2009-10-29 14:32 php5-dbg_5.2.6.dfsg.1-1+lenny4_amd64.deb
-rw-r--r-- 1 ssv ssv 359K 2009-10-29 14:32 php5-dev_5.2.6.dfsg.1-1+lenny4_amd64.deb
-rw-r--r-- 1 ssv ssv 37K 2009-10-29 14:32 php5-gd_5.2.6.dfsg.1-1+lenny4_amd64.deb
-rw-r--r-- 1 ssv ssv 17K 2009-10-29 14:32 php5-gmp_5.2.6.dfsg.1-1+lenny4_amd64.deb
-rw-r--r-- 1 ssv ssv 38K 2009-10-29 14:32 php5-imap_5.2.6.dfsg.1-1+lenny4_amd64.deb
-rw-r--r-- 1 ssv ssv 48K 2009-10-29 14:32 php5-interbase_5.2.6.dfsg.1-1+lenny4_amd64.deb
-rw-r--r-- 1 ssv ssv 20K 2009-10-29 14:32 php5-ldap_5.2.6.dfsg.1-1+lenny4_amd64.deb
-rw-r--r-- 1 ssv ssv 14K 2009-10-29 14:32 php5-mcrypt_5.2.6.dfsg.1-1+lenny4_amd64.deb
-rw-r--r-- 1 ssv ssv 5.3K 2009-10-29 14:32 php5-mhash_5.2.6.dfsg.1-1+lenny4_amd64.deb
-rw-r--r-- 1 ssv ssv 72K 2009-10-29 14:32 php5-mysql_5.2.6.dfsg.1-1+lenny4_amd64.deb
-rw-r--r-- 1 ssv ssv 38K 2009-10-29 14:32 php5-odbc_5.2.6.dfsg.1-1+lenny4_amd64.deb
-rw-r--r-- 1 ssv ssv 56K 2009-10-29 14:32 php5-pgsql_5.2.6.dfsg.1-1+lenny4_amd64.deb
-rw-r--r-- 1 ssv ssv 9.3K 2009-10-29 14:32 php5-pspell_5.2.6.dfsg.1-1+lenny4_amd64.deb
-rw-r--r-- 1 ssv ssv 5.0K 2009-10-29 14:32 php5-recode_5.2.6.dfsg.1-1+lenny4_amd64.deb
-rw-r--r-- 1 ssv ssv 13K 2009-10-29 14:32 php5-snmp_5.2.6.dfsg.1-1+lenny4_amd64.deb
-rw-r--r-- 1 ssv ssv 39K 2009-10-29 14:32 php5-sqlite_5.2.6.dfsg.1-1+lenny4_amd64.deb
-rw-r--r-- 1 ssv ssv 28K 2009-10-29 14:32 php5-sybase_5.2.6.dfsg.1-1+lenny4_amd64.deb
-rw-r--r-- 1 ssv ssv 18K 2009-10-29 14:32 php5-tidy_5.2.6.dfsg.1-1+lenny4_amd64.deb
-rw-r--r-- 1 ssv ssv 40K 2009-10-29 14:32 php5-xmlrpc_5.2.6.dfsg.1-1+lenny4_amd64.deb
-rw-r--r-- 1 ssv ssv 14K 2009-10-29 14:32 php5-xsl_5.2.6.dfsg.1-1+lenny4_amd64.deb
-rw-r--r-- 1 ssv ssv 327K 2009-10-29 14:32 php-pear_5.2.6.dfsg.1-1+lenny4_all.deb

Что устанавливать решать уже вам (и зависимостям), минимальный набор (php5-common+php5-cli+php5-cgi) у меня заработал, на продакшн еще не протестировал (возможно отпишу после удачного теста).

Надеюсь кому-то эта тема окажется полезной, также надеюсь, что кто-то менее ленивый чем я соберет более качественный пакет =)
Всем спасибо.
Vladislav
Re: Собрать deb-�
October 31, 2009 05:02AM
ssv пишет:

4) Куда нибудь скачиваем отсюда http://php-fpm.org/downloads/ патч для нужной версии, распаковываем, перемещаем в debian/patches/
Правим debian/patches/series - добавляем туда строку с названием патча, например, php-5.2.6-fpm-0.5.9.diff. Suhosin уже успешно добавлен мейнтейнерами debian'a, так что его я не трогал.


У меня такой вариант почему-то не прокатил. Правда, я пробовал так год
назад. Причина (выделено ниже) была в следующем (копирую кусок
сообщения от 22.10.2008):
______-=- _____

"Я понял в чем дело. В rules есть секция:

unprepared:

        dh_testdir
        sed -i -e
's/EXTRA_VERSION="-$(PHP5_DEBIAN_REVISION)"/EXTRA_VERSION=""/'
configure.in
        rm -f configure aclocal.m4 config.sub config.guess ltmain.sh
        rm -f build/libtool.m4 main/php_config.h.in
        rm -f prepared-stamp

в которой удаляются файлы, на которые php-fpm должен
накладывать патчи. Эта секция вызывается до наложения патчей. Вот
вывод:
#dpkg-buildpackage -rfakeroot -b
dpkg-buildpackage: set CPPFLAGS to default value:
dpkg-buildpackage: set CFLAGS to default value: -g -O2
dpkg-buildpackage: set CXXFLAGS to default value: -g -O2
dpkg-buildpackage: set FFLAGS to default value: -g -O2
dpkg-buildpackage: set LDFLAGS to default value:
-Wl,-Bsymbolic-functions
dpkg-buildpackage: пакет исходных текстов php5
dpkg-buildpackage: версия исходных текстов 5.2.4-2ubuntu5.3
dpkg-buildpackage: исходные тексты изменены Jamie Strandboge
&lt;jamie@ubuntu.com&gt;
dpkg-buildpackage: архитектура хоста i386
 fakeroot debian/rules clean
dh_testdir
sed -i -e 's/EXTRA_VERSION="-2ubuntu5.3"/EXTRA_VERSION=""/' configure.in
rm -f configure aclocal.m4 config.sub config.guess ltmain.sh
rm -f build/libtool.m4 main/php_config.h.in
rm -f prepared-stamp
QUILT_PATCHES=debian/patches quilt --quiltrc /dev/null pop -a -R ||
test $? = 2
No patch removed
rm -rf .pc debian/stamp-patched
dh_testdir
dh_testroot
rm -f configure-apache2-stamp build-apache2-stamp
rm -f configure-cgi-stamp build-cgi-stamp
rm -f configure-cli-stamp build-cli-stamp
rm -f build-pear-stamp
rm -f install-stamp
rm -rf apache2-build
rm -rf cgi-build
rm -rf cli-build
rm -rf pear-build
rm -f debian/copyright
rm -f test-results.txt
dh_clean
# clean up autogenerated cruft
cat debian/modulelist | while read package extname dsoname; do \
        rm -f debian/php5-$package.postinst; \
    done
for sapi in libapache2-mod-php5 php5-cgi php5-cli; do \
        for cruft in postrm links; do \
            rm -f debian/${sapi}.${cruft}; \
        done; \
    done
 debian/rules build
# quilt exits with 2 as return when there was nothing to do.
# That's not an error here (but it's usefull to break loops in crude
scripts)
QUILT_PATCHES=debian/patches quilt --quiltrc /dev/null push -a || test
$? = 2"
 
______-=-_____


Думаю по этой же причине nomadrin в самом начале наложил патч
php-fpm и только потом dch -i, dpkg-buildpackage -sa.
ssv
Re: Собрать deb-пакет php-fpm
October 31, 2009 09:40AM
Нынче этот target выглядит так:


unprepared:
dh_testdir
sed -i -e 's/EXTRA_VERSION="-$(PHP5_DEBIAN_REVISION)"/EXTRA_VERSION=""/' configure.in
rm -f prepared-stamp
Vitaliy Katochka
Re: Собрать deb-Ð акет php-fpm
November 08, 2009 10:48AM
Попытка на Ubuntu 9.10 не сложилось (

1. dpkg-source -x php5_5.2.10.dfsg.1-2ubuntu6.1.dsc

gpgv: Signature made Wed 28 Oct 2009 03:05:17 PM EET using DSA key ID
FA14013B
gpgv: Can't check signature: public key not found
dpkg-source: warning: failed to verify signature on ./php5_5.2.10.dfsg.
1-2ubuntu6.1.dsc
dpkg-source: info: extracting php5 in php5-5.2.10.dfsg.1
dpkg-source: info: unpacking php5_5.2.10.dfsg.1.orig.tar.gz
dpkg-source: info: applying php5_5.2.10.dfsg.1-2ubuntu6.1.diff.gz

2. dpkg-buildpackage -sa

make[1]: *** [ext/date/php_date.lo] Ошибка 1
make[1]: Выход из каталога `/home/inbusiness/php-fpm/php5-5.2.10.dfsg.
1/apache2-build'
make: *** [build-apache2-stamp] Ошибка 2
dpkg-buildpackage: ошибка: debian/rules build возвратил код ошибки 2


Подскажите, что не так?


On Oct 30, 4:15 pm, "ssv" <nginx-fo...@nginx.us> wrote:
> Почитав данную тему, а также:www.debian.org/doc/maint-guide/index.ru.html#contents
> nomadrain.org/ru/node/35
>
> Поступил следующим образом:
>
> 1) $apt-get build-dep php5
> 2) переходим в созданную нами заранее папку для сборки пакетов, после чего
> $apt-get source php5, или dpkg-source -x php5-вер-си-я.dsc (читаем выше в этой теме)
> 3) cd php5-вер-си-я
> 4) Куда нибудь скачиваем отсюдаhttp://php-fpm.org/downloads/патч для нужной версии, распаковываем, перемещаем в debian/patches/
> Правим debian/patches/series - добавляем туда строку с названием патча, например, php-5.2.6-fpm-0.5.9.diff. Suhosin уже успешно добавлен мейнтейнерами debian'a, так что его я не трогал.
> 5) Правим:
> debian/rules
> Меня хватило на добавления строки --enable-fpm в цели configure-cgi-stamp
> В цели install можно добавить установку php-fpm.conf и rc-скрипта(как это сделать написано у nomadrain), я этого не делал (следовательно после установки пакета нужно самостоятельно позаботится о них).
> 6) dch -i
> 7) dpkg-buildpackage -sa
> Если все пройдет успешно, у меня случилось именно так, то в ../ вы получите примерно следующую картину:
> ssv@XXX:~/debian/php5-fpm/php5-5.2.6.dfsg.1$ ls -alh ../
> total 35M
> drwxr-xr-x 4 ssv ssv 4.0K 2009-10-29 14:53 .
> drwxr-xr-x 4 ssv ssv 4.0K 2009-10-30 11:39 ..
> -rw-r--r-- 1 ssv ssv 2.5M 2009-10-29 14:32 libapache2-mod-php5_5.2.6.dfsg.1-1+lenny4_amd64.deb
> -rw-r--r-- 1 ssv ssv 2.5M 2009-10-29 14:32 libapache2-mod-php5filter_5.2.6.dfsg.1-1+lenny4_amd64.deb
> drwxr-xr-x 23 ssv ssv 4.0K 2009-10-29 14:31 php5-5.2.6.dfsg.1
> -rw-r--r-- 1 ssv ssv 157K 2009-05-04 23:35 php5_5.2.6.dfsg.1-1+lenny3.diff.gz
> -rw-r--r-- 1 ssv ssv 2.5K 2009-05-04 23:35 php5_5.2.6.dfsg.1-1+lenny3.dsc
> -rw-r--r-- 1 ssv ssv 1.1K 2009-10-29 14:32 php5_5.2.6.dfsg.1-1+lenny4_all.deb
> -rw-r--r-- 1 ssv ssv 12K 2009-10-29 14:32 php5_5.2.6.dfsg.1-1+lenny4_amd64.changes
> -rw-r--r-- 1 ssv ssv 441K 2009-10-29 14:08 php5_5.2.6.dfsg.1-1+lenny4.diff.gz
> -rw-r--r-- 1 ssv ssv 2.3K 2009-10-29 14:08 php5_5.2.6.dfsg.1-1+lenny4.dsc
> -rw-r--r-- 1 ssv ssv 12M 2008-11-29 22:32 php5_5.2.6.dfsg.1.orig.tar.gz
> -rw-r--r-- 1 ssv ssv 5.0M 2009-10-29 14:32 php5-cgi_5.2.6.dfsg.1-1+lenny4_amd64.deb
> -rw-r--r-- 1 ssv ssv 2.5M 2009-10-29 14:32 php5-cli_5.2.6.dfsg.1-1+lenny4_amd64.deb
> -rw-r--r-- 1 ssv ssv 358K 2009-10-29 14:32 php5-common_5.2.6.dfsg.1-1+lenny4_amd64.deb
> -rw-r--r-- 1 ssv ssv 25K 2009-10-29 14:32 php5-curl_5.2.6.dfsg.1-1+lenny4_amd64.deb
> -rw-r--r-- 1 ssv ssv 8.0M 2009-10-29 14:32 php5-dbg_5.2.6.dfsg.1-1+lenny4_amd64.deb
> -rw-r--r-- 1 ssv ssv 359K 2009-10-29 14:32 php5-dev_5.2.6.dfsg.1-1+lenny4_amd64.deb
> -rw-r--r-- 1 ssv ssv 37K 2009-10-29 14:32 php5-gd_5.2.6.dfsg.1-1+lenny4_amd64.deb
> -rw-r--r-- 1 ssv ssv 17K 2009-10-29 14:32 php5-gmp_5.2.6.dfsg.1-1+lenny4_amd64.deb
> -rw-r--r-- 1 ssv ssv 38K 2009-10-29 14:32 php5-imap_5.2.6.dfsg.1-1+lenny4_amd64.deb
> -rw-r--r-- 1 ssv ssv 48K 2009-10-29 14:32 php5-interbase_5.2.6.dfsg.1-1+lenny4_amd64.deb
> -rw-r--r-- 1 ssv ssv 20K 2009-10-29 14:32 php5-ldap_5.2.6.dfsg.1-1+lenny4_amd64.deb
> -rw-r--r-- 1 ssv ssv 14K 2009-10-29 14:32 php5-mcrypt_5.2.6.dfsg.1-1+lenny4_amd64.deb
> -rw-r--r-- 1 ssv ssv 5.3K 2009-10-29 14:32 php5-mhash_5.2.6.dfsg.1-1+lenny4_amd64.deb
> -rw-r--r-- 1 ssv ssv 72K 2009-10-29 14:32 php5-mysql_5.2.6.dfsg.1-1+lenny4_amd64.deb
> -rw-r--r-- 1 ssv ssv 38K 2009-10-29 14:32 php5-odbc_5.2.6.dfsg.1-1+lenny4_amd64.deb
> -rw-r--r-- 1 ssv ssv 56K 2009-10-29 14:32 php5-pgsql_5.2.6.dfsg.1-1+lenny4_amd64.deb
> -rw-r--r-- 1 ssv ssv 9.3K 2009-10-29 14:32 php5-pspell_5.2.6.dfsg.1-1+lenny4_amd64.deb
> -rw-r--r-- 1 ssv ssv 5.0K 2009-10-29 14:32 php5-recode_5.2.6.dfsg.1-1+lenny4_amd64.deb
> -rw-r--r-- 1 ssv ssv 13K 2009-10-29 14:32 php5-snmp_5.2.6.dfsg.1-1+lenny4_amd64.deb
> -rw-r--r-- 1 ssv ssv 39K 2009-10-29 14:32 php5-sqlite_5.2.6.dfsg.1-1+lenny4_amd64.deb
> -rw-r--r-- 1 ssv ssv 28K 2009-10-29 14:32 php5-sybase_5.2.6.dfsg.1-1+lenny4_amd64.deb
> -rw-r--r-- 1 ssv ssv 18K 2009-10-29 14:32 php5-tidy_5.2.6.dfsg.1-1+lenny4_amd64.deb
> -rw-r--r-- 1 ssv ssv 40K 2009-10-29 14:32 php5-xmlrpc_5.2.6.dfsg.1-1+lenny4_amd64.deb
> -rw-r--r-- 1 ssv ssv 14K 2009-10-29 14:32 php5-xsl_5.2.6.dfsg.1-1+lenny4_amd64.deb
> -rw-r--r-- 1 ssv ssv 327K 2009-10-29 14:32 php-pear_5.2.6.dfsg.1-1+lenny4_all.deb
>
> Что устанавливать решать уже вам (и зависимостям), минимальный набор (php5-common+php5-cli+php5-cgi) у меня заработал, на продакшн еще не протестировал (возможно отпишу после удачного теста).
>
> Надеюсь кому-то эта тема окажется полезной, также надеюсь, что кто-то менее ленивый чем я соберет более качественный пакет =)
> Всем спасибо.
>
> Posted at Nginx Forum:http://forum.nginx.org/read.php?25,13898,18302#msg-18302
XEK
Re: Собрать deb-Ð акет php-fpm
November 09, 2009 09:12AM
export LE_VER=1.4.12-stable
export PHP_VER=5.2.10
export LIBEVENT_SEARCH_PATH="shared,$PWD/libevent-$LE_VER/usr/local"

case "$1" in
1)
export LE_VER=1.4.12-stable
wget "http://www.monkey.org/~provos/libevent-$LE_VER.tar.gz"
tar -zxvf "libevent-$LE_VER.tar.gz"
cd "libevent-$LE_VER"
./configure && make
export DESTDIR=$PWD
make install
cd ..
;;

2)
export PHP_VER=5.2.11
wget "http://launchpad.net/php-fpm/master/0.6/+download/php-fpm-0.6~
$PHP_VER.tar.gz"
tar -zxvf "php-fpm-0.6~$PHP_VER.tar.gz"
"php-fpm-0.6-$PHP_VER/generate-fpm-patch"
;;

3)
#echo $LIBEVENT_SEARCH_PATH
#exit
if [ ! -f php-$PHP_VER.tar.gz ]; then
wget "http://ru2.php.net/get/php-$PHP_VER.tar.gz/from/uk.php.net/
mirror"
tar xvfz "php-$PHP_VER.tar.gz"
cd "php-$PHP_VER"
patch -p1 < ../fpm.patch
./buildconf --force
mkdir fpm-build && cd fpm-build
else
cd "php-$PHP_VER/fpm-build"
fi
echo $LIBEVENT_SEARCH_PATH
../configure --with-fpm \
--with-libevent="$LIBEVENT_SEARCH_PATH" \
--with-zlib --disable-mbstring --with-openssl --with-mysql \
--with-mysql-sock --with-gd --with-jpeg-dir=/usr/lib \
--without-sqlite --enable-pdo --enable-reflection --with-pdo-mysql
\
--with-mysqli \
--with-config-file-path=/etc/php \
--with-config-file-scan-dir=/etc/php/conf.d \
--with-fpm-conf=/etc/php/fpm.conf \
--with-fpm-user=www-data \
--with-fpm-group=www-data \
--with-freetype-dir=/usr/local --with-curl --with-gettext
cd ../..
# --with-mcrypt

;;

4)
cd "php-$PHP_VER/fpm-build"
make && make install
cd ../..
;;
esac


я не совсем в тему но помогает,
собираете по ./скрипт 1, ./скрипт 2 ...
Vitaliy Okulov
Re: Собрать deb-Ð акет php-fpm
November 09, 2009 09:42AM
Под debian 5.0 есть собранный 5.11 + fpm для amd64. Сегодня выложу правила
для сборки.

2009/11/8 Vitaliy Katochka <vkatochka@gmail.com>

>
> Попытка на Ubuntu 9.10 не сложилось (
>
> 1. dpkg-source -x php5_5.2.10.dfsg.1-2ubuntu6.1.dsc
>
> gpgv: Signature made Wed 28 Oct 2009 03:05:17 PM EET using DSA key ID
> FA14013B
> gpgv: Can't check signature: public key not found
> dpkg-source: warning: failed to verify signature on ./php5_5.2.10.dfsg.
> 1-2ubuntu6.1.dsc
> dpkg-source: info: extracting php5 in php5-5.2.10.dfsg.1
> dpkg-source: info: unpacking php5_5.2.10.dfsg.1.orig.tar.gz
> dpkg-source: info: applying php5_5.2.10.dfsg.1-2ubuntu6.1.diff.gz
>
> 2. dpkg-buildpackage -sa
>
> make[1]: *** [ext/date/php_date.lo] Ошибка 1
> make[1]: Выход из каталога `/home/inbusiness/php-fpm/php5-5.2.10.dfsg.
> 1/apache2-build'
> make: *** [build-apache2-stamp] Ошибка 2
> dpkg-buildpackage: ошибка: debian/rules build возвратил код ошибки 2
>
>
> Подскажите, что не так?
>
>
> On Oct 30, 4:15 pm, "ssv" <nginx-fo...@nginx.us> wrote:
> > Почитав данную тему, а также:
> www.debian.org/doc/maint-guide/index.ru.html#contents
> > nomadrain.org/ru/node/35
> >
> > Поступил следующим образом:
> >
> > 1) $apt-get build-dep php5
> > 2) переходим в созданную нами заранее папку для сборки пакетов, после
> чего
> > $apt-get source php5, или dpkg-source -x php5-вер-си-я.dsc (читаем выше
> в этой теме)
> > 3) cd php5-вер-си-я
> > 4) Куда нибудь скачиваем отсюдаhttp://php-fpm.org/downloads/патчhttp://php-fpm.org/downloads/%D0%BF%D0%B0%D1%82%D1%87для нужной версии, распаковываем, перемещаем в debian/patches/
> > Правим debian/patches/series - добавляем туда строку с названием патча,
> например, php-5.2.6-fpm-0.5.9.diff. Suhosin уже успешно добавлен
> мейнтейнерами debian'a, так что его я не трогал.
> > 5) Правим:
> > debian/rules
> > Меня хватило на добавления строки --enable-fpm в цели
> configure-cgi-stamp
> > В цели install можно добавить установку php-fpm.conf и rc-скрипта(как это
> сделать написано у nomadrain), я этого не делал (следовательно после
> установки пакета нужно самостоятельно позаботится о них).
> > 6) dch -i
> > 7) dpkg-buildpackage -sa
> > Если все пройдет успешно, у меня случилось именно так, то в ../ вы
> получите примерно следующую картину:
> > ssv@XXX:~/debian/php5-fpm/php5-5.2.6.dfsg.1$ ls -alh ../
> > total 35M
> > drwxr-xr-x 4 ssv ssv 4.0K 2009-10-29 14:53 .
> > drwxr-xr-x 4 ssv ssv 4.0K 2009-10-30 11:39 ..
> > -rw-r--r-- 1 ssv ssv 2.5M 2009-10-29 14:32
> libapache2-mod-php5_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > -rw-r--r-- 1 ssv ssv 2.5M 2009-10-29 14:32
> libapache2-mod-php5filter_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > drwxr-xr-x 23 ssv ssv 4.0K 2009-10-29 14:31 php5-5.2.6.dfsg.1
> > -rw-r--r-- 1 ssv ssv 157K 2009-05-04 23:35
> php5_5.2.6.dfsg.1-1+lenny3.diff.gz
> > -rw-r--r-- 1 ssv ssv 2.5K 2009-05-04 23:35
> php5_5.2.6.dfsg.1-1+lenny3.dsc
> > -rw-r--r-- 1 ssv ssv 1.1K 2009-10-29 14:32
> php5_5.2.6.dfsg.1-1+lenny4_all.deb
> > -rw-r--r-- 1 ssv ssv 12K 2009-10-29 14:32
> php5_5.2.6.dfsg.1-1+lenny4_amd64.changes
> > -rw-r--r-- 1 ssv ssv 441K 2009-10-29 14:08
> php5_5.2.6.dfsg.1-1+lenny4.diff.gz
> > -rw-r--r-- 1 ssv ssv 2.3K 2009-10-29 14:08
> php5_5.2.6.dfsg.1-1+lenny4.dsc
> > -rw-r--r-- 1 ssv ssv 12M 2008-11-29 22:32 php5_5.2.6.dfsg.1.orig.tar.gz
> > -rw-r--r-- 1 ssv ssv 5.0M 2009-10-29 14:32
> php5-cgi_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > -rw-r--r-- 1 ssv ssv 2.5M 2009-10-29 14:32
> php5-cli_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > -rw-r--r-- 1 ssv ssv 358K 2009-10-29 14:32
> php5-common_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > -rw-r--r-- 1 ssv ssv 25K 2009-10-29 14:32
> php5-curl_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > -rw-r--r-- 1 ssv ssv 8.0M 2009-10-29 14:32
> php5-dbg_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > -rw-r--r-- 1 ssv ssv 359K 2009-10-29 14:32
> php5-dev_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > -rw-r--r-- 1 ssv ssv 37K 2009-10-29 14:32
> php5-gd_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > -rw-r--r-- 1 ssv ssv 17K 2009-10-29 14:32
> php5-gmp_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > -rw-r--r-- 1 ssv ssv 38K 2009-10-29 14:32
> php5-imap_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > -rw-r--r-- 1 ssv ssv 48K 2009-10-29 14:32
> php5-interbase_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > -rw-r--r-- 1 ssv ssv 20K 2009-10-29 14:32
> php5-ldap_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > -rw-r--r-- 1 ssv ssv 14K 2009-10-29 14:32
> php5-mcrypt_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > -rw-r--r-- 1 ssv ssv 5.3K 2009-10-29 14:32
> php5-mhash_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > -rw-r--r-- 1 ssv ssv 72K 2009-10-29 14:32
> php5-mysql_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > -rw-r--r-- 1 ssv ssv 38K 2009-10-29 14:32
> php5-odbc_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > -rw-r--r-- 1 ssv ssv 56K 2009-10-29 14:32
> php5-pgsql_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > -rw-r--r-- 1 ssv ssv 9.3K 2009-10-29 14:32
> php5-pspell_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > -rw-r--r-- 1 ssv ssv 5.0K 2009-10-29 14:32
> php5-recode_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > -rw-r--r-- 1 ssv ssv 13K 2009-10-29 14:32
> php5-snmp_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > -rw-r--r-- 1 ssv ssv 39K 2009-10-29 14:32
> php5-sqlite_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > -rw-r--r-- 1 ssv ssv 28K 2009-10-29 14:32
> php5-sybase_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > -rw-r--r-- 1 ssv ssv 18K 2009-10-29 14:32
> php5-tidy_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > -rw-r--r-- 1 ssv ssv 40K 2009-10-29 14:32
> php5-xmlrpc_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > -rw-r--r-- 1 ssv ssv 14K 2009-10-29 14:32
> php5-xsl_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > -rw-r--r-- 1 ssv ssv 327K 2009-10-29 14:32
> php-pear_5.2.6.dfsg.1-1+lenny4_all.deb
> >
> > Что устанавливать решать уже вам (и зависимостям), минимальный набор
> (php5-common+php5-cli+php5-cgi) у меня заработал, на продакшн еще не
> протестировал (возможно отпишу после удачного теста).
> >
> > Надеюсь кому-то эта тема окажется полезной, также надеюсь, что кто-то
> менее ленивый чем я соберет более качественный пакет =)
> > Всем спасибо.
> >
> > Posted at Nginx Forum:
> http://forum.nginx.org/read.php?25,13898,18302#msg-18302
Kayo
Re: Собрать deb-Ð акет php-fpm
November 18, 2009 09:14AM
Как раз этой же темой сейчас занимаюсь. Как у вас успехи? Уже удалось
собрать пакет?

On 9 ноя, 19:40, Vitaliy Okulov <vitaliy.oku...@gmail.com> wrote:
> Под debian 5.0 есть собранный 5.11 + fpm для amd64. Сегодня выложу правила
> для сборки.
>
> 2009/11/8 Vitaliy Katochka <vkatoc...@gmail.com>
>
>
>
>
>
> > Попытка на Ubuntu 9.10 не сложилось (
>
> > 1. dpkg-source -x php5_5.2.10.dfsg.1-2ubuntu6.1.dsc
>
> > gpgv: Signature made Wed 28 Oct 2009 03:05:17 PM EET using DSA key ID
> > FA14013B
> > gpgv: Can't check signature: public key not found
> > dpkg-source: warning: failed to verify signature on ./php5_5.2.10.dfsg.
> > 1-2ubuntu6.1.dsc
> > dpkg-source: info: extracting php5 in php5-5.2.10.dfsg.1
> > dpkg-source: info: unpacking php5_5.2.10.dfsg.1.orig.tar.gz
> > dpkg-source: info: applying php5_5.2.10.dfsg.1-2ubuntu6.1.diff.gz
>
> > 2. dpkg-buildpackage -sa
>
> > make[1]: *** [ext/date/php_date.lo] Ошибка 1
> > make[1]: Выход из каталога `/home/inbusiness/php-fpm/php5-5.2.10.dfsg.
> > 1/apache2-build'
> > make: *** [build-apache2-stamp] Ошибка 2
> > dpkg-buildpackage: ошибка: debian/rules build возвратил код ошибки 2
>
> > Подскажите, что не так?
>
> > On Oct 30, 4:15 pm, "ssv" <nginx-fo...@nginx.us> wrote:
> > > Почитав данную тему, а также:
> >www.debian.org/doc/maint-guide/index.ru.html#contents
> > > nomadrain.org/ru/node/35
>
> > > Поступил следующим образом:
>
> > > 1) $apt-get build-dep php5
> > > 2) переходим в созданную нами заранее папку для сборки пакетов, после
> > чего
> > >  $apt-get source php5, или dpkg-source -x php5-вер-си-я.dsc (читаем выше
> > в этой теме)
> > > 3) cd php5-вер-си-я
> > > 4) Куда нибудь скачиваем отсюдаhttp://php-fpm.org/downloads/патчhttp://php-fpm.org/downloads/%D0%BF%D0%B0%D1%82%D1%87для нужной версии, распаковываем, перемещаем в debian/patches/
> > > Правим debian/patches/series - добавляем туда строку с названием патча,
> > например, php-5.2.6-fpm-0.5.9.diff. Suhosin уже успешно добавлен
> > мейнтейнерами debian'a, так что его я не трогал.
> > > 5) Правим:
> > > debian/rules
> > > Меня хватило на добавления строки  --enable-fpm в цели
> > configure-cgi-stamp
> > > В цели install можно добавить установку php-fpm.conf и rc-скрипта(как это
> > сделать написано у nomadrain), я этого не делал (следовательно после
> > установки пакета нужно самостоятельно позаботится о них).
> > > 6) dch -i
> > > 7) dpkg-buildpackage -sa
> > > Если все пройдет успешно, у меня случилось именно так, то в ../ вы
> > получите примерно следующую картину:
> > > ssv@XXX:~/debian/php5-fpm/php5-5.2.6.dfsg.1$ ls -alh ../
> > > total 35M
> > > drwxr-xr-x  4 ssv ssv 4.0K 2009-10-29 14:53 .
> > > drwxr-xr-x  4 ssv ssv 4.0K 2009-10-30 11:39 ..
> > > -rw-r--r--  1 ssv ssv 2.5M 2009-10-29 14:32
> > libapache2-mod-php5_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > -rw-r--r--  1 ssv ssv 2.5M 2009-10-29 14:32
> > libapache2-mod-php5filter_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > drwxr-xr-x 23 ssv ssv 4.0K 2009-10-29 14:31 php5-5.2.6.dfsg.1
> > > -rw-r--r--  1 ssv ssv 157K 2009-05-04 23:35
> > php5_5.2.6.dfsg.1-1+lenny3.diff.gz
> > > -rw-r--r--  1 ssv ssv 2.5K 2009-05-04 23:35
> > php5_5.2.6.dfsg.1-1+lenny3.dsc
> > > -rw-r--r--  1 ssv ssv 1.1K 2009-10-29 14:32
> > php5_5.2.6.dfsg.1-1+lenny4_all.deb
> > > -rw-r--r--  1 ssv ssv  12K 2009-10-29 14:32
> > php5_5.2.6.dfsg.1-1+lenny4_amd64.changes
> > > -rw-r--r--  1 ssv ssv 441K 2009-10-29 14:08
> > php5_5.2.6.dfsg.1-1+lenny4.diff.gz
> > > -rw-r--r--  1 ssv ssv 2.3K 2009-10-29 14:08
> > php5_5.2.6.dfsg.1-1+lenny4.dsc
> > > -rw-r--r--  1 ssv ssv  12M 2008-11-29 22:32 php5_5.2.6.dfsg.1.orig.tar.gz
> > > -rw-r--r--  1 ssv ssv 5.0M 2009-10-29 14:32
> > php5-cgi_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > -rw-r--r--  1 ssv ssv 2.5M 2009-10-29 14:32
> > php5-cli_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > -rw-r--r--  1 ssv ssv 358K 2009-10-29 14:32
> > php5-common_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > -rw-r--r--  1 ssv ssv  25K 2009-10-29 14:32
> > php5-curl_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > -rw-r--r--  1 ssv ssv 8.0M 2009-10-29 14:32
> > php5-dbg_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > -rw-r--r--  1 ssv ssv 359K 2009-10-29 14:32
> > php5-dev_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > -rw-r--r--  1 ssv ssv  37K 2009-10-29 14:32
> > php5-gd_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > -rw-r--r--  1 ssv ssv  17K 2009-10-29 14:32
> > php5-gmp_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > -rw-r--r--  1 ssv ssv  38K 2009-10-29 14:32
> > php5-imap_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > -rw-r--r--  1 ssv ssv  48K 2009-10-29 14:32
> > php5-interbase_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > -rw-r--r--  1 ssv ssv  20K 2009-10-29 14:32
> > php5-ldap_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > -rw-r--r--  1 ssv ssv  14K 2009-10-29 14:32
> > php5-mcrypt_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > -rw-r--r--  1 ssv ssv 5.3K 2009-10-29 14:32
> > php5-mhash_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > -rw-r--r--  1 ssv ssv  72K 2009-10-29 14:32
> > php5-mysql_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > -rw-r--r--  1 ssv ssv  38K 2009-10-29 14:32
> > php5-odbc_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > -rw-r--r--  1 ssv ssv  56K 2009-10-29 14:32
> > php5-pgsql_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > -rw-r--r--  1 ssv ssv 9.3K 2009-10-29 14:32
> > php5-pspell_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > -rw-r--r--  1 ssv ssv 5.0K 2009-10-29 14:32
> > php5-recode_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > -rw-r--r--  1 ssv ssv  13K 2009-10-29 14:32
> > php5-snmp_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > -rw-r--r--  1 ssv ssv  39K 2009-10-29 14:32
> > php5-sqlite_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > -rw-r--r--  1 ssv ssv  28K 2009-10-29 14:32
> > php5-sybase_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > -rw-r--r--  1 ssv ssv  18K 2009-10-29 14:32
> > php5-tidy_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > -rw-r--r--  1 ssv ssv  40K 2009-10-29 14:32
> > php5-xmlrpc_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > -rw-r--r--  1 ssv ssv  14K 2009-10-29 14:32
> > php5-xsl_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > -rw-r--r--  1 ssv ssv 327K 2009-10-29 14:32
> > php-pear_5.2.6.dfsg.1-1+lenny4_all.deb
>
> > > Что устанавливать решать уже вам (и зависимостям), минимальный набор
> > (php5-common+php5-cli+php5-cgi) у меня заработал, на продакшн еще не
> > протестировал (возможно отпишу после удачного теста).
>
> > > Надеюсь кому-то эта тема окажется полезной, также надеюсь, что кто-то
> > менее ленивый чем я соберет более качественный пакет =)
> > > Всем спасибо.
>
> > > Posted at Nginx Forum:
> >http://forum.nginx.org/read.php?25,13898,18302#msg-18302
Vitaliy Okulov
Re: Собрать deb-Ð акет php-fpm
November 18, 2009 09:14AM
Ответил напрямую автору письма. Пишу сюда.

http://vokulov.ru/debian/php5-5.2.11/php5_compile_rules.tar.gz

Не исправлен 1 баг, лечится по идее этим патчем -
http://github.com/dreamcat4/php5-5.2.10.dfsg.1/blob/master/debian/patches/supress_warn_pdo_shared.patch

2009/11/18 Kayo <kayo.k11.4@gmail.com>

>
> Как раз этой же темой сейчас занимаюсь. Как у вас успехи? Уже удалось
> собрать пакет?
>
> On 9 ноя, 19:40, Vitaliy Okulov <vitaliy.oku...@gmail.com> wrote:
> > Под debian 5.0 есть собранный 5.11 + fpm для amd64. Сегодня выложу
> правила
> > для сборки.
> >
> > 2009/11/8 Vitaliy Katochka <vkatoc...@gmail.com>
> >
> >
> >
> >
> >
> > > Попытка на Ubuntu 9.10 не сложилось (
> >
> > > 1. dpkg-source -x php5_5.2.10.dfsg.1-2ubuntu6.1.dsc
> >
> > > gpgv: Signature made Wed 28 Oct 2009 03:05:17 PM EET using DSA key ID
> > > FA14013B
> > > gpgv: Can't check signature: public key not found
> > > dpkg-source: warning: failed to verify signature on ./php5_5.2.10.dfsg.
> > > 1-2ubuntu6.1.dsc
> > > dpkg-source: info: extracting php5 in php5-5.2.10.dfsg.1
> > > dpkg-source: info: unpacking php5_5.2.10.dfsg.1.orig.tar.gz
> > > dpkg-source: info: applying php5_5.2.10.dfsg.1-2ubuntu6.1.diff.gz
> >
> > > 2. dpkg-buildpackage -sa
> >
> > > make[1]: *** [ext/date/php_date.lo] Ошибка 1
> > > make[1]: Выход из каталога `/home/inbusiness/php-fpm/php5-5.2.10.dfsg.
> > > 1/apache2-build'
> > > make: *** [build-apache2-stamp] Ошибка 2
> > > dpkg-buildpackage: ошибка: debian/rules build возвратил код ошибки 2
> >
> > > Подскажите, что не так?
> >
> > > On Oct 30, 4:15 pm, "ssv" <nginx-fo...@nginx.us> wrote:
> > > > Почитав данную тему, а также:
> > >www.debian.org/doc/maint-guide/index.ru.html#contents
> > > > nomadrain.org/ru/node/35
> >
> > > > Поступил следующим образом:
> >
> > > > 1) $apt-get build-dep php5
> > > > 2) переходим в созданную нами заранее папку для сборки пакетов, после
> > > чего
> > > > $apt-get source php5, или dpkg-source -x php5-вер-си-я.dsc (читаем
> выше
> > > в этой теме)
> > > > 3) cd php5-вер-си-я
> > > > 4) Куда нибудь скачиваем отсюдаhttp://php-fpm.org/downloads/патчhttp://php-fpm.org/downloads/%D0%BF%D0%B0%D1%82%D1%87
> http://php-fpm.org/downloads/%D0%BF%D0%B0%D1%82%D1%87для нужной версии,
> распаковываем, перемещаем в debian/patches/
> > > > Правим debian/patches/series - добавляем туда строку с названием
> патча,
> > > например, php-5.2.6-fpm-0.5.9.diff. Suhosin уже успешно добавлен
> > > мейнтейнерами debian'a, так что его я не трогал.
> > > > 5) Правим:
> > > > debian/rules
> > > > Меня хватило на добавления строки --enable-fpm в цели
> > > configure-cgi-stamp
> > > > В цели install можно добавить установку php-fpm.conf и rc-скрипта(как
> это
> > > сделать написано у nomadrain), я этого не делал (следовательно после
> > > установки пакета нужно самостоятельно позаботится о них).
> > > > 6) dch -i
> > > > 7) dpkg-buildpackage -sa
> > > > Если все пройдет успешно, у меня случилось именно так, то в ../ вы
> > > получите примерно следующую картину:
> > > > ssv@XXX:~/debian/php5-fpm/php5-5.2.6.dfsg.1$ ls -alh ../
> > > > total 35M
> > > > drwxr-xr-x 4 ssv ssv 4.0K 2009-10-29 14:53 .
> > > > drwxr-xr-x 4 ssv ssv 4.0K 2009-10-30 11:39 ..
> > > > -rw-r--r-- 1 ssv ssv 2.5M 2009-10-29 14:32
> > > libapache2-mod-php5_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > > -rw-r--r-- 1 ssv ssv 2.5M 2009-10-29 14:32
> > > libapache2-mod-php5filter_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > > drwxr-xr-x 23 ssv ssv 4.0K 2009-10-29 14:31 php5-5.2.6.dfsg.1
> > > > -rw-r--r-- 1 ssv ssv 157K 2009-05-04 23:35
> > > php5_5.2.6.dfsg.1-1+lenny3.diff.gz
> > > > -rw-r--r-- 1 ssv ssv 2.5K 2009-05-04 23:35
> > > php5_5.2.6.dfsg.1-1+lenny3.dsc
> > > > -rw-r--r-- 1 ssv ssv 1.1K 2009-10-29 14:32
> > > php5_5.2.6.dfsg.1-1+lenny4_all.deb
> > > > -rw-r--r-- 1 ssv ssv 12K 2009-10-29 14:32
> > > php5_5.2.6.dfsg.1-1+lenny4_amd64.changes
> > > > -rw-r--r-- 1 ssv ssv 441K 2009-10-29 14:08
> > > php5_5.2.6.dfsg.1-1+lenny4.diff.gz
> > > > -rw-r--r-- 1 ssv ssv 2.3K 2009-10-29 14:08
> > > php5_5.2.6.dfsg.1-1+lenny4.dsc
> > > > -rw-r--r-- 1 ssv ssv 12M 2008-11-29 22:32
> php5_5.2.6.dfsg.1.orig.tar.gz
> > > > -rw-r--r-- 1 ssv ssv 5.0M 2009-10-29 14:32
> > > php5-cgi_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > > -rw-r--r-- 1 ssv ssv 2.5M 2009-10-29 14:32
> > > php5-cli_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > > -rw-r--r-- 1 ssv ssv 358K 2009-10-29 14:32
> > > php5-common_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > > -rw-r--r-- 1 ssv ssv 25K 2009-10-29 14:32
> > > php5-curl_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > > -rw-r--r-- 1 ssv ssv 8.0M 2009-10-29 14:32
> > > php5-dbg_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > > -rw-r--r-- 1 ssv ssv 359K 2009-10-29 14:32
> > > php5-dev_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > > -rw-r--r-- 1 ssv ssv 37K 2009-10-29 14:32
> > > php5-gd_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > > -rw-r--r-- 1 ssv ssv 17K 2009-10-29 14:32
> > > php5-gmp_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > > -rw-r--r-- 1 ssv ssv 38K 2009-10-29 14:32
> > > php5-imap_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > > -rw-r--r-- 1 ssv ssv 48K 2009-10-29 14:32
> > > php5-interbase_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > > -rw-r--r-- 1 ssv ssv 20K 2009-10-29 14:32
> > > php5-ldap_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > > -rw-r--r-- 1 ssv ssv 14K 2009-10-29 14:32
> > > php5-mcrypt_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > > -rw-r--r-- 1 ssv ssv 5.3K 2009-10-29 14:32
> > > php5-mhash_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > > -rw-r--r-- 1 ssv ssv 72K 2009-10-29 14:32
> > > php5-mysql_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > > -rw-r--r-- 1 ssv ssv 38K 2009-10-29 14:32
> > > php5-odbc_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > > -rw-r--r-- 1 ssv ssv 56K 2009-10-29 14:32
> > > php5-pgsql_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > > -rw-r--r-- 1 ssv ssv 9.3K 2009-10-29 14:32
> > > php5-pspell_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > > -rw-r--r-- 1 ssv ssv 5.0K 2009-10-29 14:32
> > > php5-recode_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > > -rw-r--r-- 1 ssv ssv 13K 2009-10-29 14:32
> > > php5-snmp_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > > -rw-r--r-- 1 ssv ssv 39K 2009-10-29 14:32
> > > php5-sqlite_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > > -rw-r--r-- 1 ssv ssv 28K 2009-10-29 14:32
> > > php5-sybase_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > > -rw-r--r-- 1 ssv ssv 18K 2009-10-29 14:32
> > > php5-tidy_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > > -rw-r--r-- 1 ssv ssv 40K 2009-10-29 14:32
> > > php5-xmlrpc_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > > -rw-r--r-- 1 ssv ssv 14K 2009-10-29 14:32
> > > php5-xsl_5.2.6.dfsg.1-1+lenny4_amd64.deb
> > > > -rw-r--r-- 1 ssv ssv 327K 2009-10-29 14:32
> > > php-pear_5.2.6.dfsg.1-1+lenny4_all.deb
> >
> > > > Что устанавливать решать уже вам (и зависимостям), минимальный набор
> > > (php5-common+php5-cli+php5-cgi) у меня заработал, на продакшн еще не
> > > протестировал (возможно отпишу после удачного теста).
> >
> > > > Надеюсь кому-то эта тема окажется полезной, также надеюсь, что кто-то
> > > менее ленивый чем я соберет более качественный пакет =)
> > > > Всем спасибо.
> >
> > > > Posted at Nginx Forum:
> > >http://forum.nginx.org/read.php?25,13898,18302#msg-18302
>
Kayo Ayanami
Re: Собрать deb-Ð акет php-fpm
November 18, 2009 11:52AM
Решил поступил несколько по-другому, собрать php-fpm как отдельный пакет.
Отпишусь в ту ветку, как получится.

2009/11/18 Vitaliy Okulov <vitaliy.okulov@gmail.com>

> Ответил напрямую автору письма. Пишу сюда.
>
> http://vokulov.ru/debian/php5-5.2.11/php5_compile_rules.tar.gz
>
> Не исправлен 1 баг, лечится по идее этим патчем -
> http://github.com/dreamcat4/php5-5.2.10.dfsg.1/blob/master/debian/patches/supress_warn_pdo_shared.patch
>
> 2009/11/18 Kayo <kayo.k11.4@gmail.com>
>
>
>> Как раз этой же темой сейчас занимаюсь. Как у вас успехи? Уже удалось
>> собрать пакет?
>>
>> On 9 ноя, 19:40, Vitaliy Okulov <vitaliy.oku...@gmail.com> wrote:
>> > Под debian 5.0 есть собранный 5.11 + fpm для amd64. Сегодня выложу
>> правила
>> > для сборки.
>> >
>> > 2009/11/8 Vitaliy Katochka <vkatoc...@gmail.com>
>> >
>> >
>> >
>> >
>> >
>> > > Попытка на Ubuntu 9.10 не сложилось (
>> >
>> > > 1. dpkg-source -x php5_5.2.10.dfsg.1-2ubuntu6.1.dsc
>> >
>> > > gpgv: Signature made Wed 28 Oct 2009 03:05:17 PM EET using DSA key ID
>> > > FA14013B
>> > > gpgv: Can't check signature: public key not found
>> > > dpkg-source: warning: failed to verify signature on
>> ./php5_5.2.10.dfsg.
>> > > 1-2ubuntu6.1.dsc
>> > > dpkg-source: info: extracting php5 in php5-5.2.10.dfsg.1
>> > > dpkg-source: info: unpacking php5_5.2.10.dfsg.1.orig.tar.gz
>> > > dpkg-source: info: applying php5_5.2.10.dfsg.1-2ubuntu6.1.diff.gz
>> >
>> > > 2. dpkg-buildpackage -sa
>> >
>> > > make[1]: *** [ext/date/php_date.lo] Ошибка 1
>> > > make[1]: Выход из каталога `/home/inbusiness/php-fpm/php5-5.2.10.dfsg.
>> > > 1/apache2-build'
>> > > make: *** [build-apache2-stamp] Ошибка 2
>> > > dpkg-buildpackage: ошибка: debian/rules build возвратил код ошибки 2
>> >
>> > > Подскажите, что не так?
>> >
>> > > On Oct 30, 4:15 pm, "ssv" <nginx-fo...@nginx.us> wrote:
>> > > > Почитав данную тему, а также:
>> > >www.debian.org/doc/maint-guide/index.ru.html#contents
>> > > > nomadrain.org/ru/node/35
>> >
>> > > > Поступил следующим образом:
>> >
>> > > > 1) $apt-get build-dep php5
>> > > > 2) переходим в созданную нами заранее папку для сборки пакетов,
>> после
>> > > чего
>> > > > $apt-get source php5, или dpkg-source -x php5-вер-си-я.dsc (читаем
>> выше
>> > > в этой теме)
>> > > > 3) cd php5-вер-си-я
>> > > > 4) Куда нибудь скачиваем отсюдаhttp://php-fpm.org/downloads/патчhttp://php-fpm.org/downloads/%D0%BF%D0%B0%D1%82%D1%87
>> http://php-fpm.org/downloads/%D0%BF%D0%B0%D1%82%D1%87для нужной версии,
>> распаковываем, перемещаем в debian/patches/
>> > > > Правим debian/patches/series - добавляем туда строку с названием
>> патча,
>> > > например, php-5.2.6-fpm-0.5.9.diff. Suhosin уже успешно добавлен
>> > > мейнтейнерами debian'a, так что его я не трогал.
>> > > > 5) Правим:
>> > > > debian/rules
>> > > > Меня хватило на добавления строки --enable-fpm в цели
>> > > configure-cgi-stamp
>> > > > В цели install можно добавить установку php-fpm.conf и
>> rc-скрипта(как это
>> > > сделать написано у nomadrain), я этого не делал (следовательно после
>> > > установки пакета нужно самостоятельно позаботится о них).
>> > > > 6) dch -i
>> > > > 7) dpkg-buildpackage -sa
>> > > > Если все пройдет успешно, у меня случилось именно так, то в ../ вы
>> > > получите примерно следующую картину:
>> > > > ssv@XXX:~/debian/php5-fpm/php5-5.2.6.dfsg.1$ ls -alh ../
>> > > > total 35M
>> > > > drwxr-xr-x 4 ssv ssv 4.0K 2009-10-29 14:53 .
>> > > > drwxr-xr-x 4 ssv ssv 4.0K 2009-10-30 11:39 ..
>> > > > -rw-r--r-- 1 ssv ssv 2.5M 2009-10-29 14:32
>> > > libapache2-mod-php5_5.2.6.dfsg.1-1+lenny4_amd64.deb
>> > > > -rw-r--r-- 1 ssv ssv 2.5M 2009-10-29 14:32
>> > > libapache2-mod-php5filter_5.2.6.dfsg.1-1+lenny4_amd64.deb
>> > > > drwxr-xr-x 23 ssv ssv 4.0K 2009-10-29 14:31 php5-5.2.6.dfsg.1
>> > > > -rw-r--r-- 1 ssv ssv 157K 2009-05-04 23:35
>> > > php5_5.2.6.dfsg.1-1+lenny3.diff.gz
>> > > > -rw-r--r-- 1 ssv ssv 2.5K 2009-05-04 23:35
>> > > php5_5.2.6.dfsg.1-1+lenny3.dsc
>> > > > -rw-r--r-- 1 ssv ssv 1.1K 2009-10-29 14:32
>> > > php5_5.2.6.dfsg.1-1+lenny4_all.deb
>> > > > -rw-r--r-- 1 ssv ssv 12K 2009-10-29 14:32
>> > > php5_5.2.6.dfsg.1-1+lenny4_amd64.changes
>> > > > -rw-r--r-- 1 ssv ssv 441K 2009-10-29 14:08
>> > > php5_5.2.6.dfsg.1-1+lenny4.diff.gz
>> > > > -rw-r--r-- 1 ssv ssv 2.3K 2009-10-29 14:08
>> > > php5_5.2.6.dfsg.1-1+lenny4.dsc
>> > > > -rw-r--r-- 1 ssv ssv 12M 2008-11-29 22:32
>> php5_5.2.6.dfsg.1.orig.tar.gz
>> > > > -rw-r--r-- 1 ssv ssv 5.0M 2009-10-29 14:32
>> > > php5-cgi_5.2.6.dfsg.1-1+lenny4_amd64.deb
>> > > > -rw-r--r-- 1 ssv ssv 2.5M 2009-10-29 14:32
>> > > php5-cli_5.2.6.dfsg.1-1+lenny4_amd64.deb
>> > > > -rw-r--r-- 1 ssv ssv 358K 2009-10-29 14:32
>> > > php5-common_5.2.6.dfsg.1-1+lenny4_amd64.deb
>> > > > -rw-r--r-- 1 ssv ssv 25K 2009-10-29 14:32
>> > > php5-curl_5.2.6.dfsg.1-1+lenny4_amd64.deb
>> > > > -rw-r--r-- 1 ssv ssv 8.0M 2009-10-29 14:32
>> > > php5-dbg_5.2.6.dfsg.1-1+lenny4_amd64.deb
>> > > > -rw-r--r-- 1 ssv ssv 359K 2009-10-29 14:32
>> > > php5-dev_5.2.6.dfsg.1-1+lenny4_amd64.deb
>> > > > -rw-r--r-- 1 ssv ssv 37K 2009-10-29 14:32
>> > > php5-gd_5.2.6.dfsg.1-1+lenny4_amd64.deb
>> > > > -rw-r--r-- 1 ssv ssv 17K 2009-10-29 14:32
>> > > php5-gmp_5.2.6.dfsg.1-1+lenny4_amd64.deb
>> > > > -rw-r--r-- 1 ssv ssv 38K 2009-10-29 14:32
>> > > php5-imap_5.2.6.dfsg.1-1+lenny4_amd64.deb
>> > > > -rw-r--r-- 1 ssv ssv 48K 2009-10-29 14:32
>> > > php5-interbase_5.2.6.dfsg.1-1+lenny4_amd64.deb
>> > > > -rw-r--r-- 1 ssv ssv 20K 2009-10-29 14:32
>> > > php5-ldap_5.2.6.dfsg.1-1+lenny4_amd64.deb
>> > > > -rw-r--r-- 1 ssv ssv 14K 2009-10-29 14:32
>> > > php5-mcrypt_5.2.6.dfsg.1-1+lenny4_amd64.deb
>> > > > -rw-r--r-- 1 ssv ssv 5.3K 2009-10-29 14:32
>> > > php5-mhash_5.2.6.dfsg.1-1+lenny4_amd64.deb
>> > > > -rw-r--r-- 1 ssv ssv 72K 2009-10-29 14:32
>> > > php5-mysql_5.2.6.dfsg.1-1+lenny4_amd64.deb
>> > > > -rw-r--r-- 1 ssv ssv 38K 2009-10-29 14:32
>> > > php5-odbc_5.2.6.dfsg.1-1+lenny4_amd64.deb
>> > > > -rw-r--r-- 1 ssv ssv 56K 2009-10-29 14:32
>> > > php5-pgsql_5.2.6.dfsg.1-1+lenny4_amd64.deb
>> > > > -rw-r--r-- 1 ssv ssv 9.3K 2009-10-29 14:32
>> > > php5-pspell_5.2.6.dfsg.1-1+lenny4_amd64.deb
>> > > > -rw-r--r-- 1 ssv ssv 5.0K 2009-10-29 14:32
>> > > php5-recode_5.2.6.dfsg.1-1+lenny4_amd64.deb
>> > > > -rw-r--r-- 1 ssv ssv 13K 2009-10-29 14:32
>> > > php5-snmp_5.2.6.dfsg.1-1+lenny4_amd64.deb
>> > > > -rw-r--r-- 1 ssv ssv 39K 2009-10-29 14:32
>> > > php5-sqlite_5.2.6.dfsg.1-1+lenny4_amd64.deb
>> > > > -rw-r--r-- 1 ssv ssv 28K 2009-10-29 14:32
>> > > php5-sybase_5.2.6.dfsg.1-1+lenny4_amd64.deb
>> > > > -rw-r--r-- 1 ssv ssv 18K 2009-10-29 14:32
>> > > php5-tidy_5.2.6.dfsg.1-1+lenny4_amd64.deb
>> > > > -rw-r--r-- 1 ssv ssv 40K 2009-10-29 14:32
>> > > php5-xmlrpc_5.2.6.dfsg.1-1+lenny4_amd64.deb
>> > > > -rw-r--r-- 1 ssv ssv 14K 2009-10-29 14:32
>> > > php5-xsl_5.2.6.dfsg.1-1+lenny4_amd64.deb
>> > > > -rw-r--r-- 1 ssv ssv 327K 2009-10-29 14:32
>> > > php-pear_5.2.6.dfsg.1-1+lenny4_all.deb
>> >
>> > > > Что устанавливать решать уже вам (и зависимостям), минимальный набор
>> > > (php5-common+php5-cli+php5-cgi) у меня заработал, на продакшн еще не
>> > > протестировал (возможно отпишу после удачного теста).
>> >
>> > > > Надеюсь кому-то эта тема окажется полезной, также надеюсь, что
>> кто-то
>> > > менее ленивый чем я соберет более качественный пакет =)
>> > > > Всем спасибо.
>> >
>> > > > Posted at Nginx Forum:
>> > >http://forum.nginx.org/read.php?25,13898,18302#msg-18302
>>
>
>


--
-------------------------------------------------------------
Kayo Ayanami

jabber: kayo@jabber.ru
gtalk-xmpp: kayo.k11.4@gmail.com
ya-xmpp: kayo-k11-4@ya.ru
sourceforge: phoenix11@users.sf.net
luaforge: phoenix11@users.luaforge.net
Vitaliy Okulov
Re: Собрать deb-Ð акет php-fpm
November 18, 2009 03:22PM
В этих правилах собирается отдельный бинарник php5-fpm.

2009/11/18 Kayo Ayanami <kayo.k11.4@gmail.com>

> Решил поступил несколько по-другому, собрать php-fpm как отдельный пакет.
> Отпишусь в ту ветку, как получится.
>
> 2009/11/18 Vitaliy Okulov <vitaliy.okulov@gmail.com>
>
> Ответил напрямую автору письма. Пишу сюда.
>>
>> http://vokulov.ru/debian/php5-5.2.11/php5_compile_rules.tar.gz
>>
>> Не исправлен 1 баг, лечится по идее этим патчем -
>> http://github.com/dreamcat4/php5-5.2.10.dfsg.1/blob/master/debian/patches/supress_warn_pdo_shared.patch
>>
>> 2009/11/18 Kayo <kayo.k11.4@gmail.com>
>>
>>
>>> Как раз этой же темой сейчас занимаюсь. Как у вас успехи? Уже удалось
>>> собрать пакет?
>>>
>>> On 9 ноя, 19:40, Vitaliy Okulov <vitaliy.oku...@gmail.com> wrote:
>>> > Под debian 5.0 есть собранный 5.11 + fpm для amd64. Сегодня выложу
>>> правила
>>> > для сборки.
>>> >
>>> > 2009/11/8 Vitaliy Katochka <vkatoc...@gmail.com>
>>> >
>>> >
>>> >
>>> >
>>> >
>>> > > Попытка на Ubuntu 9.10 не сложилось (
>>> >
>>> > > 1. dpkg-source -x php5_5.2.10.dfsg.1-2ubuntu6.1.dsc
>>> >
>>> > > gpgv: Signature made Wed 28 Oct 2009 03:05:17 PM EET using DSA key ID
>>> > > FA14013B
>>> > > gpgv: Can't check signature: public key not found
>>> > > dpkg-source: warning: failed to verify signature on
>>> ./php5_5.2.10.dfsg.
>>> > > 1-2ubuntu6.1.dsc
>>> > > dpkg-source: info: extracting php5 in php5-5.2.10.dfsg.1
>>> > > dpkg-source: info: unpacking php5_5.2.10.dfsg.1.orig.tar.gz
>>> > > dpkg-source: info: applying php5_5.2.10.dfsg.1-2ubuntu6.1.diff.gz
>>> >
>>> > > 2. dpkg-buildpackage -sa
>>> >
>>> > > make[1]: *** [ext/date/php_date.lo] Ошибка 1
>>> > > make[1]: Выход из каталога
>>> `/home/inbusiness/php-fpm/php5-5.2.10.dfsg.
>>> > > 1/apache2-build'
>>> > > make: *** [build-apache2-stamp] Ошибка 2
>>> > > dpkg-buildpackage: ошибка: debian/rules build возвратил код ошибки 2
>>> >
>>> > > Подскажите, что не так?
>>> >
>>> > > On Oct 30, 4:15 pm, "ssv" <nginx-fo...@nginx.us> wrote:
>>> > > > Почитав данную тему, а также:
>>> > >www.debian.org/doc/maint-guide/index.ru.html#contents
>>> > > > nomadrain.org/ru/node/35
>>> >
>>> > > > Поступил следующим образом:
>>> >
>>> > > > 1) $apt-get build-dep php5
>>> > > > 2) переходим в созданную нами заранее папку для сборки пакетов,
>>> после
>>> > > чего
>>> > > > $apt-get source php5, или dpkg-source -x php5-вер-си-я.dsc (читаем
>>> выше
>>> > > в этой теме)
>>> > > > 3) cd php5-вер-си-я
>>> > > > 4) Куда нибудь скачиваем отсюдаhttp://php-fpm.org/downloads/патчhttp://php-fpm.org/downloads/%D0%BF%D0%B0%D1%82%D1%87
>>> http://php-fpm.org/downloads/%D0%BF%D0%B0%D1%82%D1%87для нужной
>>> версии, распаковываем, перемещаем в debian/patches/
>>> > > > Правим debian/patches/series - добавляем туда строку с названием
>>> патча,
>>> > > например, php-5.2.6-fpm-0.5.9.diff. Suhosin уже успешно добавлен
>>> > > мейнтейнерами debian'a, так что его я не трогал.
>>> > > > 5) Правим:
>>> > > > debian/rules
>>> > > > Меня хватило на добавления строки --enable-fpm в цели
>>> > > configure-cgi-stamp
>>> > > > В цели install можно добавить установку php-fpm.conf и
>>> rc-скрипта(как это
>>> > > сделать написано у nomadrain), я этого не делал (следовательно после
>>> > > установки пакета нужно самостоятельно позаботится о них).
>>> > > > 6) dch -i
>>> > > > 7) dpkg-buildpackage -sa
>>> > > > Если все пройдет успешно, у меня случилось именно так, то в ../ вы
>>> > > получите примерно следующую картину:
>>> > > > ssv@XXX:~/debian/php5-fpm/php5-5.2.6.dfsg.1$ ls -alh ../
>>> > > > total 35M
>>> > > > drwxr-xr-x 4 ssv ssv 4.0K 2009-10-29 14:53 .
>>> > > > drwxr-xr-x 4 ssv ssv 4.0K 2009-10-30 11:39 ..
>>> > > > -rw-r--r-- 1 ssv ssv 2.5M 2009-10-29 14:32
>>> > > libapache2-mod-php5_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>> > > > -rw-r--r-- 1 ssv ssv 2.5M 2009-10-29 14:32
>>> > > libapache2-mod-php5filter_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>> > > > drwxr-xr-x 23 ssv ssv 4.0K 2009-10-29 14:31 php5-5.2.6.dfsg.1
>>> > > > -rw-r--r-- 1 ssv ssv 157K 2009-05-04 23:35
>>> > > php5_5.2.6.dfsg.1-1+lenny3.diff.gz
>>> > > > -rw-r--r-- 1 ssv ssv 2.5K 2009-05-04 23:35
>>> > > php5_5.2.6.dfsg.1-1+lenny3.dsc
>>> > > > -rw-r--r-- 1 ssv ssv 1.1K 2009-10-29 14:32
>>> > > php5_5.2.6.dfsg.1-1+lenny4_all.deb
>>> > > > -rw-r--r-- 1 ssv ssv 12K 2009-10-29 14:32
>>> > > php5_5.2.6.dfsg.1-1+lenny4_amd64.changes
>>> > > > -rw-r--r-- 1 ssv ssv 441K 2009-10-29 14:08
>>> > > php5_5.2.6.dfsg.1-1+lenny4.diff.gz
>>> > > > -rw-r--r-- 1 ssv ssv 2.3K 2009-10-29 14:08
>>> > > php5_5.2.6.dfsg.1-1+lenny4.dsc
>>> > > > -rw-r--r-- 1 ssv ssv 12M 2008-11-29 22:32
>>> php5_5.2.6.dfsg.1.orig.tar.gz
>>> > > > -rw-r--r-- 1 ssv ssv 5.0M 2009-10-29 14:32
>>> > > php5-cgi_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>> > > > -rw-r--r-- 1 ssv ssv 2.5M 2009-10-29 14:32
>>> > > php5-cli_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>> > > > -rw-r--r-- 1 ssv ssv 358K 2009-10-29 14:32
>>> > > php5-common_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>> > > > -rw-r--r-- 1 ssv ssv 25K 2009-10-29 14:32
>>> > > php5-curl_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>> > > > -rw-r--r-- 1 ssv ssv 8.0M 2009-10-29 14:32
>>> > > php5-dbg_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>> > > > -rw-r--r-- 1 ssv ssv 359K 2009-10-29 14:32
>>> > > php5-dev_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>> > > > -rw-r--r-- 1 ssv ssv 37K 2009-10-29 14:32
>>> > > php5-gd_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>> > > > -rw-r--r-- 1 ssv ssv 17K 2009-10-29 14:32
>>> > > php5-gmp_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>> > > > -rw-r--r-- 1 ssv ssv 38K 2009-10-29 14:32
>>> > > php5-imap_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>> > > > -rw-r--r-- 1 ssv ssv 48K 2009-10-29 14:32
>>> > > php5-interbase_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>> > > > -rw-r--r-- 1 ssv ssv 20K 2009-10-29 14:32
>>> > > php5-ldap_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>> > > > -rw-r--r-- 1 ssv ssv 14K 2009-10-29 14:32
>>> > > php5-mcrypt_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>> > > > -rw-r--r-- 1 ssv ssv 5.3K 2009-10-29 14:32
>>> > > php5-mhash_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>> > > > -rw-r--r-- 1 ssv ssv 72K 2009-10-29 14:32
>>> > > php5-mysql_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>> > > > -rw-r--r-- 1 ssv ssv 38K 2009-10-29 14:32
>>> > > php5-odbc_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>> > > > -rw-r--r-- 1 ssv ssv 56K 2009-10-29 14:32
>>> > > php5-pgsql_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>> > > > -rw-r--r-- 1 ssv ssv 9.3K 2009-10-29 14:32
>>> > > php5-pspell_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>> > > > -rw-r--r-- 1 ssv ssv 5.0K 2009-10-29 14:32
>>> > > php5-recode_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>> > > > -rw-r--r-- 1 ssv ssv 13K 2009-10-29 14:32
>>> > > php5-snmp_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>> > > > -rw-r--r-- 1 ssv ssv 39K 2009-10-29 14:32
>>> > > php5-sqlite_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>> > > > -rw-r--r-- 1 ssv ssv 28K 2009-10-29 14:32
>>> > > php5-sybase_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>> > > > -rw-r--r-- 1 ssv ssv 18K 2009-10-29 14:32
>>> > > php5-tidy_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>> > > > -rw-r--r-- 1 ssv ssv 40K 2009-10-29 14:32
>>> > > php5-xmlrpc_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>> > > > -rw-r--r-- 1 ssv ssv 14K 2009-10-29 14:32
>>> > > php5-xsl_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>> > > > -rw-r--r-- 1 ssv ssv 327K 2009-10-29 14:32
>>> > > php-pear_5.2.6.dfsg.1-1+lenny4_all.deb
>>> >
>>> > > > Что устанавливать решать уже вам (и зависимостям), минимальный
>>> набор
>>> > > (php5-common+php5-cli+php5-cgi) у меня заработал, на продакшн еще не
>>> > > протестировал (возможно отпишу после удачного теста).
>>> >
>>> > > > Надеюсь кому-то эта тема окажется полезной, также надеюсь, что
>>> кто-то
>>> > > менее ленивый чем я соберет более качественный пакет =)
>>> > > > Всем спасибо.
>>> >
>>> > > > Posted at Nginx Forum:
>>> > >http://forum.nginx.org/read.php?25,13898,18302#msg-18302
>>>
>>
>>
>
>
> --
> -------------------------------------------------------------
> Kayo Ayanami
>
> jabber: kayo@jabber.ru
> gtalk-xmpp: kayo.k11.4@gmail.com
> ya-xmpp: kayo-k11-4@ya.ru
> sourceforge: phoenix11@users.sf.net
> luaforge: phoenix11@users.luaforge.net
>
>
Re: Собрать deb-Ð акет php-fpm
November 18, 2009 04:18PM
2009/11/18 Vitaliy Okulov <vitaliy.okulov@gmail.com>:
> Ответил напрямую автору письма. Пишу сюда.
>
> http://vokulov.ru/debian/php5-5.2.11/php5_compile_rules.tar.gz
>
> Не исправлен 1 баг, лечится по идее этим патчем -
> http://github.com/dreamcat4/php5-5.2.10.dfsg.1/blob/master/debian/patches/supress_warn_pdo_shared.patch

Its a harmless warning message saying the PDO extension is trying to
load twice. You might avoid by setting
"../configure --with-pdo=shared,/usr"

Because Debian like to compile PDO as shared extension and distribute
it in php5-common .deb.

dreamcat4
dreamcat4@gmail.com
Kayo Ayanami
Re: Собрать deb-Ð акет php-fpm
November 19, 2009 08:32AM
Как обещал собрал отдельный .deb пакет php-fpm. Итак, что сделано:

* Сборка осуществляется по второму варианту (как описано в readme
полученного от upstream архива с исходниками), без необходимости применения
патчей для исходных кодов самого php.
* При сборке пакета выполняется следующее:
1. Получение и распаковка пакета исходных текстов php (5.2.11) во
временную директорию внутри проекта
2. Стандартное конфигурирование и частичная сборка php (выполнение правила
php-cgi-stamp в debian/rules в принципе достаточно)
3. Конфигурирование php-fpm с указанием места расположения собранного кода
php и дополнительных параметров и сборка php-fpm
4. Формирование дерева каталогов с помещением в него файлов php-fpm,
файлов сопровождения и сборка пакета
* Были сделаны следующие изменения:
1. Файл конфигурации помещен в /etc/php5/php-fpm.conf и фиксируется при
обновлении пакета
2. По умолчанию сервис слушает сокет (/var/run/php-fpm.sock) вместо tcp
порта (127.0.0.1:9000)
3. Файл примера конфигурации nginx помещен в
/usr/share/docs/php-fpm-0.6/examples/nginx-site-conf.sample и переменная
fastcgi_pass имеет значение unix:/var/run/php-fpm.sock
4. Сервис конфигурируется как стартующий по умолчанию при установке пакета
5. Настройки php берутся те же как для php-cgi (то есть читается
/etc/php5/cgi/php.ini и все что в /etc/php5/cgi/conf.d/*.ini)
* Пакет протестирован на двух системах: на той, на которой собирался, и на
xen-vps сервере.

Осталось придумать, куда выложить файлы, отправлять прямо сюда наверно не
стоит.

Пока не разбирался на тему как стать сопровождающим пакетов в составе
команды debian, но в принципе можно попробовать со временем добавить пакет в
репозитарий.

И да, чуть не забыл предупредить: это первый .deb пакет, который
сконструировал в своей жизни, так что требуются энтузиасты для потестить,
поконсультировать ^_~

2009/11/19 Vitaliy Okulov <vitaliy.okulov@gmail.com>

> В этих правилах собирается отдельный бинарник php5-fpm.
>
> 2009/11/18 Kayo Ayanami <kayo.k11.4@gmail.com>
>
> Решил поступил несколько по-другому, собрать php-fpm как отдельный пакет.
>> Отпишусь в ту ветку, как получится.
>>
>> 2009/11/18 Vitaliy Okulov <vitaliy.okulov@gmail.com>
>>
>> Ответил напрямую автору письма. Пишу сюда.
>>>
>>> http://vokulov.ru/debian/php5-5.2.11/php5_compile_rules.tar.gz
>>>
>>> Не исправлен 1 баг, лечится по идее этим патчем -
>>> http://github.com/dreamcat4/php5-5.2.10.dfsg.1/blob/master/debian/patches/supress_warn_pdo_shared.patch
>>>
>>> 2009/11/18 Kayo <kayo.k11.4@gmail.com>
>>>
>>>
>>>> Как раз этой же темой сейчас занимаюсь. Как у вас успехи? Уже удалось
>>>> собрать пакет?
>>>>
>>>> On 9 ноя, 19:40, Vitaliy Okulov <vitaliy.oku...@gmail.com> wrote:
>>>> > Под debian 5.0 есть собранный 5.11 + fpm для amd64. Сегодня выложу
>>>> правила
>>>> > для сборки.
>>>> >
>>>> > 2009/11/8 Vitaliy Katochka <vkatoc...@gmail.com>
>>>> >
>>>> >
>>>> >
>>>> >
>>>> >
>>>> > > Попытка на Ubuntu 9.10 не сложилось (
>>>> >
>>>> > > 1. dpkg-source -x php5_5.2.10.dfsg.1-2ubuntu6.1.dsc
>>>> >
>>>> > > gpgv: Signature made Wed 28 Oct 2009 03:05:17 PM EET using DSA key
>>>> ID
>>>> > > FA14013B
>>>> > > gpgv: Can't check signature: public key not found
>>>> > > dpkg-source: warning: failed to verify signature on
>>>> ./php5_5.2.10.dfsg.
>>>> > > 1-2ubuntu6.1.dsc
>>>> > > dpkg-source: info: extracting php5 in php5-5.2.10.dfsg.1
>>>> > > dpkg-source: info: unpacking php5_5.2.10.dfsg.1.orig.tar.gz
>>>> > > dpkg-source: info: applying php5_5.2.10.dfsg.1-2ubuntu6.1.diff.gz
>>>> >
>>>> > > 2. dpkg-buildpackage -sa
>>>> >
>>>> > > make[1]: *** [ext/date/php_date.lo] Ошибка 1
>>>> > > make[1]: Выход из каталога
>>>> `/home/inbusiness/php-fpm/php5-5.2.10.dfsg.
>>>> > > 1/apache2-build'
>>>> > > make: *** [build-apache2-stamp] Ошибка 2
>>>> > > dpkg-buildpackage: ошибка: debian/rules build возвратил код ошибки 2
>>>> >
>>>> > > Подскажите, что не так?
>>>> >
>>>> > > On Oct 30, 4:15 pm, "ssv" <nginx-fo...@nginx.us> wrote:
>>>> > > > Почитав данную тему, а также:
>>>> > >www.debian.org/doc/maint-guide/index.ru.html#contents
>>>> > > > nomadrain.org/ru/node/35
>>>> >
>>>> > > > Поступил следующим образом:
>>>> >
>>>> > > > 1) $apt-get build-dep php5
>>>> > > > 2) переходим в созданную нами заранее папку для сборки пакетов,
>>>> после
>>>> > > чего
>>>> > > > $apt-get source php5, или dpkg-source -x php5-вер-си-я.dsc
>>>> (читаем выше
>>>> > > в этой теме)
>>>> > > > 3) cd php5-вер-си-я
>>>> > > > 4) Куда нибудь скачиваем отсюдаhttp://php-fpm.org/downloads/патчhttp://php-fpm.org/downloads/%D0%BF%D0%B0%D1%82%D1%87
>>>> http://php-fpm.org/downloads/%D0%BF%D0%B0%D1%82%D1%87для нужной
>>>> версии, распаковываем, перемещаем в debian/patches/
>>>> > > > Правим debian/patches/series - добавляем туда строку с названием
>>>> патча,
>>>> > > например, php-5.2.6-fpm-0.5.9.diff. Suhosin уже успешно добавлен
>>>> > > мейнтейнерами debian'a, так что его я не трогал.
>>>> > > > 5) Правим:
>>>> > > > debian/rules
>>>> > > > Меня хватило на добавления строки --enable-fpm в цели
>>>> > > configure-cgi-stamp
>>>> > > > В цели install можно добавить установку php-fpm.conf и
>>>> rc-скрипта(как это
>>>> > > сделать написано у nomadrain), я этого не делал (следовательно после
>>>> > > установки пакета нужно самостоятельно позаботится о них).
>>>> > > > 6) dch -i
>>>> > > > 7) dpkg-buildpackage -sa
>>>> > > > Если все пройдет успешно, у меня случилось именно так, то в ../ вы
>>>> > > получите примерно следующую картину:
>>>> > > > ssv@XXX:~/debian/php5-fpm/php5-5.2.6.dfsg.1$ ls -alh ../
>>>> > > > total 35M
>>>> > > > drwxr-xr-x 4 ssv ssv 4.0K 2009-10-29 14:53 .
>>>> > > > drwxr-xr-x 4 ssv ssv 4.0K 2009-10-30 11:39 ..
>>>> > > > -rw-r--r-- 1 ssv ssv 2.5M 2009-10-29 14:32
>>>> > > libapache2-mod-php5_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>>> > > > -rw-r--r-- 1 ssv ssv 2.5M 2009-10-29 14:32
>>>> > > libapache2-mod-php5filter_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>>> > > > drwxr-xr-x 23 ssv ssv 4.0K 2009-10-29 14:31 php5-5.2.6.dfsg.1
>>>> > > > -rw-r--r-- 1 ssv ssv 157K 2009-05-04 23:35
>>>> > > php5_5.2.6.dfsg.1-1+lenny3.diff.gz
>>>> > > > -rw-r--r-- 1 ssv ssv 2.5K 2009-05-04 23:35
>>>> > > php5_5.2.6.dfsg.1-1+lenny3.dsc
>>>> > > > -rw-r--r-- 1 ssv ssv 1.1K 2009-10-29 14:32
>>>> > > php5_5.2.6.dfsg.1-1+lenny4_all.deb
>>>> > > > -rw-r--r-- 1 ssv ssv 12K 2009-10-29 14:32
>>>> > > php5_5.2.6.dfsg.1-1+lenny4_amd64.changes
>>>> > > > -rw-r--r-- 1 ssv ssv 441K 2009-10-29 14:08
>>>> > > php5_5.2.6.dfsg.1-1+lenny4.diff.gz
>>>> > > > -rw-r--r-- 1 ssv ssv 2.3K 2009-10-29 14:08
>>>> > > php5_5.2.6.dfsg.1-1+lenny4.dsc
>>>> > > > -rw-r--r-- 1 ssv ssv 12M 2008-11-29 22:32
>>>> php5_5.2.6.dfsg.1.orig.tar.gz
>>>> > > > -rw-r--r-- 1 ssv ssv 5.0M 2009-10-29 14:32
>>>> > > php5-cgi_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>>> > > > -rw-r--r-- 1 ssv ssv 2.5M 2009-10-29 14:32
>>>> > > php5-cli_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>>> > > > -rw-r--r-- 1 ssv ssv 358K 2009-10-29 14:32
>>>> > > php5-common_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>>> > > > -rw-r--r-- 1 ssv ssv 25K 2009-10-29 14:32
>>>> > > php5-curl_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>>> > > > -rw-r--r-- 1 ssv ssv 8.0M 2009-10-29 14:32
>>>> > > php5-dbg_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>>> > > > -rw-r--r-- 1 ssv ssv 359K 2009-10-29 14:32
>>>> > > php5-dev_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>>> > > > -rw-r--r-- 1 ssv ssv 37K 2009-10-29 14:32
>>>> > > php5-gd_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>>> > > > -rw-r--r-- 1 ssv ssv 17K 2009-10-29 14:32
>>>> > > php5-gmp_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>>> > > > -rw-r--r-- 1 ssv ssv 38K 2009-10-29 14:32
>>>> > > php5-imap_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>>> > > > -rw-r--r-- 1 ssv ssv 48K 2009-10-29 14:32
>>>> > > php5-interbase_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>>> > > > -rw-r--r-- 1 ssv ssv 20K 2009-10-29 14:32
>>>> > > php5-ldap_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>>> > > > -rw-r--r-- 1 ssv ssv 14K 2009-10-29 14:32
>>>> > > php5-mcrypt_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>>> > > > -rw-r--r-- 1 ssv ssv 5.3K 2009-10-29 14:32
>>>> > > php5-mhash_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>>> > > > -rw-r--r-- 1 ssv ssv 72K 2009-10-29 14:32
>>>> > > php5-mysql_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>>> > > > -rw-r--r-- 1 ssv ssv 38K 2009-10-29 14:32
>>>> > > php5-odbc_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>>> > > > -rw-r--r-- 1 ssv ssv 56K 2009-10-29 14:32
>>>> > > php5-pgsql_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>>> > > > -rw-r--r-- 1 ssv ssv 9.3K 2009-10-29 14:32
>>>> > > php5-pspell_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>>> > > > -rw-r--r-- 1 ssv ssv 5.0K 2009-10-29 14:32
>>>> > > php5-recode_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>>> > > > -rw-r--r-- 1 ssv ssv 13K 2009-10-29 14:32
>>>> > > php5-snmp_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>>> > > > -rw-r--r-- 1 ssv ssv 39K 2009-10-29 14:32
>>>> > > php5-sqlite_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>>> > > > -rw-r--r-- 1 ssv ssv 28K 2009-10-29 14:32
>>>> > > php5-sybase_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>>> > > > -rw-r--r-- 1 ssv ssv 18K 2009-10-29 14:32
>>>> > > php5-tidy_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>>> > > > -rw-r--r-- 1 ssv ssv 40K 2009-10-29 14:32
>>>> > > php5-xmlrpc_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>>> > > > -rw-r--r-- 1 ssv ssv 14K 2009-10-29 14:32
>>>> > > php5-xsl_5.2.6.dfsg.1-1+lenny4_amd64.deb
>>>> > > > -rw-r--r-- 1 ssv ssv 327K 2009-10-29 14:32
>>>> > > php-pear_5.2.6.dfsg.1-1+lenny4_all.deb
>>>> >
>>>> > > > Что устанавливать решать уже вам (и зависимостям), минимальный
>>>> набор
>>>> > > (php5-common+php5-cli+php5-cgi) у меня заработал, на продакшн еще не
>>>> > > протестировал (возможно отпишу после удачного теста).
>>>> >
>>>> > > > Надеюсь кому-то эта тема окажется полезной, также надеюсь, что
>>>> кто-то
>>>> > > менее ленивый чем я соберет более качественный пакет =)
>>>> > > > Всем спасибо.
>>>> >
>>>> > > > Posted at Nginx Forum:
>>>> > >http://forum.nginx.org/read.php?25,13898,18302#msg-18302
>>>>
>>>
>>>
>>
>>
>> --
>> -------------------------------------------------------------
>> Kayo Ayanami
>>
>> jabber: kayo@jabber.ru
>> gtalk-xmpp: kayo.k11.4@gmail.com
>> ya-xmpp: kayo-k11-4@ya.ru
>> sourceforge: phoenix11@users.sf.net
>> luaforge: phoenix11@users.luaforge.net
>>
>>
>


--
-------------------------------------------------------------
Kayo Ayanami

jabber: kayo@jabber.ru
gtalk-xmpp: kayo.k11.4@gmail.com
ya-xmpp: kayo-k11-4@ya.ru
sourceforge: phoenix11@users.sf.net
luaforge: phoenix11@users.luaforge.net
Re: Собрать deb-пакет php-fpm
November 19, 2009 09:27AM
Вставлю и свои 5 копеек.

Также собирал php-fpm как отдельный бинарник под Debian 5 Lenny i386, по дороге накидал инструкцию.

Собирал пакеты из репозиториев:
sid --- deb http://ftp.de.debian.org/debian sid main
dotdeb --- deb http://packages.dotdeb.org stable all
Основывался http://github.com/dreamcat4/php5-5.2.10.dfsg.1
Итог более детально можно смотреть здесь ---> http://jaaah.ru/php-fpm/php5-5.2.11.dfsg.1.tar.gz

[b]Настройка среды:[/b]

Сначала создаём папку в которой будем пересобирать пакет и переходим в неё.
*Лучше делать её не в tmp, т.к после перезагрузки сервера эта папка обычно очищается.

1) Скачиваем необходимые по зависимостям пакеты, исходники.
apt-get build-dep php5
apt-get source php5
получаем папку вида php5_2.xxx
*Для php из sid - php5-5.2.11.dfsg.1
*Для php из dotdeb - php5-5.2.11

2) Также FPM необходимы два пакета libxml2-dev и libevent-dev, если их нет доставляем.
apt-get install libxml2-dev

libevent-dev не старше версии 1.4-2, её можно поставить из sid / squeeze
sources.list << deb http://ftp.de.debian.org/debian sid main
apt-get update
apt-get install libevent-dev

*Желательно установить autoconf до версии 2.13
apt-get autoconf2.13
*Если пакет из sid / squeeze то необходимо обновить libtool до версии (2.2.6a-4)

[b]Настройка пакета:[/b]

1) Скачиваем патч необходимой версии, далее генерируем его
wget "http://launchpad.net/php-fpm/master/0.6/+download/php-fpm-0.6-$PHP_VER.tar.gz"
tar -zxvf "php-fpm-0.6-$PHP_VER.tar.gz"
"php-fpm-0.6-$PHP_VER/generate-fpm-patch"

2) копируем патч в папочку debian/patches в папке php_5.xxx
добавляем в series << fpm.patch
http://jaaah.ru/php-fpm/series.html
* В php от dotdeb были проблемы с suhosin.patch

3) далее правим debian/rules
http://jaaah.ru/php-fpm/rules.html

*Возникала проблема с PDO, решил следующим образом: --disable-pdo
Позже увидел, что dreamcat4 советует делать так: --with-pdo=shared,/usr

4) правим debian/control
добавляем описание пакета php-fpm
http://jaaah.ru/php-fpm/control.html

5) добавляем в дирректорию debian/patches допольнитльеные файлы пакета

php5-fpm.dirs
php5-fpm.logrotate
php5-fpm.postinst
php5-fpm.prerm

http://jaaah.ru/php-fpm/php5-fpm_files.html

6) Переходим в папку пакета и создаём папку для файлов патча
cd php_5.xxx && mkdir -p php_5.xxx/sapi/fpm
Копируем в эту папку следующие файлы --- смотри пакет
убираем с них 755, оставляем только на configure.


[b]Сборка:[/b]

1) dch -i

2) dpkg-buildpackage -sa

После сборки получаем стопку пакетов с долгожданным php-fpm.
Устанавливаем так: dpkg -i php5-common_5.2.11.dfsg.1-2_i386.deb php5-fpm_5.2.11.dfsg.1-2_i386.deb

Пакеты тестируются на локальной машине уже 4 дня, проблем ни с чем пока не возникало.
Re: Собрать deb-Ð акет php-fpm
November 19, 2009 09:48AM
2009/11/19 Kayo Ayanami <kayo.k11.4@gmail.com>:
>   2. По умолчанию сервис слушает сокет (/var/run/php-fpm.sock) вместо tcp
> порта (127.0.0.1:9000)
>   3. Файл примера конфигурации nginx помещен в
> /usr/share/docs/php-fpm-0.6/examples/nginx-site-conf.sample и переменная
> fastcgi_pass имеет значение unix:/var/run/php-fpm.sock

Php-fpm doesn't work reliably with sockets. It causes some occasional error.
The only solution we know is to stay using TCP and avoid unix socket.

Otherwise we would recommend sockets because they are faster.

dreamcat4
dreamcat4@gmail.com
Kayo Ayanami
Re: Собрать deb-Ð акет php-fpm
November 19, 2009 11:28AM
Hmm.. Strange.. I haven't yet notice such trouble on my system. But I may
try to solve problem, related to using unix sockets. Ok.. Then I do rolled
back to using tcp by default for my package.

2009/11/19 dreamcat four <dreamcat4@gmail.com>

> 2009/11/19 Kayo Ayanami <kayo.k11.4@gmail.com>:
> > 2. По умолчанию сервис слушает сокет (/var/run/php-fpm.sock) вместо tcp
> > порта (127.0.0.1:9000)
> > 3. Файл примера конфигурации nginx помещен в
> > /usr/share/docs/php-fpm-0.6/examples/nginx-site-conf.sample и переменная
> > fastcgi_pass имеет значение unix:/var/run/php-fpm.sock
>
> Php-fpm doesn't work reliably with sockets. It causes some occasional
> error.
> The only solution we know is to stay using TCP and avoid unix socket.
>
> Otherwise we would recommend sockets because they are faster.
>
> dreamcat4
> dreamcat4@gmail.com
>



--
-------------------------------------------------------------
Kayo Ayanami

jabber: kayo@jabber.ru
gtalk-xmpp: kayo.k11.4@gmail.com
ya-xmpp: kayo-k11-4@ya.ru
sourceforge: phoenix11@users.sf.net
luaforge: phoenix11@users.luaforge.net
Re: Собрать deb-Ð акет php-fpm
November 19, 2009 12:12PM
Вставлю и свои 5 копеек.

Также собирал php-fpm как отдельный бинарник под Debian 5 Lenny i386,
по дороге накидал инструкцию.

Собирал пакеты из репозиториев:
sid --- deb http://ftp.de.debian.org/debian sid main
dotdeb --- deb http://packages.dotdeb.org stable all
Основывался http://github.com/dreamcat4/php5-5.2.10.dfsg.1
Итог более детально можно смотреть здесь ---> http://jaaah.ru/php-fpm/php5-5.2.11.dfsg.1.tar.gz

Настройка среды:

Сначала создаём папку в которой будем пересобирать пакет и переходим в
неё.
*Лучше делать её не в tmp, т.к после перезагрузки сервера эта папка
обычно очищается.

1) Скачиваем необходимые по зависимостям пакеты, исходники.
apt-get build-dep php5
apt-get source php5
получаем папку вида php5_2.xxx
*Для php из sid - php5-5.2.11.dfsg.1
*Для php из dotdeb - php5-5.2.11

2) Также FPM необходимы два пакета libxml2-dev и libevent-dev, если их
нет доставляем.
apt-get install libxml2-dev

libevent-dev не старше версии 1.4-2, её можно поставить из sid /
squeeze
sources.list << deb http://ftp.de.debian.org/debian sid main
apt-get update
apt-get install libevent-dev

*Желательно установить autoconf до версии 2.13
apt-get autoconf2.13
*Если пакет из sid / squeeze то необходимо обновить libtool до версии
(2.2.6a-4)

Настройка пакета:

1) Скачиваем патч необходимой версии, далее генерируем его
wget "http://launchpad.net/php-fpm/master/0.6/+download/php-fpm-0.6-
$PHP_VER.tar.gz";
tar -zxvf "php-fpm-0.6-$PHP_VER.tar.gz"
"php-fpm-0.6-$PHP_VER/generate-fpm-patch"

2) копируем патч в папочку debian/patches в папке php_5.xxx
добавляем в series << fpm.patch
http://jaaah.ru/php-fpm/series.html
* В php от dotdeb были проблемы с suhosin.patch

3) далее правим debian/rules
http://jaaah.ru/php-fpm/rules.html

*Возникала проблема с PDO, решил следующим образом: --disable-pdo
Позже увидел, что dreamcat4 советует делать так: --with-pdo=shared,/
usr

4) правим debian/control
добавляем описание пакета php-fpm
http://jaaah.ru/php-fpm/control.html

5) добавляем в дирректорию debian/patches допольнитльеные файлы пакета

php5-fpm.dirs
php5-fpm.logrotate
php5-fpm.postinst
php5-fpm.prerm

http://jaaah.ru/php-fpm/php5-fpm_files.html

6) Переходим в папку пакета и создаём папку для файлов патча
cd php_5.xxx && mkdir -p php_5.xxx/sapi/fpm
Копируем в эту папку следующие файлы http://jaaah.ru/php-fpm/sapi.tar.gz
убираем с них 755, оставляем только на configure.

Сборка:

1) dch -i

2) dpkg-buildpackage -sa

После сборки получаем стопку пакетов с долгожданным php-fpm.
Устанавливаем так: dpkg -i php5-common_5.2.11.dfsg.1-2_i386.deb php5-
fpm_5.2.11.dfsg.1-2_i386.deb

Пакеты тестируются на локальной машине уже 4 дня, проблем ни с чем
пока не возникало.
ks
Re: Собрать deb-Ð акет php-fpm
November 19, 2009 09:20PM
А как тестируем, если не секрет?

2009/11/19 razor <razor@jaaah.ru>

> Вставлю и свои 5 копеек.
>
> Также собирал php-fpm как отдельный бинарник под Debian 5 Lenny i386,
> по дороге накидал инструкцию.
>
> Собирал пакеты из репозиториев:
> sid --- deb http://ftp.de.debian.org/debian sid main
> dotdeb --- deb http://packages.dotdeb.org stable all
> Основывался http://github.com/dreamcat4/php5-5.2.10.dfsg.1
> Итог более детально можно смотреть здесь --->
> http://jaaah.ru/php-fpm/php5-5.2.11.dfsg.1.tar.gz
>
> Настройка среды:
>
> Сначала создаём папку в которой будем пересобирать пакет и переходим в
> неё.
> *Лучше делать её не в tmp, т.к после перезагрузки сервера эта папка
> обычно очищается.
>
> 1) Скачиваем необходимые по зависимостям пакеты, исходники.
> apt-get build-dep php5
> apt-get source php5
> получаем папку вида php5_2.xxx
> *Для php из sid - php5-5.2.11.dfsg.1
> *Для php из dotdeb - php5-5.2.11
>
> 2) Также FPM необходимы два пакета libxml2-dev и libevent-dev, если их
> нет доставляем.
> apt-get install libxml2-dev
>
> libevent-dev не старше версии 1.4-2, её можно поставить из sid /
> squeeze
> sources.list << deb http://ftp.de.debian.org/debian sid main
> apt-get update
> apt-get install libevent-dev
>
> *Желательно установить autoconf до версии 2.13
> apt-get autoconf2.13
> *Если пакет из sid / squeeze то необходимо обновить libtool до версии
> (2.2.6a-4)
>
> Настройка пакета:
>
> 1) Скачиваем патч необходимой версии, далее генерируем его
> wget "http://launchpad.net/php-fpm/master/0.6/+download/php-fpm-0.6-
> $PHP_VER.tar.gz";
> tar -zxvf "php-fpm-0.6-$PHP_VER.tar.gz"
> "php-fpm-0.6-$PHP_VER/generate-fpm-patch"
>
> 2) копируем патч в папочку debian/patches в папке php_5.xxx
> добавляем в series << fpm.patch
> http://jaaah.ru/php-fpm/series.html
> * В php от dotdeb были проблемы с suhosin.patch
>
> 3) далее правим debian/rules
> http://jaaah.ru/php-fpm/rules.html
>
> *Возникала проблема с PDO, решил следующим образом: --disable-pdo
> Позже увидел, что dreamcat4 советует делать так: --with-pdo=shared,/
> usr
>
> 4) правим debian/control
> добавляем описание пакета php-fpm
> http://jaaah.ru/php-fpm/control.html
>
> 5) добавляем в дирректорию debian/patches допольнитльеные файлы пакета
>
> php5-fpm.dirs
> php5-fpm.logrotate
> php5-fpm.postinst
> php5-fpm.prerm
>
> http://jaaah.ru/php-fpm/php5-fpm_files.html
>
> 6) Переходим в папку пакета и создаём папку для файлов патча
> cd php_5.xxx && mkdir -p php_5.xxx/sapi/fpm
> Копируем в эту папку следующие файлы http://jaaah.ru/php-fpm/sapi.tar.gz
> убираем с них 755, оставляем только на configure.
>
> Сборка:
>
> 1) dch -i
>
> 2) dpkg-buildpackage -sa
>
> После сборки получаем стопку пакетов с долгожданным php-fpm.
> Устанавливаем так: dpkg -i php5-common_5.2.11.dfsg.1-2_i386.deb php5-
> fpm_5.2.11.dfsg.1-2_i386.deb
>
> Пакеты тестируются на локальной машине уже 4 дня, проблем ни с чем
> пока не возникало.
Re: Собрать deb-Ð акет php-fpm
November 20, 2009 08:06AM
Насчёт тестирования поясню:
Имелось ввиду тестирование стабильности работы самого FPM в php 5.2.11
а не качества сборки.
Имею в своём распоряжении небольшую сеть, потому довольно неплохо
удаётся эмулировать нагрузочное тестирование, использую siege. Также
ставил пакеты в виртуальной машине OpenVZ пробовал ограничивать
ресурсы памяти, процессора и т.д. Патч ведёт себя очень достойно,
сбоев в работе при нормальной настройке добиться так и не удалось.

Как тестировать сборку пакетов, честно говоря толком не представляю.
Потому руководствовался принципом, если нормально всё устанавливается
и стабильно работает, то сборка нормальная :)

Ранее просто были замечены проблемы с php-fpm под штатный php 5.2.6,
демон нормально не выгружался. Правда там патч накладывал на php-cgi.
В этой версии проблем с выгрузкой/загрузкой не наблюдается.

Из замеченных недочётов:
после установки пакета, запускающий файл php5-fpm ищет демона php-fpm
не там где положено (фиксим путь в /etc/init.d/php5-fpm)
также php собирался без mcrypt,imap,interbase

На выходных, времени будет больше, потому планирую пересобрать пакеты
заново с внесением соответствующих правок, а также директивой --with-
pdo=shared,/usr (Thanks dreamcat4).
Заменю эти исходники http://jaaah.ru/php-fpm/php5-5.2.11.dfsg.1.tar.gz
правленными.
Если есть интерес, пишите, выложу на всеобщее обозрение также и
готовые пакеты.


On 20 ноя, 05:10, Khazret Sapenov <sape...@gmail.com> wrote:
> А как тестируем, если не секрет?
>
> 2009/11/19 razor <ra...@jaaah.ru>
>
> > Вставлю и свои 5 копеек.
>
> > Также собирал php-fpm как отдельный бинарник под Debian 5 Lenny i386,
> > по дороге накидал инструкцию.
>
> > Собирал пакеты из репозиториев:
> > sid --- debhttp://ftp.de.debian.org/debiansid main
> > dotdeb --- debhttp://packages.dotdeb.orgstable all
> > Основывалсяhttp://github.com/dreamcat4/php5-5.2.10.dfsg.1
> > Итог более детально можно смотреть здесь --->
> >http://jaaah.ru/php-fpm/php5-5.2.11.dfsg.1.tar.gz
>
> > Настройка среды:
>
> > Сначала создаём папку в которой будем пересобирать пакет и переходим в
> > неё.
> > *Лучше делать её не в tmp, т.к после перезагрузки сервера эта папка
> > обычно очищается.
>
> > 1) Скачиваем необходимые по зависимостям пакеты, исходники.
> > apt-get build-dep php5
> > apt-get source php5
> > получаем папку вида php5_2.xxx
> > *Для php из sid - php5-5.2.11.dfsg.1
> > *Для php из dotdeb - php5-5.2.11
>
> > 2) Также FPM необходимы два пакета libxml2-dev и libevent-dev, если их
> > нет доставляем.
> > apt-get install libxml2-dev
>
> > libevent-dev не старше версии 1.4-2, её можно поставить из sid /
> > squeeze
> > sources.list << debhttp://ftp.de.debian.org/debiansid main
> > apt-get update
> > apt-get install libevent-dev
>
> > *Желательно установить autoconf до версии 2.13
> > apt-get autoconf2.13
> > *Если пакет из sid / squeeze то необходимо обновить libtool до версии
> > (2.2.6a-4)
>
> > Настройка пакета:
>
> > 1) Скачиваем патч необходимой версии, далее генерируем его
> > wget "http://launchpad.net/php-fpm/master/0.6/+download/php-fpm-0.6-
> > $PHP_VER.tar.gz";
> > tar -zxvf "php-fpm-0.6-$PHP_VER.tar.gz"
> > "php-fpm-0.6-$PHP_VER/generate-fpm-patch"
>
> > 2) копируем патч в папочку debian/patches в папке php_5.xxx
> > добавляем в series << fpm.patch
> >http://jaaah.ru/php-fpm/series.html
> > * В php от dotdeb были проблемы с suhosin.patch
>
> > 3) далее правим debian/rules
> >http://jaaah.ru/php-fpm/rules.html
>
> > *Возникала проблема с PDO, решил следующим образом: --disable-pdo
> > Позже увидел, что dreamcat4 советует делать так: --with-pdo=shared,/
> > usr
>
> > 4) правим debian/control
> > добавляем описание пакета php-fpm
> >http://jaaah.ru/php-fpm/control.html
>
> > 5) добавляем в дирректорию debian/patches допольнитльеные файлы пакета
>
> > php5-fpm.dirs
> > php5-fpm.logrotate
> > php5-fpm.postinst
> > php5-fpm.prerm
>
> >http://jaaah.ru/php-fpm/php5-fpm_files.html
>
> > 6) Переходим в папку пакета и создаём папку для файлов патча
> > cd php_5.xxx && mkdir -p php_5.xxx/sapi/fpm
> > Копируем в эту папку следующие файлыhttp://jaaah.ru/php-fpm/sapi.tar.gz
> > убираем с них 755, оставляем только на configure.
>
> > Сборка:
>
> > 1) dch -i
>
> > 2) dpkg-buildpackage -sa
>
> > После сборки получаем стопку пакетов с долгожданным php-fpm.
> > Устанавливаем так: dpkg -i php5-common_5.2.11.dfsg.1-2_i386.deb php5-
> > fpm_5.2.11.dfsg.1-2_i386.deb
>
> > Пакеты тестируются на локальной машине уже 4 дня, проблем ни с чем
> > пока не возникало.
>
>
Kayo Ayanami
Re: Собрать deb-Ð акет php-fpm
November 20, 2009 10:54AM
Подскажите где и как можно захостить мою пакетизацию php-fpm? (source и
amd64)
Пытался на launchpad, но пока не разобрался, почему сервис не берет аплод.

2009/11/20 razor <razor@jaaah.ru>

> Насчёт тестирования поясню:
> Имелось ввиду тестирование стабильности работы самого FPM в php 5.2.11
> а не качества сборки.
> Имею в своём распоряжении небольшую сеть, потому довольно неплохо
> удаётся эмулировать нагрузочное тестирование, использую siege. Также
> ставил пакеты в виртуальной машине OpenVZ пробовал ограничивать
> ресурсы памяти, процессора и т.д. Патч ведёт себя очень достойно,
> сбоев в работе при нормальной настройке добиться так и не удалось.
>
> Как тестировать сборку пакетов, честно говоря толком не представляю.
> Потому руководствовался принципом, если нормально всё устанавливается
> и стабильно работает, то сборка нормальная :)
>
> Ранее просто были замечены проблемы с php-fpm под штатный php 5.2.6,
> демон нормально не выгружался. Правда там патч накладывал на php-cgi.
> В этой версии проблем с выгрузкой/загрузкой не наблюдается.
>
> Из замеченных недочётов:
> после установки пакета, запускающий файл php5-fpm ищет демона php-fpm
> не там где положено (фиксим путь в /etc/init.d/php5-fpm)
> также php собирался без mcrypt,imap,interbase
>
> На выходных, времени будет больше, потому планирую пересобрать пакеты
> заново с внесением соответствующих правок, а также директивой --with-
> pdo=shared,/usr (Thanks dreamcat4).
> Заменю эти исходники http://jaaah.ru/php-fpm/php5-5.2.11.dfsg.1.tar.gz
> правленными.
> Если есть интерес, пишите, выложу на всеобщее обозрение также и
> готовые пакеты.
>
>
> On 20 ноя, 05:10, Khazret Sapenov <sape...@gmail.com> wrote:
> > А как тестируем, если не секрет?
> >
> > 2009/11/19 razor <ra...@jaaah.ru>
> >
> > > Вставлю и свои 5 копеек.
> >
> > > Также собирал php-fpm как отдельный бинарник под Debian 5 Lenny i386,
> > > по дороге накидал инструкцию.
> >
> > > Собирал пакеты из репозиториев:
> > > sid --- debhttp://ftp.de.debian.org/debiansid main
> > > dotdeb --- debhttp://packages.dotdeb.orgstable all
> > > Основывалсяhttp://github.com/dreamcat4/php5-5.2.10.dfsg.1
> > > Итог более детально можно смотреть здесь --->
> > >http://jaaah.ru/php-fpm/php5-5.2.11.dfsg.1.tar.gz
> >
> > > Настройка среды:
> >
> > > Сначала создаём папку в которой будем пересобирать пакет и переходим в
> > > неё.
> > > *Лучше делать её не в tmp, т.к после перезагрузки сервера эта папка
> > > обычно очищается.
> >
> > > 1) Скачиваем необходимые по зависимостям пакеты, исходники.
> > > apt-get build-dep php5
> > > apt-get source php5
> > > получаем папку вида php5_2.xxx
> > > *Для php из sid - php5-5.2.11.dfsg.1
> > > *Для php из dotdeb - php5-5.2.11
> >
> > > 2) Также FPM необходимы два пакета libxml2-dev и libevent-dev, если их
> > > нет доставляем.
> > > apt-get install libxml2-dev
> >
> > > libevent-dev не старше версии 1.4-2, её можно поставить из sid /
> > > squeeze
> > > sources.list << debhttp://ftp.de.debian.org/debiansid main
> > > apt-get update
> > > apt-get install libevent-dev
> >
> > > *Желательно установить autoconf до версии 2.13
> > > apt-get autoconf2.13
> > > *Если пакет из sid / squeeze то необходимо обновить libtool до версии
> > > (2.2.6a-4)
> >
> > > Настройка пакета:
> >
> > > 1) Скачиваем патч необходимой версии, далее генерируем его
> > > wget "http://launchpad.net/php-fpm/master/0.6/+download/php-fpm-0.6-
> > > $PHP_VER.tar.gz";
> > > tar -zxvf "php-fpm-0.6-$PHP_VER.tar.gz"
> > > "php-fpm-0.6-$PHP_VER/generate-fpm-patch"
> >
> > > 2) копируем патч в папочку debian/patches в папке php_5.xxx
> > > добавляем в series << fpm.patch
> > >http://jaaah.ru/php-fpm/series.html
> > > * В php от dotdeb были проблемы с suhosin.patch
> >
> > > 3) далее правим debian/rules
> > >http://jaaah.ru/php-fpm/rules.html
> >
> > > *Возникала проблема с PDO, решил следующим образом: --disable-pdo
> > > Позже увидел, что dreamcat4 советует делать так: --with-pdo=shared,/
> > > usr
> >
> > > 4) правим debian/control
> > > добавляем описание пакета php-fpm
> > >http://jaaah.ru/php-fpm/control.html
> >
> > > 5) добавляем в дирректорию debian/patches допольнитльеные файлы пакета
> >
> > > php5-fpm.dirs
> > > php5-fpm.logrotate
> > > php5-fpm.postinst
> > > php5-fpm.prerm
> >
> > >http://jaaah.ru/php-fpm/php5-fpm_files.html
> >
> > > 6) Переходим в папку пакета и создаём папку для файлов патча
> > > cd php_5.xxx && mkdir -p php_5.xxx/sapi/fpm
> > > Копируем в эту папку следующие файлы
> http://jaaah.ru/php-fpm/sapi.tar.gz
> > > убираем с них 755, оставляем только на configure.
> >
> > > Сборка:
> >
> > > 1) dch -i
> >
> > > 2) dpkg-buildpackage -sa
> >
> > > После сборки получаем стопку пакетов с долгожданным php-fpm.
> > > Устанавливаем так: dpkg -i php5-common_5.2.11.dfsg.1-2_i386.deb php5-
> > > fpm_5.2.11.dfsg.1-2_i386.deb
> >
> > > Пакеты тестируются на локальной машине уже 4 дня, проблем ни с чем
> > > пока не возникало.
> >
> >
>



--
-------------------------------------------------------------
Kayo Ayanami

jabber: kayo@jabber.ru
gtalk-xmpp: kayo.k11.4@gmail.com
ya-xmpp: kayo-k11-4@ya.ru
sourceforge: phoenix11@users.sf.net
luaforge: phoenix11@users.luaforge.net
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 64
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready