Welcome! Log In Create A New Profile

Advanced

Не компилируется php 5.3.2 с php-fpm под Fedora 13

Posted by NT Man 
Не компилируется php 5.3.2 с php-fpm под Fedora 13
June 29, 2010 12:00PM
1) Установил пакеты: libxml2-devel openssl-devel bzip2-devel curl-
devel libjpeg-devel libpng-devel libevent-devel freetype-devel t1lib-
devel libc-client-devel libmcrypt-devel mysql-devel

2) Скачал сорцы с оф. сайта.

3) после
cd php-5.3.x
svn co http://svn.php.net/repository/php/php-src/branches/PHP_5_3/sapi/fpm
sapi/fpm
../buildconf --force

повылезало куча ошибок:
[root@mikhail-pc php-5.3.2]# ./buildconf --force
Forcing buildconf
buildconf: checking installation...
buildconf: autoconf version 2.65 (ok)
buildconf: Your version of autoconf likely contains buggy cache code.
Running vcsclean for you.
To avoid this, install autoconf-2.13.
Can't figure out your VCS, not cleaning.
rebuilding configure
ext/pdo_dblib/config.m4:56: warning: AC_CACHE_VAL(pdo_inc_path, ...):
suspicious cache-id, must contain _cv_ to be cached
.../../lib/autoconf/general.m4:1998: AC_CACHE_VAL is expanded from...
.../../lib/autoconf/general.m4:2019: AC_CACHE_CHECK is expanded from...
aclocal.m4:2738: PHP_CHECK_PDO_INCLUDES is expanded from...
ext/pdo_firebird/config.m4:48: warning:
AC_CACHE_VAL(pdo_inc_path, ...): suspicious cache-id, must contain
_cv_ to be cached
ext/pdo_mysql/config.m4:138: warning: AC_CACHE_VAL(pdo_inc_path, ...):
suspicious cache-id, must contain _cv_ to be cached
ext/pdo_oci/config.m4:196: warning: AC_CACHE_VAL(pdo_inc_path, ...):
suspicious cache-id, must contain _cv_ to be cached
ext/pdo_odbc/config.m4:44: warning: AC_CACHE_VAL(pdo_inc_path, ...):
suspicious cache-id, must contain _cv_ to be cached
ext/pdo_pgsql/config.m4:106: warning: AC_CACHE_VAL(pdo_inc_path, ...):
suspicious cache-id, must contain _cv_ to be cached
ext/pdo_sqlite/config.m4:16: warning: AC_CACHE_VAL(pdo_inc_path, ...):
suspicious cache-id, must contain _cv_ to be cached
ext/sqlite/config.m4:50: warning: AC_CACHE_VAL(pdo_inc_path, ...):
suspicious cache-id, must contain _cv_ to be cached
rebuilding main/php_config.h.in
autoheader: WARNING: Using auxiliary files such as `acconfig.h',
`config.h.bot'
autoheader: WARNING: and `config.h.top', to define templates for
`config.h.in'
autoheader: WARNING: is deprecated and discouraged.
autoheader:
autoheader: WARNING: Using the third argument of `AC_DEFINE' and
autoheader: WARNING: `AC_DEFINE_UNQUOTED' allows one to define a
template without
autoheader: WARNING: `acconfig.h':
autoheader:
autoheader: WARNING: AC_DEFINE([NEED_FUNC_MAIN], 1,
autoheader: [Define if a function `main' is needed.])
autoheader:
autoheader: WARNING: More sophisticated templates can also be
produced, see the
autoheader: WARNING: documentation.
ext/pdo_dblib/config.m4:56: warning: AC_CACHE_VAL(pdo_inc_path, ...):
suspicious cache-id, must contain _cv_ to be cached
.../../lib/autoconf/general.m4:1998: AC_CACHE_VAL is expanded from...
.../../lib/autoconf/general.m4:2019: AC_CACHE_CHECK is expanded from...
aclocal.m4:2738: PHP_CHECK_PDO_INCLUDES is expanded from...
ext/pdo_firebird/config.m4:48: warning:
AC_CACHE_VAL(pdo_inc_path, ...): suspicious cache-id, must contain
_cv_ to be cached
ext/pdo_mysql/config.m4:138: warning: AC_CACHE_VAL(pdo_inc_path, ...):
suspicious cache-id, must contain _cv_ to be cached
ext/pdo_oci/config.m4:196: warning: AC_CACHE_VAL(pdo_inc_path, ...):
suspicious cache-id, must contain _cv_ to be cached
ext/pdo_odbc/config.m4:44: warning: AC_CACHE_VAL(pdo_inc_path, ...):
suspicious cache-id, must contain _cv_ to be cached
ext/pdo_pgsql/config.m4:106: warning: AC_CACHE_VAL(pdo_inc_path, ...):
suspicious cache-id, must contain _cv_ to be cached
ext/pdo_sqlite/config.m4:16: warning: AC_CACHE_VAL(pdo_inc_path, ...):
suspicious cache-id, must contain _cv_ to be cached
ext/sqlite/config.m4:50: warning: AC_CACHE_VAL(pdo_inc_path, ...):
suspicious cache-id, must contain _cv_ to be cached

Уже сутки бьюсь. PHP 5.3.2 без php-fpm нормально собирается, так-же
нормально собирается PHP 5.3.3RC1.
Re: Не компилируется php 5.3.2 с php-fpm под Fedora 13
June 30, 2010 04:30AM
возьми собранные пакеты
ftp://centos.alt.ru/pub/php-fpm/5.3.2-1/RHEL/RPMS/
Re: Не компилируется php 5.3.2 с php-fpm под Fedora 13
June 30, 2010 12:10PM
hg_04 Wrote:
-------------------------------------------------------
> возьми собранные пакеты
> ftp://centos.alt.ru/pub/php-fpm/5.3.2-1/RHEL/RPMS/

Хороший репозитарий, сам им пользуюсь под CentOS-ю. Но под последней Федорой пакеты из него не ставятся выдавая ошибки:

[code]
could not do simulate: php-common-5.3.2-2.el5.i386 требуется libcrypto.so.6
php-common-5.3.2-2.el5.i386 требуется libcurl.so.3
php-common-5.3.2-2.el5.i386 требуется libssl.so.6
[/code]
Re: Не компилируется php 5.3.2 с php-fpm под Fedora 13
July 01, 2010 01:48AM
У меня была похожая проблема, сейчас уже не помню деталей.

Вы пробовали установить autoconf версии 2.13? мне это, вроде, помогло
Re: Не компилируется php 5.3.2 с php-fpm под Fedora 13
July 01, 2010 09:53AM
после Вашего совета попробовал, мне не помогло:
[code]
[root@mikhail-pc /]# yum install php-fpm
Загруженные плагины:presto, refresh-packagekit
epel | 3.4 kB 00:00
epel/primary_db | 2.6 MB 00:03
Настройка процесса установки
Разрешение зависимостей
--> Запуск проверки транзакции
---> Пакет php-fpm.i386 0:5.3.2-2.el5 должен Обновлено
--> Обработка зависимостей: php-common = 5.3.2-2.el5 для пакета: php-fpm-5.3.2-2.el5.i386
--> Обработка зависимостей: libssl.so.6 для пакета: php-fpm-5.3.2-2.el5.i386
--> Обработка зависимостей: libcrypto.so.6 для пакета: php-fpm-5.3.2-2.el5.i386
--> Запуск проверки транзакции
---> Пакет php-common.i386 0:5.3.2-2.el5 должен Обновлено
--> Обработка зависимостей: libcurl.so.3 для пакета: php-common-5.3.2-2.el5.i386
--> Обработка зависимостей: libssl.so.6 для пакета: php-common-5.3.2-2.el5.i386
--> Обработка зависимостей: libcrypto.so.6 для пакета: php-common-5.3.2-2.el5.i386
---> Пакет php-fpm.i386 0:5.3.2-2.el5 должен Обновлено
--> Обработка зависимостей: libssl.so.6 для пакета: php-fpm-5.3.2-2.el5.i386
--> Обработка зависимостей: libcrypto.so.6 для пакета: php-fpm-5.3.2-2.el5.i386
--> Окончание разрешения зависимостей
Ошибка: Пакет: php-fpm-5.3.2-2.el5.i386 (CentALT)
Необходимо: libcrypto.so.6
Ошибка: Пакет: php-common-5.3.2-2.el5.i386 (CentALT)
Необходимо: libcurl.so.3
Ошибка: Пакет: php-common-5.3.2-2.el5.i386 (CentALT)
Необходимо: libssl.so.6
Ошибка: Пакет: php-fpm-5.3.2-2.el5.i386 (CentALT)
Необходимо: libssl.so.6
Ошибка: Пакет: php-common-5.3.2-2.el5.i386 (CentALT)
Необходимо: libcrypto.so.6
Вы можете попробовать --skip-broken чтобы обойти проблему.
Вы можете попробовать запустить: rpm -Va --nofiles --nodigest
[/code]
Re: Не компилируется php 5.3.2 с php-fpm под Fedora 13
July 07, 2010 06:46AM
когдаже народ научится ставить из исходников

офф
Re: Не компилируется php 5.3.2 с php-fpm под Fedora 13
July 07, 2010 01:56PM
paranoidchaos Wrote:
-------------------------------------------------------
> когдаже народ научится
> ставить из исходников
>
> офф


Вопрос изначально был по сборке из исходников. У меня после наложения php-fpm на php 5.3.2 повылезало кучу ошибок см. самый первый пост.
Re: Не компилируется php 5.3.2 с php-fpm под Fedora 13
July 08, 2010 06:30AM
>>У меня после наложения php-fpm на php 5.3.2 повылезало кучу ошибок см. самый первый пост.

а зачем из свн тащим сорцы ??? они что стабильные ???? (ну и что там уже есть фпм)
я ставил стейбл достал патчи и пропатчил - всё норма
Re: Не компилируется php 5.3.2 с php-fpm под Fedora 13
July 10, 2010 03:50AM
paranoidchaos Wrote:
-------------------------------------------------------
> а зачем из свн тащим сорцы
> ??? они что стабильные ???? (ну
> и что там уже есть фпм)
> я ставил стейбл достал
> патчи и пропатчил - всё
> норма


Заходим на офсайт и что видим в разделе download?

[quote=http://php-fpm.org/download/]
PHP Core - PHP 5.3.x
PHP-FPM is finally in PHP core! It is based off of the 0.6.x series in Launchpad. It is most likely going to ship with PHP 5.4 (consider it "relatively stable" right now.)

It is available via SVN. To build FPM with your PHP 5.3.x, first unpack your PHP 5.3.x download and change into the directory, then follow these instructions:

For the "stable" version, which has been reported as production capable:

cd php-5.3.x
svn co http://svn.php.net/repository/php/php-src/branches/PHP_5_3/sapi/fpm sapi/fpm
./buildconf --force
./configure --enable-fpm ...your other configure options, etc...
make && make install

For the trunk version, which includes all the newest features and experimental options (use at your own risk):

cd php-5.3.x
svn co http://svn.php.net/repository/php/php-src/trunk/sapi/fpm sapi/fpm
./buildconf --force
./configure --enable-fpm ...your other configure options, etc...
make && make install
[/quote]
Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 65
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready