Welcome! Log In Create A New Profile

Advanced

Странность при обновлении с Debian 9 до Debian 10

August 11, 2019 03:04AM
При обновлении с Debian 9 Stretch до Debian 10 Buster nginx с официального репозитория (http://nginx.org/packages/mainline/debian/) не обновляется

Суть проблемы в том, что при стандартном обновлении системы (замена "stretch" на "buster" в sources.list, затем apt update, apt upgrade, apt dist-upgrage) пакет nginx остаётся на версии для stretch

sources.list
# nginx mainline
# http://nginx.org/ru/linux_packages.html
deb http://nginx.org/packages/mainline/debian/ buster nginx
deb-src http://nginx.org/packages/mainline/debian/ buster nginx

Все действия ниже делались на уже полностью обновлённой системе

cat /etc/*release*
PRETTY_NAME="Debian GNU/Linux 10 (buster)"
NAME="Debian GNU/Linux"
VERSION_ID="10"
VERSION="10 (buster)"

uname -a
Linux fanat1k.ru 4.19.0-5-amd64 #1 SMP Debian 4.19.37-5+deb10u2 (2019-08-08) x86_64 GNU/Linux

aptitude show nginx
Package: nginx
Version: 1.17.2-1~stretch
State: installed
Automatically installed: no
Priority: optional
Section: httpd
Maintainer: Sergey Budnevitch <sb@nginx.com>

apt reinstall nginx
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reinstallation of nginx is not possible, it cannot be downloaded.
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.

aptitude update
W: Package nginx had been marked to reinstall, but the file for the current installed version 1.17.2-1~stretch is not available
Hit http://mirror.timeweb.ru/mariadb/repo/10.4/debian buster InRelease
Hit http://security.debian.org buster/updates InRelease
Hit http://ftp.ru.debian.org/debian buster InRelease
Hit http://ftp.ru.debian.org/debian buster-backports InRelease
Hit http://ftp.ru.debian.org/debian buster-updates InRelease
Hit http://nginx.org/packages/mainline/debian buster InRelease
Hit https://packages.sury.org/php buster InRelease

aptitude install nginx
nginx is already installed at the requested version (1.17.2-1~stretch)
nginx is already installed at the requested version (1.17.2-1~stretch)
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.

И помогло лишь

aptitude install nginx-module-image-filter
The following NEW packages will be installed:
nginx-module-image-filter{b}
0 packages upgraded, 1 newly installed, 0 to remove and 3 not upgraded.
Need to get 80.1 kB of archives. After unpacking 133 kB will be used.
The following packages have unmet dependencies:
nginx-module-image-filter : Depends: nginx (= 1.17.2-1~buster) but 1.17.2-1~stretch is installed
The following actions will resolve these dependencies:

Keep the following packages at their current version:
1) nginx-module-image-filter [Not Installed]



Accept this solution? [Y/n/q/?] n
The following actions will resolve these dependencies:

Downgrade the following packages:
1) nginx [1.17.2-1~stretch (now) -> 1.17.2-1~buster (stable)]
2) nginx-module-geoip [1.17.2-1~stretch (now) -> 1.17.2-1~buster (stable)]



Accept this solution? [Y/n/q/?] Y
The following packages will be DOWNGRADED:
nginx nginx-module-geoip
The following NEW packages will be installed:
nginx-module-image-filter
0 packages upgraded, 1 newly installed, 2 downgraded, 0 to remove and 3 not upgraded.
Need to get 1,008 kB of archives. After unpacking 150 kB will be used.
Do you want to continue? [Y/n/?]
Get: 1 http://nginx.org/packages/mainline/debian buster/nginx amd64 nginx-module-geoip amd64 1.17.2-1~buster [75.9 kB]
Get: 2 http://nginx.org/packages/mainline/debian buster/nginx amd64 nginx amd64 1.17.2-1~buster [852 kB]
Get: 3 http://nginx.org/packages/mainline/debian buster/nginx amd64 nginx-module-image-filter amd64 1.17.2-1~buster [80.1 kB]
Fetched 1,008 kB in 1s (1,565 kB/s)
dpkg: warning: downgrading nginx-module-geoip from 1.17.2-1~stretch to 1.17.2-1~buster
(Reading database ... 75606 files and directories currently installed.)
Preparing to unpack .../nginx-module-geoip_1.17.2-1~buster_amd64.deb ...
Unpacking nginx-module-geoip (1.17.2-1~buster) over (1.17.2-1~stretch) ...
dpkg: warning: downgrading nginx from 1.17.2-1~stretch to 1.17.2-1~buster
Preparing to unpack .../nginx_1.17.2-1~buster_amd64.deb ...
Unpacking nginx (1.17.2-1~buster) over (1.17.2-1~stretch) ...
Selecting previously unselected package nginx-module-image-filter.
Preparing to unpack .../nginx-module-image-filter_1.17.2-1~buster_amd64.deb ...
Unpacking nginx-module-image-filter (1.17.2-1~buster) ...
Setting up nginx (1.17.2-1~buster) ...
Setting up nginx-module-geoip (1.17.2-1~buster) ...
----------------------------------------------------------------------

The GeoIP dynamic modules for nginx have been installed.
To enable these modules, add the following to /etc/nginx/nginx.conf
and reload nginx:

load_module modules/ngx_http_geoip_module.so;
load_module modules/ngx_stream_geoip_module.so;
Subject Author Posted

Странность при обновлении с Debian 9 до Debian 10

mmmisha August 11, 2019 03:04AM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 70
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready