Welcome! Log In Create A New Profile

Advanced

400 Bad Request

July 08, 2015 10:19AM
Добрый день!

Столкнулся с 400 ошибкой, увеличение параметра "large_client_header_buffers 32 16k;" не дает результата.
Включал error_log c уровнем ошибок info, ошибок связанных с этим запросом не нашел.
Включил error_log в режиме debug, но к сожалению так и не смог понять суть ошибки.

Привожу дополнительную информацию:

debug: http://pastebin.com/QJW2ZqSN

nginx -V: http://pastebin.com/WJ97eg0R

nginx-conf: http://pastebin.com/hPdZQpWh

По задумке nginx проксирует запросы на 5.5.5.5, а статический контент определенный в отдельном location пытается получить у varnish. Varnish в случае если запрошенного контента нет в кеше идет за ним на 10.0.2.3 на котором слушает nginx, и получает напрямую с сервера 5.5.5.5. В upstream блоке сделана защита на случай недоступности сервера с varnish, определен прямой backup сервер 5.5.5.5. Если я убираю с upstream блока backup-сервер, то схема работает без 400-ошибок. Ошибки выдает только на статический контент и бессистемно. Прошу помощи в поиске ошибки.
Subject Author Posted

400 Bad Request

Oleg Kupr July 08, 2015 10:19AM

Re: 400 Bad Request

Oleg Kupr July 08, 2015 10:35AM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 69
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready