Welcome! Log In Create A New Profile

Advanced

php-fastcgi stalling

Kiril Angov
April 10, 2009 09:03PM
Ok, here is a problem I had before but did not pay enough attention. I
have php-cgi spawned with a simple init.d script. 10 child processed.
I send one request to a PHP script let's say sloooooow.php, so the
browser waits for the page to load but the problem is that while that
page is loading, no other php page can be opened. That happens usually
when I do send a slow query through the phpMyAdmin but it can happen
on the production site also.

So, anybody know what the problem can be? Obviously php takes time to
respond but that should not stop nginx from serving other request. I
am pretty sure the problem is in PHP but what could it be?

Thanks in advance.
Subject Author Posted

php-fastcgi stalling

Kiril Angov April 10, 2009 09:03PM

Re: php-fastcgi stalling

SSSlippy April 11, 2009 09:39AM

Re: php-fastcgi stalling

Kiril Angov April 11, 2009 09:46AM

Re: php-fastcgi stalling

Eugene Lazutkin April 11, 2009 12:07PM

Re: php-fastcgi stalling

Kiril Angov April 11, 2009 01:55PM

Re: php-fastcgi stalling

Peter Langhans April 13, 2009 11:07AM

Re: php-fastcgi stalling

Kiril Angov April 13, 2009 01:17PM

Re: php-fastcgi stalling

Peter Langhans April 13, 2009 01:39PM

Re: php-fastcgi stalling

Kiril Angov April 13, 2009 01:49PM

Re: php-fastcgi stalling

Cliff Wells April 13, 2009 02:17PM

Re: php-fastcgi stalling

Denis Filimonov April 11, 2009 11:21AM

Re: php-fastcgi stalling

mike April 11, 2009 01:27PM

Re: php-fastcgi stalling

SSSlippy April 13, 2009 02:37PM

Re: php-fastcgi stalling

mike April 13, 2009 04:06PM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 58
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready