Welcome! Log In Create A New Profile

Advanced

Reverse Proxy - Issue in 0.8.36/.37

June 04, 2010 08:04PM
I can't really post my config with all information but I can post the specific configuration for the site's that have issues.

nginx 0.7.x does not show this problem.

If you configure a SSL reverse proxy:
server {
listen 192.168.12.2:1001;
ssl on;
ssl_certificate /usr/local/nginx/cert/apache-cert;
ssl_certificate_key /usr/local/nginx/cert/apache-key;
ssl_session_timeout 5m;
keepalive_timeout 15;
location / {
#limit_req zone=one burst=10;
proxy_read_timeout 300;
proxy_connect_timeout 300;
proxy_pass http://example.site.com:6043;
proxy_redirect off;
proxy_set_header Host $host;
proxy_set_header X-Real-IP $remote_addr;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_set_header X-Forwarded-Proto https;
}
}

Then it always gives 'Bad Gateway'. This issue was never present with 0.7.x

Setting proxy_pass to : https:// or http:// gives the same result.

Enabling or disabling buffering offers the same result.

Any ideas if this is a new bug? I have thus far, tested .36/.37 - I'm building .38 now to see if it's still an issue.

Any help would be greatly appreciated.
Subject Author Posted

Reverse Proxy - Issue in 0.8.36/.37

Kevin June 04, 2010 08:04PM

Re: Reverse Proxy - Issue in 0.8.36/.37

Kevin June 04, 2010 08:07PM

Re: Reverse Proxy - Issue in 0.8.36/.37

Kevin June 04, 2010 08:18PM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 59
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready