Welcome! Log In Create A New Profile

Advanced

Posts Not Appearing on Upstreams

Tony Holmes
April 06, 2009 02:11PM
I have (and love) nginx front ends that map users to one of many apache back
ends.

I had php uploads of 2M working. The files were getting posted and all was
well. I had a request to increase this to 20M and... it doesn't work.

I see successful posts on the front end (nginx) and back end (apache) AND
the php upload folder (/tmp/php_uploads) is touched and updated with the
time of the upload. No uploaded temporary file is created. I can change the
post/buffer size to/from 2M/20M to make it work/not work. It has to be
something obvious (and yes I've checked the back end apache/php to make sure
there are no post/upload limits).

location / {
proxy_set_header Host $host;
proxy_set_header X-Real-IP $remote_addr;
proxy_set_header X-Forwarded-For $remote_addr;
proxy_redirect off;
proxy_pass http://$server$request_uri;

client_max_body_size 8M;
client_body_buffer_size 8M;

proxy_buffering off;

proxy_connect_timeout 60;
proxy_send_timeout 300;
proxy_read_timeout 120;

proxy_pass_header Expires;
proxy_pass_header Cache-Control;
proxy_pass_header Last-Modified;
proxy_pass_header ETag;
proxy_pass_header Content-Length;
}

As soon as the file tips over 2M, it fails - which is highly suspicious but
I see no defaults that thwart that. Also, a 7MB upload takes about 30s so
the send timeout isn't failing.

What am I missing?

TIA!

Tony
Subject Author Posted

Posts Not Appearing on Upstreams

Tony Holmes April 06, 2009 02:11PM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 274
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready