April 20, 2010 04:22PM
Hello,

I am working on replacing our Kemp Loadbalancers with nginx and so far, things look good except for a minor issue. When a request comes into my server on the HTTP port, our JBoss server uses ACEGI to redirect to https://www.myserver.com/dev/home. The first time this redirection occurs, I'm sent to the URL of my proxy_pass directive.

I am running version 0.7.65 stable on CentOS 5.4. Here is my configuration file:

error_log /var/log/nginx_error.log;
worker_processes 2;

events {
worker_connections 4096;
}

http {
ssl_session_cache shared:SSL:10m;
ssl_session_timeout 10m;

upstream jboss_dev_servers {
server 192.168.2.86:8080;
server 192.168.2.87:8080;
}

server {
listen 80;
listen 443 default ssl;
access_log /var/log/nginx_access.log;
keepalive_timeout 70;
server_name www.myserver.com;
ssl_certificate dev.crt;
ssl_certificate_key dev.key;
ssl_protocols SSLv3 TLSv1;
ssl_ciphers HIGH:!ADH:!MD5;
location / {
proxy_pass http://jboss_dev_servers;
}
}
}

When a user types in www.myserver.com, they are redirected to https://jboss_dev_servers/dev/home. If I hit refresh, they are then directed to the proper url (https://www.myserver.com/dev/home/) and the web page displays.

Any ideas?
Subject Author Posted

Problems with upstream

mevans336 April 20, 2010 04:22PM

Re: Problems with upstream

Ryan Malayter April 20, 2010 05:56PM

Re: Problems with upstream

mevans336 April 20, 2010 09:22PM

Re: Problems with upstream

Ryan Malayter April 21, 2010 07:26AM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 73
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready