Welcome! Log In Create A New Profile

Advanced

Re: nginx upstream problem

April 14, 2010 10:45AM
Hi,

Ok, the failover problem is solved after I applied Maxim's suggestions.

Now the current problem is that nginx does not load balance equally between servers.

Under heavy load(300 clients) I killed 2 apache servers so apache3 was taking all the load. I put back online apache2 and now for some reason apache3 was getting few hits and most of the load was going to apache2. When I put back online apache1, it got most of the load, apache2 taking less load and apache3 almost no load at all.

Why the strange behavior? How do I make it load balance equally between the 3 apache servers? All the apache servers have identical hardware and software configuration.

Please help
Subject Author Posted

nginx upstream problem

izghitu April 13, 2010 04:28PM

Re: nginx upstream problem

Maxim Dounin April 13, 2010 06:10PM

Re: nginx upstream problem

izghitu April 13, 2010 06:19PM

Re: nginx upstream problem

izghitu April 14, 2010 10:45AM

Re: nginx upstream problem

Reinis Rozitis April 14, 2010 01:04PM

Re: nginx upstream problem

Maxim Dounin April 14, 2010 01:24PM

Re: nginx upstream problem

izghitu April 14, 2010 11:49AM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 73
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready