Welcome! Log In Create A New Profile

Advanced

Segfault for loopback resolver

March 20, 2010 10:28PM
Hi,

With a standard (i.e. no options) installation of 0.8.34 on my Linux
machine I get a segfault if the resolver named in the conf file is a
loopback address/IP, but the resolver does not exist. Other
non-existing resolvers don't cause a problem (they just hang, and
probably will time out), only loopback ones.

The debug log is :

2010/03/21 04:07:30 [debug] 4287#0: *3 http cl:-1 max:1048576
2010/03/21 04:07:30 [debug] 4287#0: *3 generic phase: 2
2010/03/21 04:07:30 [debug] 4287#0: *3 post rewrite phase: 3
2010/03/21 04:07:30 [debug] 4287#0: *3 generic phase: 4
2010/03/21 04:07:30 [debug] 4287#0: *3 generic phase: 5
2010/03/21 04:07:30 [debug] 4287#0: *3 access phase: 6
2010/03/21 04:07:30 [debug] 4287#0: *3 access phase: 7
2010/03/21 04:07:30 [debug] 4287#0: *3 post access phase: 8
2010/03/21 04:07:30 [debug] 4287#0: *3 http script var: "http"
2010/03/21 04:07:30 [debug] 4287#0: *3 http script copy: "://"
2010/03/21 04:07:30 [debug] 4287#0: *3 http script var: "google.com"
2010/03/21 04:07:30 [debug] 4287#0: *3 http script var: "/"
2010/03/21 04:07:30 [debug] 4287#0: *3 http init upstream, client timer: 0
2010/03/21 04:07:30 [debug] 4287#0: *3 epoll add event: fd:3 op:3
ev:80000005
2010/03/21 04:07:30 [debug] 4287#0: *3 posix_memalign:
0000000001A44DD0:4096 @16
2010/03/21 04:07:30 [debug] 4287#0: *3 http script copy: "Host: "
2010/03/21 04:07:30 [debug] 4287#0: *3 http script var: "google.com"
2010/03/21 04:07:30 [debug] 4287#0: *3 http script copy: "
"
2010/03/21 04:07:30 [debug] 4287#0: *3 http script copy: "Connection: close
"
2010/03/21 04:07:30 [debug] 4287#0: *3 http proxy header: "User-Agent:
curl/7.19.5 (x86_64-pc-linux-gnu) libcurl/7.19.5 OpenSSL/0.9.8g
zlib/1.2.3.3 libidn/1.15"
2010/03/21 04:07:30 [debug] 4287#0: *3 http proxy header: "Accept: */*"
2010/03/21 04:07:30 [debug] 4287#0: *3 http proxy header:
"Proxy-Connection: Keep-Alive"
2010/03/21 04:07:30 [debug] 4287#0: *3 http proxy header:
"GET / HTTP/1.0
Host: google.com
Connection: close
User-Agent: curl/7.19.5 (x86_64-pc-linux-gnu) libcurl/7.19.5
OpenSSL/0.9.8g zlib/1.2.3.3 libidn/1.15
Accept: */*
Proxy-Connection: Keep-Alive

"
2010/03/21 04:07:30 [debug] 4287#0: *3 http cleanup add: 0000000001A44E60
2010/03/21 04:07:30 [debug] 4287#0: *3 http finalize request: -4, "/?"
a:1, c:2
2010/03/21 04:07:30 [debug] 4287#0: *3 http request count:2 blk:0
2010/03/21 04:07:30 [debug] 4287#0: *3 http run request: "/?"
2010/03/21 04:07:30 [debug] 4287#0: *3 http upstream check client, write
event:1, "/"
2010/03/21 04:07:30 [debug] 4287#0: *3 http upstream recv(): -1 (11:
Resource temporarily unavailable)
2010/03/21 04:07:30 [alert] 4275#0: worker process 4287 exited on signal 11


I've not got time to look into and write a patch for it right now, but
will do if no-one gets around to it at some point.

Thanks,

Marcus.



_______________________________________________
nginx mailing list
nginx@nginx.org
http://nginx.org/mailman/listinfo/nginx
Subject Author Posted

Segfault for loopback resolver

Eugaia March 20, 2010 10:28PM

Re: Segfault for loopback resolver

Maxim Dounin March 24, 2010 10:14PM

Re: Segfault for loopback resolver (CONFIRMED)

Chaos Wang September 08, 2010 12:30AM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 72
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready