Welcome! Log In Create A New Profile

Advanced

Re: PHP_SELF not set

September 11, 2009 05:13PM
vesperto Wrote:

> The latest stable version is 7.6.1, you could try
> compiling from
> source. What's Ubuntu's default fastcgi_params
> file? Here are a few on
> mine:
>
> fastcgi_param SCRIPT_NAME
> $fastcgi_script_name;
> fastcgi_param DOCUMENT_URI $document_uri;
>
> Are those on yours? I've commented out
> fastcgi_param DOCUMENT_ROOT
> because i define that under each virtual host.
> Your nginx.conf could
> also provide some clues, as well as PHP's error
> log (set php.ini to
> log to a file) and nginx's error.log as well.

Thanks, I do have SCRIPT_NAME defined, and it is getting passed correctly. There seems to be something special about PHP_SELF; it isn't defined in my nginx.conf or in my fastcgi_params, and when I dump $_SERVER from php it's set to a zero-length string. Again, explicitly setting it in nginx.conf or fastcgi_params doesn't do anything.

I can make cacti work by replacing all references to PHP_SELF with REQUEST_URI, but that's not a very maintainable solution.
Subject Author Posted

PHP_SELF not set

durist September 11, 2009 04:15PM

Re: PHP_SELF not set

vesperto September 11, 2009 04:52PM

Re: PHP_SELF not set

durist September 11, 2009 05:13PM

Re: PHP_SELF not set

vesperto September 11, 2009 05:40PM

Re: PHP_SELF not set

durist September 11, 2009 06:10PM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 74
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready