Welcome! Log In Create A New Profile

Advanced

document root problem?

March 12, 2010 06:17PM
I am running a wordpress setup with nginx and I have an error that I haven't been able to track down. In my log files I'm getting a lot of errors like this:

"[error] 17434#0: *140 open() "/home/tcb/public_htmlon" failed (2: No such file or directory) ... "

This is causing a lot of my pages to not load. My document root is /home/tcb/public_html without the "on" This error is not isolated to any particular file or script (i.e. getting it for phpmyadmin, wordpress pages, etc) but it is not consistent.

For example - here is a rewrite rule I have in place: (using the wordpress plugin and rewrites)

location / {
rewrite log on; //side question - where does this write too?
rewrite ^/([0-9]+)/([_0-9a-zA-Z-]+)/?$ $theme/listing.php?mls=$1 last;
rewrite ^/([0-9]+)/([_0-9a-zA-Z-]+)+.html?$ $theme/listing.php?mls=$1 last;
rewrite ^/([0-9]+)/?$ $theme/listing.php?mls=$1 last;
try_files $uri $uri/ @wordpress;
}

This address works - http://sellsutah.net/938326/210-summit-dr-smithfield-utah/
and this one fails - http://sellsutah.net/784004/1290-e-1550-n-north-logan-utah/
with a 404 file not found error

The second one puts an entry in the error log with the error I gave above.

I very happy with the speed increase from nginx - but frustrated by this issue

Thank you

Flash
Subject Author Posted

document root problem?

flash March 12, 2010 06:17PM

Re: document root problem?

Maxim Dounin March 12, 2010 06:42PM

Re: document root problem?

Dave Evans March 12, 2010 06:44PM

Re: document root problem?

flash March 12, 2010 07:44PM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 83
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready