Welcome! Log In Create A New Profile

Advanced

Re: glype 404 error nginx/0.7.59+ fastcgi

February 07, 2010 05:49AM
Thanks so muchRob. Following your helpful config files and this nice, noob-friendly tutorial:

http://guvnr.com/web/web-dev/install-nginx-not-apache/

at last I could manage to get nginx running glype.

I put my working config files here just in case they can help others to bang their head on the issue (use Rob's for fastcgi_params):

nginx.conf
[code]
user www-data www-data;
worker_processes 4;

events {
worker_connections 1024;
}

http {
include mime.types;
default_type application/octet-stream;

sendfile on;
tcp_nopush on;
tcp_nodelay off;
keepalive_timeout 5;

gzip on;
gzip_comp_level 2;
gzip_proxied any;
gzip_types text/plain text/css application/x-javascript text/xml application/xml $

include /usr/local/nginx/sites-enabled/*;
include /usr/local/nginx/conf/fastcgi_params;

}
[/code]

vhost1 (example.com)
[code]
server {
listen 80;
server_name www.example.com;
rewrite ^/(.*) http://example.com/$1 permanent;
}

server {
listen 80;
server_name example.com;
access_log /home/public_html/example.com/log/access.log;
error_log /home/public_html/example.com/log/error.log;


root /home/public_html/example.com/public/;
index index.html index.php;
autoindex on;

# pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000

location ~ ^.+\.php$ {
fastcgi_pass 127.0.0.1:9000;
fastcgi_index index.php;
}

location ~* ^.+\.(jpg|jpeg|gif|png)$ {
access_log off;
expires 30d;
}

}
[/code]

As you see these are very basic files, but it took me one week to get them up and running.

Another thing worth noting is that when I used a tweaked version of Glype which happened to lacked main.js, I encountered 404 error (I guess it was the main reason at the first place!) However, apache2 did not complaint about the lacking file it and runs the very same tweaked script.

Now down to optimisation. Hope it does not suffer from bloating behaviours of apache :)
Subject Author Posted

glype 404 error nginx/0.7.59+ fastcgi

zereshk February 04, 2010 10:51PM

Re: glype 404 error nginx/0.7.59+ fastcgi

Rob Schultz February 05, 2010 09:02AM

Re: glype 404 error nginx/0.7.59+ fastcgi

zereshk February 05, 2010 10:37PM

Re: glype 404 error nginx/0.7.59+ fastcgi

Rob Schultz February 06, 2010 03:56AM

Re: glype 404 error nginx/0.7.59+ fastcgi

zereshk February 06, 2010 04:22AM

Re: glype 404 error nginx/0.7.59+ fastcgi

Rob Schultz February 06, 2010 01:28PM

Re: glype 404 error nginx/0.7.59+ fastcgi

zereshk February 07, 2010 05:49AM

Re: glype 404 error nginx/0.7.59+ fastcgi

zereshk February 07, 2010 05:54AM

Re: glype 404 error nginx/0.7.59+ fastcgi

Rob Schultz February 07, 2010 12:30PM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 65
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready