Rob Schultz
February 05, 2010 09:02AM
Go into your glype admin page and turn off Path info URL encoding
option or setup Path info via http://wiki.nginx.org/NginxHttpFcgiModule#fastcgi_split_path_info

Sent from my iPhone

On Feb 4, 2010, at 11:34 PM, "zereshk" <nginx-forum@nginx.us> wrote:

> Hi nginx gurus,
> I have this weird problem:
>
> After following carefully this tutorial:
> http://www.linuxspace.org/archives/1576
>
> I could get my glype script page, but it does not work: The nginx
> gives a '404 Not Found' whenever I try to get a url through glype
> proxy.
>
> You can see the problem here:
> http://www.bigheid.info/
>
> Here is my nginx.conf
>
>
> #user
> user www;
> #numbers of worker processes
> worker_processes 2;
>
> #path to nginx.pid
> pid /home/www/bigheid.info/nginx.pid;
>
> events
> {
> worker_connections 1024;
> }
>
> http
> {
> include mime.types;
> default_type application/octet-stream;
>
> #log format
> log_format main '$remote_addr - $remote_user [$time_local]
> "$request" '
> '$status $body_bytes_sent "$http_referer" '
> '"$http_user_agent" "$http_x_forwarded_for"';
>
> sendfile on;
> tcp_nopush on;
>
> #keepalive_timeout 0;
> keepalive_timeout 65;
>
> #compression
> gzip on;
> gzip_min_length 1100;
> gzip_buffers 4 8k;
> gzip_types text/plain;
> gzip_comp_level 3;
> gzip_proxied any;
>
> #configure virtual server
> server {
>
> #port
> listen 80;
>
> #server name
> server_name localhost;
>
> #coding
> charset utf-8;
>
> #main directory where is site
> root /home/www/bigheid.info/public;
>
> #LOGS
> #------------------------------------------------------------------
> access_log /home/www/bigheid.info/log/localhost.access.log;
> error_log /home/www/bigheid.info/log/error.log;
> access_log /home/www/bigheid.info/log/access.log combined;
>
> #------------------------------------------------------------------
> #location
> location / {
> root /home/www/bigheid.info/public;
> index index.html index.htm index.php;
> }
>
> error_page 404 /404.html;
>
> # redirect server error pages to the static page /50x.html
> #
> error_page 500 502 503 504 /50x.html;
> location = /50x.html {
> root html;
> }
>
>
>
> # pass the PHP scripts to FastCGI server listening on
> 127.0.0.1:9000
> #PHP + CGI + some parametrs
> location ~ \.php$ {
> fastcgi_pass 127.0.0.1:9000;
> fastcgi_index index.php;
> fastcgi_param SCRIPT_FILENAME /home/www/bigheid.info/
> public/$fastcgi_script_name;
> include fastcgi_params;
> fastcgi_param QUERY_STRING $query_string;
> fastcgi_param REQUEST_METHOD $request_method;
> fastcgi_param CONTENT_TYPE $content_type;
> fastcgi_param CONTENT_LENGTH $content_length;
>
> }
>
>
>
> And my fastcgi_params:
>
>
>
> fastcgi_param QUERY_STRING $query_string;
> fastcgi_param REQUEST_METHOD $request_method;
> fastcgi_param CONTENT_TYPE $content_type;
> fastcgi_param CONTENT_LENGTH $content_length;
>
> fastcgi_param SCRIPT_NAME $fastcgi_script_name;
> fastcgi_param REQUEST_URI $request_uri;
> fastcgi_param DOCUMENT_URI $document_uri;
> fastcgi_param DOCUMENT_ROOT $document_root;
> fastcgi_param SERVER_PROTOCOL $server_protocol;
>
> fastcgi_param GATEWAY_INTERFACE CGI/1.1;
> fastcgi_param SERVER_SOFTWARE nginx/$nginx_version;
>
> fastcgi_param REMOTE_ADDR $remote_addr;
> fastcgi_param REMOTE_PORT $remote_port;
> fastcgi_param SERVER_ADDR $server_addr;
> fastcgi_param SERVER_PORT $server_port;
> fastcgi_param SERVER_NAME $server_name;
>
> # PHP only, required if PHP was built with --enable-force-cgi-redirect
> fastcgi_param REDIRECT_STATUS 200;
>
>
> Let me know if you need to know my other configurations.
>
> Actually, nginx is very little known among proxy community (take a
> look at proxy.org and you'll see).
>
> Your clues are very much appreciated. I promise to spread the word
> if you could solve this nasty problem.
> Thank you,
> Zereshk
>
> Posted at Nginx Forum: http://forum.nginx.org/read.php?2,50781,50781#msg-50781
>
>
> _______________________________________________
> nginx mailing list
> nginx@nginx.org
> http://nginx.org/mailman/listinfo/nginx

_______________________________________________
nginx mailing list
nginx@nginx.org
http://nginx.org/mailman/listinfo/nginx
Subject Author Posted

glype 404 error nginx/0.7.59+ fastcgi

zereshk February 04, 2010 10:51PM

Re: glype 404 error nginx/0.7.59+ fastcgi

Rob Schultz February 05, 2010 09:02AM

Re: glype 404 error nginx/0.7.59+ fastcgi

zereshk February 05, 2010 10:37PM

Re: glype 404 error nginx/0.7.59+ fastcgi

Rob Schultz February 06, 2010 03:56AM

Re: glype 404 error nginx/0.7.59+ fastcgi

zereshk February 06, 2010 04:22AM

Re: glype 404 error nginx/0.7.59+ fastcgi

Rob Schultz February 06, 2010 01:28PM

Re: glype 404 error nginx/0.7.59+ fastcgi

zereshk February 07, 2010 05:49AM

Re: glype 404 error nginx/0.7.59+ fastcgi

zereshk February 07, 2010 05:54AM

Re: glype 404 error nginx/0.7.59+ fastcgi

Rob Schultz February 07, 2010 12:30PM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 76
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready