Welcome! Log In Create A New Profile

Advanced

TLS record lost -- AapacheBenchmark-session is not closed

November 14, 2022 07:53AM
Using NGINX-1.21.6 as TLS test-server with remote Apache-Benchmark(AB) test-client
Both Server and Client are on Ubuntu20.04
For >6 workers on NGINX and >16 concurrent sessions AB sessions (ab -n400 -c32 https://)
a couple of test-sessions are not closed and AB reports timeout for them.
TCPDUMP analizys discover the a TLS-Record is lost == Not Sent by NGINX (or NET-stack) towatd OpenSSL and out to NET-dev.

Anybody have seen same/similar?
Thanks
Subject Author Posted

TLS record lost -- AapacheBenchmark-session is not closed

ymarkman November 14, 2022 07:53AM

Re: TLS record lost -- AapacheBenchmark-session is not closed

Sergey A. Osokin November 14, 2022 09:50AM

Re: TLS record lost -- AapacheBenchmark-session is not closed

ymarkman November 14, 2022 10:35AM

Re: TLS record lost -- AapacheBenchmark-session is not closed

ymarkman November 15, 2022 10:25AM

Re: TLS record lost -- AapacheBenchmark-session is not closed

Sergey A. Osokin November 15, 2022 10:44AM

Re: TLS record lost -- AapacheBenchmark-session is not closed

ymarkman November 15, 2022 11:34AM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 109
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready