Welcome! Log In Create A New Profile

Advanced

Re: least_conn not working for me

December 25, 2020 08:04PM
Wanted to follow up to say that you were spot on.

The file was ~800mb and it was indeed caching the whole thing. We could see the file get served to nginx and then nginx continued to serve to the client.

We were able to show that it was indeed doing least_conn by downloading a file that was multiple gigabytes in size. This exceeded the buffer and would tie up that connection. When that happened we would then see connections get routed to the other upstream.

Thanks so much for helping educate us.
Subject Author Posted

least_conn not working for me

kenneth.s.brooks December 23, 2020 10:28AM

Re: least_conn not working for me

kenneth.s.brooks December 23, 2020 10:57AM

Re: least_conn not working for me

Maxim Dounin December 23, 2020 12:16PM

Re: least_conn not working for me

kenneth.s.brooks December 23, 2020 12:36PM

Re: least_conn not working for me

kenneth.s.brooks December 23, 2020 01:12PM

Re: least_conn not working for me

pbooth December 23, 2020 02:08PM

Re: least_conn not working for me

Maxim Dounin December 23, 2020 04:28PM

Re: least_conn not working for me

kenneth.s.brooks December 23, 2020 04:44PM

Re: least_conn not working for me

philw December 23, 2020 05:00PM

Re: least_conn not working for me

Maxim Dounin December 23, 2020 05:16PM

Re: least_conn not working for me

kenneth.s.brooks December 23, 2020 05:40PM

Re: least_conn not working for me

kenneth.s.brooks December 25, 2020 08:04PM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 55
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready