Welcome! Log In Create A New Profile

Advanced

Nginx crashing my site when adding new config

August 19, 2020 02:53PM
Hello,

I am trying to create a config for a process called Isso, when I do create the config as you can see below Nginx crashes my site. If I remove the Isso Nginx config my site comes back online.
```
nginx.service - A high performance web server and a reverse proxy server
Loaded: loaded (/lib/systemd/system/nginx.service; enabled; vendor preset: en
Active: failed (Result: exit-code) since Wed 2020-08-19 18:04:04 UTC; 11s ago
Docs: man:nginx(8)
Process: 8596 ExecStop=/sbin/start-stop-daemon --quiet --stop --retry QUIT/5 -
Process: 20499 ExecStartPre=/usr/sbin/nginx -t -q -g daemon on; master_process
Main PID: 335 (code=exited, status=0/SUCCESS)
```

My Nginx config located in /etc/nginx/sites-available and linked to sites-enabled.

```
server {
listen 80;
listen [::]:80;
server_name isso.mydomain.tld;
return 301 https://isso.mydomain.tld$request_uri;

access_log /dev/null;
error_log /dev/null;
}
server {
listen 443 ssl http2;
listen [::]:443 ssl http2;
server_name isso.mydomain.tld;

access_log /var/log/nginx/isso-access.log;
error_log /var/log/nginx/isso-error.log;

ssl_certificate /etc/nginx/https/fullchain.pem;
ssl_certificate_key /etc/nginx/https/key.pem;


location / {
proxy_set_header Host $http_host;
proxy_set_header X-Real-IP $remote_addr;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_set_header X-Forwarded-Proto $scheme;
proxy_pass http://localhost:8080;
}
}
```
Subject Author Posted

Nginx crashing my site when adding new config

CranberryPie August 19, 2020 02:53PM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 78
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready