Welcome! Log In Create A New Profile

Advanced

Found Nginx 1.19.0 stopped but no idea what happened

July 01, 2020 02:56AM
hello everybody,

I'm using nginx 1.19.0 with ModSec on Centos 7. The other day it
happened twice that nginx was stopped. No idea what could cause the
issue but i found on the error.log the following:

So it seems the server was running out of memory and it stopped nginx?
Thank you

2020/06/29 17:23:39 [alert] 1890#1890: sendmsg() failed (9: Bad file descriptor)
2020/06/29 17:23:39 [alert] 1890#1890: sendmsg() failed (9: Bad file descriptor)
2020/06/29 17:23:39 [alert] 1890#1890: sendmsg() failed (9: Bad file descriptor)
2020/06/29 17:24:28 [alert] 1890#1890: fork() failed while spawning
"worker process" (12: Cannot allocate memory)
2020/06/29 17:24:28 [alert] 1890#1890: sendmsg() failed (9: Bad file descriptor)
2020/06/29 17:24:28 [alert] 1890#1890: sendmsg() failed (9: Bad file descriptor)
2020/06/29 17:24:28 [alert] 1890#1890: fork() failed while spawning
"cache manager process" (12: Cannot allocate memory)
2020/06/29 17:24:28 [alert] 1890#1890: sendmsg() failed (9: Bad file descriptor)
2020/06/29 17:24:28 [alert] 1890#1890: sendmsg() failed (9: Bad file descriptor)
2020/06/29 18:10:35 [notice] 2461#2461: ModSecurity-nginx v1.0.1
(rules loaded inline/local/remote: 0/19826/0)
2020/06/29 18:10:35 [emerg] 2461#2461: bind() to 0.0.0.0:443 failed
(98: Address already in use)
2020/06/29 18:10:35 [emerg] 2461#2461: bind() to 0.0.0.0:80 failed
(98: Address already in use)
2020/06/29 18:10:35 [emerg] 2461#2461: bind() to 0.0.0.0:443 failed
(98: Address already in use)
2020/06/29 18:10:35 [emerg] 2461#2461: bind() to 0.0.0.0:80 failed
(98: Address already in use)
2020/06/29 18:10:35 [emerg] 2461#2461: bind() to 0.0.0.0:443 failed
(98: Address already in use)
2020/06/29 18:10:35 [emerg] 2461#2461: bind() to 0.0.0.0:80 failed
(98: Address already in use)
2020/06/29 18:10:35 [emerg] 2461#2461: bind() to 0.0.0.0:443 failed
(98: Address already in use)
2020/06/29 18:10:35 [emerg] 2461#2461: bind() to 0.0.0.0:80 failed
(98: Address already in use)
2020/06/29 18:10:35 [emerg] 2461#2461: bind() to 0.0.0.0:443 failed
(98: Address already in use)
2020/06/29 18:10:35 [emerg] 2461#2461: bind() to 0.0.0.0:80 failed
(98: Address already in use)
2020/06/29 18:10:35 [emerg] 2461#2461: still could not bind()
2020/06/29 18:11:16 [alert] 1890#1890: unlink() "/run/nginx.pid"
failed (2: No such file or directory)
2020/06/29 18:11:48 [notice] 927#927: ModSecurity-nginx v1.0.1 (rules
loaded inline/local/remote: 0/19826/0)
_______________________________________________
nginx mailing list
nginx@nginx.org
http://mailman.nginx.org/mailman/listinfo/nginx
Subject Author Posted

Found Nginx 1.19.0 stopped but no idea what happened

Evald80 July 01, 2020 02:56AM

Re: Found Nginx 1.19.0 stopped but no idea what happened

Evald80 July 02, 2020 08:28AM

Re: Found Nginx 1.19.0 stopped but no idea what happened

Francis Daly July 02, 2020 09:06AM

Re: Found Nginx 1.19.0 stopped but no idea what happened

J.R. July 02, 2020 09:56AM

Re: Found Nginx 1.19.0 stopped but no idea what happened

Evald80 July 02, 2020 12:17PM

Re: Found Nginx 1.19.0 stopped but no idea what happened

Evald80 July 06, 2020 04:17AM

Re: Found Nginx 1.19.0 stopped but no idea what happened

Francis Daly July 07, 2020 11:54AM

Re: Found Nginx 1.19.0 stopped but no idea what happened

Evald80 July 08, 2020 06:10AM

Re: Found Nginx 1.19.0 stopped but no idea what happened

Francis Daly July 09, 2020 01:04PM

Re: Found Nginx 1.19.0 stopped but no idea what happened

Evald80 July 13, 2020 03:19AM

Re: Found Nginx 1.19.0 stopped but no idea what happened

Evald80 July 15, 2020 07:56AM

Re: Found Nginx 1.19.0 stopped but no idea what happened

Evald80 August 03, 2020 05:24AM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 85
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready