Welcome! Log In Create A New Profile

Advanced

Re: nginx Digest, Vol 127, Issue 25

Devika Awasthi
May 25, 2020 06:26AM
can I be unsubscribed from this list please?

‪On Mon, May 25, 2020 at 7:27 AM ‫عـڇـڗڼـٱ ڼـڣـټـږڨۦے‬‎ <
qusaialbreazet1995@gmail.com> wrote:‬

>
>
> في السبت، 23 أيار 2020 3:00 م <nginx-request@nginx.org> كتب:
>
>> Send nginx mailing list submissions to
>> nginx@nginx.org
>>
>> To subscribe or unsubscribe via the World Wide Web, visit
>> http://mailman.nginx.org/mailman/listinfo/nginx
>> or, via email, send a message with subject or body 'help' to
>> nginx-request@nginx.org
>>
>> You can reach the person managing the list at
>> nginx-owner@nginx.org
>>
>> When replying, please edit your Subject line so it is more specific
>> than "Re: Contents of nginx digest..."
>>
>>
>> Today's Topics:
>>
>> 1. RE: nginx 1.18.0 does not reload on ubuntu 18.04 (Zach Mitchell)
>> 2. Quick question on NGINX cache (Alex Evonosky)
>>
>>
>> ----------------------------------------------------------------------
>>
>> Message: 1
>> Date: Fri, 22 May 2020 17:50:06 +0000
>> From: Zach Mitchell <zlmitche@syr.edu>
>> To: "nginx@nginx.org" <nginx@nginx.org>
>> Subject: RE: nginx 1.18.0 does not reload on ubuntu 18.04
>> Message-ID: <82f864a533724b8f81a1a0bd438f29b8@syr.edu>
>> Content-Type: text/plain; charset="utf-8"
>>
>> Finally figured it out. I enabled debug mode on the error log. It turns
>> out setting the worker_rlimit_nofile in the nginx.conf was not working. On
>> nginx startup it would say ?getrlimit(RLIMIT_NOFILE): 1024:4096". I had
>> already checked the security limits and they were set? I confirmed that the
>> workers were using the worker_rlimit_nofile correctly, but the master was
>> not able to reload correctly.
>>
>> Solution:
>> Add LimitNOFILE to the system service, on the next nginx start up the
>> debug logs show the correct nolimt! Reloading now works! Hurray!
>>
>> [Service]
>> LimitNOFILE=60000
>>
>>
>> Zach
>>
>> From: nginx <nginx-bounces@nginx.org> On Behalf Of Zach Mitchell
>> Sent: Friday, May 22, 2020 11:49 AM
>> To: nginx@nginx.org
>> Subject: RE: nginx 1.18.0 does not reload on ubuntu 18.04
>>
>> I?ve also tried that ?ExecReload=/bin/kill -s HUP $MAINPID? which doesn?t
>> work either.
>>
>> I?m testing by adding a new location rule and then reloading and it never
>> gets picked up, I have to restart the nginx process and then it finally
>> gets the new config.
>>
>> Zach
>>
>> From: nginx <nginx-bounces@nginx.org<mailto:nginx-bounces@nginx.org>> On
>> Behalf Of Moshe Katz
>> Sent: Friday, May 22, 2020 11:31 AM
>> To: nginx@nginx.org<mailto:nginx@nginx.org>
>> Subject: Re: nginx 1.18.0 does not reload on ubuntu 18.04
>>
>>
>> I installed nginx on Ubuntu 18.04 from the nginx official repository, and
>> the provided systemd service file is much simpler than yours. It looks like
>> this:
>>
>> ```
>> [Unit]
>> Description=nginx - high performance web server
>> Documentation=http://nginx.org/en/docs/
>> After=network-online.target remote-fs.target nss-lookup.target
>> Wants=network-online.target
>>
>> [Service]
>> Type=forking
>> PIDFile=/var/run/nginx.pid
>> ExecStart=/usr/sbin/nginx -c /etc/nginx/nginx.conf
>> ExecReload=/bin/kill -s HUP $MAINPID
>> ExecStop=/bin/kill -s TERM $MAINPID
>>
>> [Install]
>> WantedBy=multi-user.target
>> ```
>>
>> You should see if something more like that works for you.
>>
>>
>> On Fri, May 22, 2020 at 10:59 AM Zach Mitchell <zlmitche@syr.edu<mailto:
>> zlmitche@syr.edu>> wrote:
>> I'm using a nginx 1.18.0 and 1.16.1 and when i perform a systemctl
>> restart nginx, it does not actually reload the configs. nginx -s reload
>> does not work either. Am i missing a configure flag that allows this to
>> work properly?
>>
>> Here is my nginx -V
>>
>> built by gcc 5.4.0 20160609 (Ubuntu 5.4.0-6ubuntu1~16.04.12)
>> built with OpenSSL 1.1.1g 21 Apr 2020
>> TLS SNI support enabled
>> configure arguments: --prefix=/usr/local/nginx
>> --modules-path=/usr/lib/nginx/modules
>> --http-client-body-temp-path=/var/cache/nginx/client_temp
>> --http-proxy-temp-path=/var/cache/nginx/proxy_temp
>> --http-fastcgi-temp-path=/var/cache/nginx/fastcgi_temp
>> --http-uwsgi-temp-path=/var/cache/nginx/uwsgi_temp
>> --http-scgi-temp-path=/var/cache/nginx/scgi_temp --with-threads
>> --with-file-aio --with-http_ssl_module --with-http_v2_module
>> --with-http_stub_status_module --with-http_gunzip_module
>> --with-http_gzip_static_module --with-http_stub_status_module
>> --with-http_realip_module --with-compat --with-pcre=../pcre-8.44
>> --with-pcre-jit --with-zlib=../zlib-1.2.11 --with-openssl=../openssl-1.1.1g
>> --with-openssl-opt=no-nextprotoneg --add-module=../ngx_cache_purge-2..3
>>
>> Here is my systemd nginx.service
>>
>> [Unit]
>> Description=The NGINX HTTP and reverse proxy server
>> After=syslog.target network.target remote-fs.target nss-lookup.target
>>
>> [Service]
>> Type=forking
>> PIDFile=/usr/local/nginx/logs/nginx.pid
>> ExecStartPre=/usr/local/sbin/nginx -t -q -g 'daemon on; master_process
>> on;'
>> ExecStart=/usr/local/sbin/nginx -g 'daemon on; master_process on;'
>> ExecReload=/usr/local/sbin/nginx -g 'daemon on; master_process on;' -s
>> reload
>> ExecStop=/bin/kill -s QUIT $MAINPID
>> PrivateTmp=true
>>
>> [Install]
>> WantedBy=multi-user.target
>>
>> I've got a workaround, which i spawn a 2nd process and wait then kill the
>> old, but what is the deal?
>>
>> ExecReload=/bin/bash -c "/bin/kill -USR2 $MAINPID && /bin/sleep 5 &&
>> /bin/kill -WINCH $MAINPID && /bin/sleep 5 && /bin/kill -QUIT $MAINPID"
>>
>> I appreciate the help! Thanks.
>>
>> Zach
>> _______________________________________________
>> nginx mailing list
>> nginx@nginx.org<mailto:nginx@nginx.org>
>> http://mailman.nginx.org/mailman/listinfo/nginx
>> -------------- next part --------------
>> An HTML attachment was scrubbed...
>> URL: <
>> http://mailman.nginx.org/pipermail/nginx/attachments/20200522/e5652a44/attachment-0001.htm
>> >
>>
>> ------------------------------
>>
>> Message: 2
>> Date: Fri, 22 May 2020 21:31:46 -0400
>> From: Alex Evonosky <alex.evonosky@gmail.com>
>> To: nginx@nginx.org
>> Subject: Quick question on NGINX cache
>> Message-ID:
>> <
>> CAFZdCup_ADzqkwuC5am_tr2U9cYt20L-oqigoqXY6W57U9_eCw@mail.gmail.com>
>> Content-Type: text/plain; charset="utf-8"
>>
>> This should be pretty simple as I really cannot find a good answer on:
>>
>>
>> Running Wordpress with the default permalinks (?page_id=xxx)
>>
>> On NGINX conf, I tried:
>>
>> location / {
>> try_files $uri $uri/ /$args /index.php?$args;
>> }
>>
>> And the main page caches OK, but any page the resides on the "?page_id" is
>> not getting cached. Is there more to the "try_files" that needs applied
>> for caching of these permalinks?
>>
>>
>> Thank You,
>> Alex
>> -------------- next part --------------
>> An HTML attachment was scrubbed...
>> URL: <
>> http://mailman.nginx.org/pipermail/nginx/attachments/20200522/73627236/attachment-0001.htm
>> >
>>
>> ------------------------------
>>
>> Subject: Digest Footer
>>
>> _______________________________________________
>> nginx mailing list
>> nginx@nginx.org
>> http://mailman.nginx.org/mailman/listinfo/nginx
>>
>> ------------------------------
>>
>> End of nginx Digest, Vol 127, Issue 25
>> **************************************
>>
> _______________________________________________
> nginx mailing list
> nginx@nginx.org
> http://mailman.nginx.org/mailman/listinfo/nginx
_______________________________________________
nginx mailing list
nginx@nginx.org
http://mailman.nginx.org/mailman/listinfo/nginx
Subject Author Posted

Re: nginx Digest, Vol 127, Issue 25

Devika Awasthi May 25, 2020 06:26AM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 114
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready