Welcome! Log In Create A New Profile

Advanced

Error 512 after nginx setup

Adrian Vidican
March 15, 2020 03:00PM
Hi Everyone,

First time I post here, hopefully I'm not gonna broke any rule.

I setup Nginx on my Ubuntu 16.04 server to point my domain (using cloudflare) to my server where discourse.org http://discourse.org/ is installed.

Here's the default file in sites-available

server {
listen 80; listen [::]:80;
server_name stumblr.in;

return 301 https://$host$request_uri https://$host$request_uri/;
}

server {
listen 443 ssl http2;
server_name stumblr.in;

ssl_certificate /etc/letsencrypt/live/stumblr.in/fullchain.pem http://stumblr.in/fullchain.pem;
ssl_certificate_key /etc/letsencrypt/live/stumblr.in/privkey.pem http://stumblr.in/privkey.pem;
include /etc/nginx/snippets/ssl.conf;

location / {
proxy_pass http://stumblr.in:2045/ http://stumblr.in:2045/;
proxy_set_header Host $http_host;
proxy_http_version 1.1;
proxy_set_header X-Forwarded-Proto $scheme;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_redirect http://stumblr.in:2045/ http://stumblr.in:2045/ https://stumblr.in https://stumblr.in/;
}
}


There's no error of Nginx but I've get 512 in browser.

Any idea what could be wrong?

Thanks in advance.
Adrian Vidican_______________________________________________
nginx mailing list
nginx@nginx.org
http://mailman.nginx.org/mailman/listinfo/nginx
Subject Author Posted

Error 512 after nginx setup

Adrian Vidican March 15, 2020 03:00PM

Re: Error 512 after nginx setup

Francis Daly March 20, 2020 05:40PM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 81
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready