Sergey Kandaurov
October 14, 2019 07:40AM
> On 14 Oct 2019, at 09:56, Hett <nginx-forum@forum.nginx.org> wrote:
>
> Hello,
> I want to disable resumable downloads.
> Added max_ranges directive:
>
>
> location ~ ^(/[^/]+/[^/]+/[^/]+) {
> set $zone_limit_key $binary_remote_addr$host;
> limit_req zone=req_free burst=10 nodelay;
> limit_conn conn_free 1;
> max_ranges 0;
> rewrite ^/([^/]+)/([^/]+)/([^/]+)$
> /v1/AUTH_system/$1/$2/$3?type=free break;
> keepalive_requests 0;
> proxy_pass http://10.10.100.110:8080;
> proxy_set_header Host $host;
> proxy_set_header X-Real-IP $remote_addr;
> proxy_set_header X-Forwarded-For $remote_addr;
> proxy_intercept_errors on;
> }
>
> But it has no effect

This is because the range request is processed by the proxied server,
and then nginx has nothing to do with the response.
Instead, you may want to disable range processing on backend,
by removing the Range request header while proxying requests:

proxy_set_header Range "";

--
Sergey Kandaurov

_______________________________________________
nginx mailing list
nginx@nginx.org
http://mailman.nginx.org/mailman/listinfo/nginx
Subject Author Posted

max_ranges has no effect

Hett October 14, 2019 02:56AM

Re: max_ranges has no effect

Sergey Kandaurov October 14, 2019 07:40AM

Re: max_ranges has no effect

Hett October 15, 2019 01:34AM

Re: max_ranges has no effect

Hett October 15, 2019 01:43AM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 111
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready