Welcome! Log In Create A New Profile

Advanced

Re: nginx-1.17.3 and TLS v1.3

Anonymous User
August 15, 2019 09:32AM
I suggest you consider investigating Intels' Clear Linux.

https://docs.01.org/clearlinux/latest/index.html https://docs.01.org/clearlinux/latest/index.html

https://docs.01.org/clearlinux/latest/about.html# <https://docs.01.org/clearlinux/latest/about.html#>

https://docs.01.org/clearlinux/latest/reference/bundles/bundles.html https://docs.01.org/clearlinux/latest/reference/bundles/bundles.html

read specifically about swupd and bundles.

This is a ’Stateless’ OS

In particular to your issues, on Clear Linux you'd install nginx-mainline bundle,
all the source packages and dependancies are tested with the bundle before distribution to swupd

Example, the nginx-mainline bundle version requires lib-openssl, the and only compatible tested lib-openssl package version will be included.

This strategy eliminates all those fragmented dependancy issues every other Linux distro, where you install nginx but you’ve no real idea what openssl version is going to work with it.

Admittedly, Clear Linux is a little unfamiliar at first but give it a try, there’s far less headaches to deal with than other the ‘popular’ distros.

Apologies for not addressing your issue directly.

> On 15 Aug 2019, at 21:05, TC_Hessen <nginx-forum@forum.nginx.org> wrote:
>
> Hi,
>
> I am new to this forum, but not new to nginx. I am running multiple debian
> servers (stretch) with nginx 1.14.1 and TLS 1.3 support, i.e.
>
> nginx version: nginx/1.14.1
> built with OpenSSL 1.1.0f 25 May 2017 (running with OpenSSL 1.1.1c 28 May
> 2019)
> TLS SNI support enabled
>
> To prevent the servers agains the new bugs, I tried to upgrade directly to
> 1.17.3 provided by nginx.org. That works without any problems, but TLS 1.3
> is not running anymore:
>
> nginx version: nginx/1.17.3
> built by gcc 6.3.0 20170516 (Debian 6.3.0-18+deb9u1)
> built with OpenSSL 1.1.0j 20 Nov 2018 (running with OpenSSL 1.1.1c 28 May
> 2019)
> TLS SNI support enabled
>
> Where is the error?
>
> Posted at Nginx Forum: https://forum.nginx.org/read.php?2,285294,285294#msg-285294
>
> _______________________________________________
> nginx mailing list
> nginx@nginx.org
> http://mailman.nginx.org/mailman/listinfo/nginx

_______________________________________________
nginx mailing list
nginx@nginx.org
http://mailman.nginx.org/mailman/listinfo/nginx
Subject Author Posted

nginx-1.17.3 and TLS v1.3

TC_Hessen August 15, 2019 09:05AM

Re: nginx-1.17.3 and TLS v1.3

Anonymous User August 15, 2019 09:32AM

Re: nginx-1.17.3 and TLS v1.3

Maxim Dounin August 15, 2019 10:04AM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 80
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready