Welcome! Log In Create A New Profile

Advanced

Disable proxy buffering for websockets

Chad Phillips
December 16, 2018 05:48PM
I use software that runs a speed test via websockets. When proxying this
websocket connection through Nginx, the 'download' portion of the test is
inaccurate.

My theory is that this is due to Nginx buffering the response from the
backend server, thus the timer on the backend server reports an inaccurate
value compared to when it's not proxied.

I've tried the following settings at both the location and server levels of
my configuration:

proxy_buffering off;
proxy_ignore_headers X-Accel-Buffering;

However, this doesn't fix the problem. I've confirmed the functionality
works correctly when it's not being proxied via Nginx, so wondering if A)
there is some other cause of the issue besides the proxy buffer, or B) I'm
not using the proxy buffer settings correctly?
_______________________________________________
nginx mailing list
nginx@nginx.org
http://mailman.nginx.org/mailman/listinfo/nginx
Subject Author Posted

Disable proxy buffering for websockets

Chad Phillips December 16, 2018 05:48PM

Re: Disable proxy buffering for websockets

Maxim Dounin December 16, 2018 09:28PM

Re: Disable proxy buffering for websockets

thehunmonkgroup December 18, 2018 11:58AM

Re: Disable proxy buffering for websockets

Maxim Dounin December 18, 2018 01:46PM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 106
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready