Welcome! Log In Create A New Profile

Advanced

Re: invalid default_server parrameter

Maxim Dounin
April 24, 2017 03:52PM
Hello!

On Mon, Apr 24, 2017 at 02:10:47PM -0500, Joel Parker wrote:

> I have many servers sending ssl which I am trying to terminate. So I wanted
> to create a statement that was a catch all instead of listening for each ip
> address. I thought this would do it :
>
> server {
>
> listen 443 ssl default_server;
>
> ......
>
> }
>
> but when I run nginx -t, I keep getting the error : nginx: [emerg] the
> invalid "default_server" parameter in /etc/nginx/nginx.conf:13
>
> Is this the correct way of doing a catch all incoming ssl traffic and what
> is wrong with my syntax ?

Are you trying to use it in a stream{} block? There are no
virtual servers in the stream module, so the "listen" directive
has no "default_server" parameter - it is not needed, all
connections to the given listening socket will be handled in only
one server{} block.

--
Maxim Dounin
http://nginx.org/
_______________________________________________
nginx mailing list
nginx@nginx.org
http://mailman.nginx.org/mailman/listinfo/nginx
Subject Author Posted

invalid default_server parrameter

Joel Parker April 24, 2017 03:12PM

Re: invalid default_server parrameter

jeffdyke April 24, 2017 03:20PM

Re: invalid default_server parrameter

Maxim Dounin April 24, 2017 03:52PM

Re: invalid default_server parrameter

Joel Parker April 24, 2017 04:14PM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 68
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready