Welcome! Log In Create A New Profile

Advanced

Re: invalid default_server parrameter

April 24, 2017 03:20PM
if you're using sni, you should be able to use _ as the server_name or
remove default server b/c if this is going to represent many servers, from
memory, default_server is not a value you want. for example i run nginx
behind haproxy to create letsencrypt certs, which will listen to currently
dozens of request: (of course you may not require proxy_protocol)

----
listen 8888 proxy_protocol;
server_name _;
----

On Mon, Apr 24, 2017 at 3:10 PM, Joel Parker <joel.parker.gm@gmail.com>
wrote:

> I have many servers sending ssl which I am trying to terminate. So I
> wanted to create a statement that was a catch all instead of listening for
> each ip address. I thought this would do it :
>
> server {
>
> listen 443 ssl default_server;
>
> ......
>
> }
>
> but when I run nginx -t, I keep getting the error : nginx: [emerg] the
> invalid "default_server" parameter in /etc/nginx/nginx.conf:13
>
> Is this the correct way of doing a catch all incoming ssl traffic and what
> is wrong with my syntax ?
>
> Joel
>
> _______________________________________________
> nginx mailing list
> nginx@nginx.org
> http://mailman.nginx.org/mailman/listinfo/nginx
>
_______________________________________________
nginx mailing list
nginx@nginx.org
http://mailman.nginx.org/mailman/listinfo/nginx
Subject Author Posted

invalid default_server parrameter

Joel Parker April 24, 2017 03:12PM

Re: invalid default_server parrameter

jeffdyke April 24, 2017 03:20PM

Re: invalid default_server parrameter

Maxim Dounin April 24, 2017 03:52PM

Re: invalid default_server parrameter

Joel Parker April 24, 2017 04:14PM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 50
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready