Welcome! Log In Create A New Profile

Advanced

Illumos/SmartOS/Solaris issue when using eventport and keepalive at the same time

Peter Toth
March 16, 2017 06:48PM
Hi all,

There is a lock-up issue on Solaris derived operating systems when using
"keepalive" and "use eventport" configuration directives at the same time.

The issue has been described previously back in 2015 and a patch was
proposed here: https://forum.nginx.org/read.php?2,259798,259798#msg-259798

I have tested the patch and it is working.

Could anyone comment on whether the patch looks acceptable in its current
form?
Any objections to applying this fix in the next release?

Thanks
P
_______________________________________________
nginx mailing list
nginx@nginx.org
http://mailman.nginx.org/mailman/listinfo/nginx
Subject Author Posted

Illumos/SmartOS/Solaris issue when using eventport and keepalive at the same time

Peter Toth March 16, 2017 06:48PM

Re: Illumos/SmartOS/Solaris issue when using eventport and keepalive at the same time

Maxim Dounin March 17, 2017 09:10AM

Re: Illumos/SmartOS/Solaris issue when using eventport and keepalive at the same time

Peter Toth March 18, 2017 04:06AM

Re: Illumos/SmartOS/Solaris issue when using eventport and keepalive at the same time

James March 18, 2017 07:16AM

Re: Illumos/SmartOS/Solaris issue when using eventport and keepalive at the same time

Yaroslav Zhuravlev March 28, 2017 08:56AM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 88
Record Number of Users: 8 on April 13, 2023
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready