Welcome! Log In Create A New Profile

Advanced

FastCGI Param

December 01, 2009 03:34AM
Hi there, I have problem, but I sloved 50% of it. Need a little help. So my problem before is when I try to load php pages, nginx got "No input file specified." So I have sloved this by looking at fastcgi_param. ...
my www dir is /www
pages dir is /www/page1, /www/page2, /www/page3
my fastcgi parameters in nginx.conf is:

location ~ \.php$ {
fastcgi_pass 127.0.0.1:9000;
fastcgi_index index.php;
fastcgi_param SCRIPT_FILENAME /www$fastcgi_script_name;
include /usr/pkg/etc/nginx/fastcgi_params;
}

and have still recived "No input file specified." when I use

fastcgi_param SCRIPT_FILENAME /www$fastcgi_script_name;


but when i type the site1, 2 or 3 folder, don't have problems ... something like:

fastcgi_param SCRIPT_FILENAME /www/site1/$fastcgi_script_name; (or /www/site1$fastcgi_script_name; # will be the same)


Sooo my question, example I hosting about more than 100 web pages, this mean I have 100+ folders in /www dir. Are I must need to write 100 lines for fastcgi workin' for all?

By the way I have tired to try

fastcgi_param SCRIPT_FILENAME /www/*/$fastcgi_script_name;
fastcgi_param SCRIPT_FILENAME /www/*$fastcgi_script_name;
fastcgi_param SCRIPT_FILENAME /www/$*$fastcgi_script_name;

to enable fastcgi for all pages, but still don't work (No imput file)

Can somebody help:?

Thanks beforely!
Subject Author Posted

FastCGI Param

nt001 December 01, 2009 03:34AM

Re: FastCGI Param

nt001 December 01, 2009 06:15AM

Re: FastCGI Param

Igor Sysoev December 01, 2009 06:24AM

Re: FastCGI Param

nt001 December 04, 2009 01:37AM

Re: FastCGI Param

nt001 December 02, 2009 01:39AM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 74
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready