Welcome! Log In Create A New Profile

Advanced

Re: Why does fastcgi_keep_conn default to off?

B.R.
January 31, 2015 03:40PM
It depends on the backend, really, but you cannot assume it will support
multiple sessions on the same connection. Maybe the backend needs the '1
connection = 1 request' relationship?
A backend supporting multiplexing won't have trouble with 1
request/connection, however, backend not supporting it wil have trouble
dealing with several requests/connection.

Conclusion: the most compatible way is not to multiplex.

You know, even popular FastCGI backends may not support that correctly. Did
you know for instance that PHP-FPM had bugs related to that?
https://bugs.php.net/bug.php?id=67583
I ran into it by simply installing the most recent release from MediaWiki
somewhere... trouble stopped when multiplexing got deactivated...

IMHO default configuration should be the safest. It is then up to you to
tweak your system according to your needs.
---
*B. R.*

On Sat, Jan 31, 2015 at 4:26 PM, Olaf van der Spek <nginx-forum@nginx.us>
wrote:

> Why does fastcgi_keep_conn default to off?
> On seems to be the faster option.
>
> Posted at Nginx Forum:
> http://forum.nginx.org/read.php?2,256371,256371#msg-256371
>
> _______________________________________________
> nginx mailing list
> nginx@nginx.org
> http://mailman.nginx.org/mailman/listinfo/nginx
>
_______________________________________________
nginx mailing list
nginx@nginx.org
http://mailman.nginx.org/mailman/listinfo/nginx
Subject Author Posted

Why does fastcgi_keep_conn default to off?

Olaf van der Spek January 31, 2015 10:26AM

Re: Why does fastcgi_keep_conn default to off?

B.R. January 31, 2015 03:40PM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 106
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready