Welcome! Log In Create A New Profile

Advanced

Bug re: openssl-1.0.1

Peter Fraser
January 06, 2015 04:40PM
Hi All
I'm trying to use nginx to also proxy to owa. I am getting the error
*peer closed connection in SSL handshake while SSL handshaking to upstream*

I have read that this is due to a bug and that the solution is to downgrade
to openssl 1.0

I don't want to downgrade because I would want users to be able to connect
using TLS-1.1 and 1.2 and my understanding is that support for these
protocols was introduced in openssl-1.0.1

So my question is: Is this a bug in nginx or in openssl? If nginx, has it
been fixed yet or will it be soon?
_______________________________________________
nginx mailing list
nginx@nginx.org
http://mailman.nginx.org/mailman/listinfo/nginx
Subject Author Posted

Bug re: openssl-1.0.1

Peter Fraser January 06, 2015 04:40PM

RE: Bug re: openssl-1.0.1

Lukas Tribus January 06, 2015 05:10PM

Re: Bug re: openssl-1.0.1

Peter Fraser January 06, 2015 05:48PM

RE: Bug re: openssl-1.0.1

Lukas Tribus January 06, 2015 07:58PM

RE: Bug re: openssl-1.0.1

Lukas Tribus January 06, 2015 08:14PM

Re: Bug re: openssl-1.0.1

Peter Fraser January 12, 2015 12:22PM

RE: Bug re: openssl-1.0.1

Lukas Tribus January 12, 2015 12:58PM

Re: Bug re: openssl-1.0.1

Peter Fraser January 12, 2015 04:20PM

Re: Bug re: openssl-1.0.1

Peter Fraser January 12, 2015 11:00AM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 61
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready