Welcome! Log In Create A New Profile

Advanced

Cannot run ASP.NET Web API with Nginx and Mono on Ubuntu

November 10, 2014 02:01AM
Good day,
first of all I am new to Linux OS and mono.

I am tryiing to run my ASP.NET Web API on Ubuntu with Nginx and Mono. Here is what I've done so far:

I have installed mono, nginx, fastcgi-server4 and all successful.
I have followed all the steps from the following URL to run my application on Linux:

http://piotrwalat.net/running-asp-net-web-api-services-under-linux-and-os-x/

When I run the following command:

fastcgi-mono-server4 --appconfigdir /etc/webapps /socket=tcp:127.0.0.1:9002

nothing happens, Terminal doesn't show any response. What can I do???

Here are my configurations:

Virtual host configuration:

server {
listen 5757;
server_name localhost;
root /var/www/TestWebSite;
access_log /var/log/nginx/test.access.log;

location / {
index index.html index.htm default.aspx Default.aspx;
fastcgi_index /Default.aspx;
fastcgi_pass 127.0.0.1:9002;
include /etc/nginx/fastcgi_params;
}
}

My MonoWebApi.webapp:

<apps>
<web-application>
<name>TestWebSite</name>
<vhost>localhost</vhost>
<vport>5757</vport>
<vpath>/</vpath>
<path>/var/www/TestWebSite</path>
</web-application>
</apps>
Subject Author Posted

Cannot run ASP.NET Web API with Nginx and Mono on Ubuntu

FireFalcon November 10, 2014 02:01AM

Re: Cannot run ASP.NET Web API with Nginx and Mono on Ubuntu

Francis Daly November 10, 2014 02:02PM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 60
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready