Welcome! Log In Create A New Profile

Advanced

proxy_pass_header not working in 1.6.0

Lucas Rolff
July 01, 2014 01:00AM
Hi guys,

I'm currently running nginx version 1.6.0 (after upgrading from 1.4.4).

Sadly I've found out, after upgrading proxy_pass_header seems to stop
working, meaning no headers is passed from the upstream at all, I've
tried setting caching headers, expires headers, removing ETag etc but
nothing seems to go through.

I then wanted to test it, on other machines, because it could be a
faulty installation, but I can replicate it on 3 different machines, I'm
always getting my releases from https://github.com/nginx/nginx/releases.

My config looks as following:

https://gist.github.com/lucasRolff/c4a359d93b5906678a23

Do you guys know what can be wrong, and if there is a fix for it in any
newer version of nginx, or if I should downgrade to 1.4.4 again (Where I
know it's working at least).

Thanks in advance!

Best regards,
Lucas Rolff

_______________________________________________
nginx mailing list
nginx@nginx.org
http://mailman.nginx.org/mailman/listinfo/nginx
Subject Author Posted

proxy_pass_header not working in 1.6.0

Lucas Rolff July 01, 2014 01:00AM

Re: proxy_pass_header not working in 1.6.0

Jonathan Matthews July 01, 2014 03:12AM

Re: proxy_pass_header not working in 1.6.0

Lucas Rolff July 01, 2014 03:22AM

Re: proxy_pass_header not working in 1.6.0

Jonathan Matthews July 01, 2014 03:30AM

Re: proxy_pass_header not working in 1.6.0

Lucas Rolff July 01, 2014 03:36AM

Re: proxy_pass_header not working in 1.6.0

Jonathan Matthews July 01, 2014 03:56AM

Re: proxy_pass_header not working in 1.6.0

Lucas Rolff July 01, 2014 04:02AM

Re: proxy_pass_header not working in 1.6.0

Jonathan Matthews July 01, 2014 04:10AM

Re: proxy_pass_header not working in 1.6.0

Robert Paprocki July 01, 2014 04:26AM

Re: proxy_pass_header not working in 1.6.0

Lucas Rolff July 01, 2014 04:32AM

Re: proxy_pass_header not working in 1.6.0

Valentin V. Bartenev July 01, 2014 06:42AM

Re: proxy_pass_header not working in 1.6.0

Lucas Rolff July 01, 2014 07:02AM

Re: proxy_pass_header not working in 1.6.0

Robert Paprocki July 01, 2014 07:04AM

proxy_pass_header not working in 1.6.0

Lucas Rolff July 01, 2014 07:32AM

Re: proxy_pass_header not working in 1.6.0

Maxim Dounin July 01, 2014 08:18AM

Re: proxy_pass_header not working in 1.6.0

Lucas Rolff July 01, 2014 08:36AM

Re: proxy_pass_header not working in 1.6.0

Valentin V. Bartenev July 01, 2014 08:40AM

Re: proxy_pass_header not working in 1.6.0

Lucas Rolff July 01, 2014 08:52AM

Re: proxy_pass_header not working in 1.6.0

Maxim Dounin July 01, 2014 08:52AM

Re: proxy_pass_header not working in 1.6.0

Lucas Rolff July 01, 2014 06:42AM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 41
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready