Welcome! Log In Create A New Profile

Advanced

Cache permissions problem

April 01, 2014 03:03PM
Hello.

I've a custom build of nginx (1.4.6) with ngx_cache_purge module (2.1)

In the config file I've a cache zone declared like this:
proxy_cache_path /tmp/nginx_cache keys_zone=MYCACHE:10m;
I don't have specified any "user" (http://wiki.nginx.org/CoreModule#user) in my config.
When I run nginx with my user the cache directory is create with permissions drwx------ and is owned by my user and my group

The problem is that nothing is written in the cache directory. If I run nginx with sudo everything works.

Where am I wrong ? Hints ?

Thanks

--
Simone
Subject Author Posted

Cache permissions problem

hpatoio April 01, 2014 03:03PM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 73
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready