Welcome! Log In Create A New Profile

Advanced

Re: Issue with spdy and proxy_pass

February 19, 2014 05:05AM
I checked Tomcat logs. No errors, just status 200 and zero length. I appended %v - Local server name to the log to see if $host is passed thru correct. It is.

And now it's getting weird. I replcaed my complex website (which runs fine with pure ssl!) with a simple "Hello World" and it works!
Seems the issue was ETag / If-none-match Headers

In my website I set ETag for dynamic pages which don't change frequently, so there was no need to hit database on every request.
As soon I turn this off, my site works.
Subject Author Posted

Issue with spdy and proxy_pass

p.heppler February 18, 2014 09:15AM

Re: Issue with spdy and proxy_pass

Valentin V. Bartenev February 18, 2014 09:26AM

Re: Issue with spdy and proxy_pass

p.heppler February 18, 2014 09:42AM

Re: Issue with spdy and proxy_pass

p.heppler February 18, 2014 09:50AM

Re: Issue with spdy and proxy_pass

p.heppler February 18, 2014 09:54AM

Re: Issue with spdy and proxy_pass

Valentin V. Bartenev February 18, 2014 12:50PM

Re: Issue with spdy and proxy_pass

p.heppler February 19, 2014 03:04AM

Re: Issue with spdy and proxy_pass

p.heppler February 19, 2014 05:05AM

Re: Issue with spdy and proxy_pass

p.heppler February 19, 2014 06:24AM

Re: Issue with spdy and proxy_pass

Valentin V. Bartenev February 19, 2014 09:26AM

Re: Issue with spdy and proxy_pass

p.heppler February 19, 2014 10:44AM

Re: Issue with spdy and proxy_pass

p.heppler February 21, 2014 09:40AM

Re: Issue with spdy and proxy_pass

p.heppler February 24, 2014 09:04AM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 179
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready