Welcome! Log In Create A New Profile

Advanced

Mono MVC Timeout

Gee
May 26, 2013 10:02AM
Hi everyone!

I am struggling to get a (simple) MVC app work under OpenBSD (5.3) + Mono
(2.10.9) + Nginx (1.2.6)

I can get a simple index.aspx (Hello World) app to work, but the default
MVC 3 template doesn't seem to work.

I made some minor changes to remove any reference to SQL providers in
Web.config and I removed EntityFramework.dll, as well as ensuring that the
various System.Web.* dlls also co-existed in my \bin folder.

All I seem to get is this:

504 Gateway Time-out
nginx/1.2.6

This is how I am launching fastcgi-mono-server4:
fastcgi-mono-server4 /applications/:. /socket=tcp:127.0.0.1:9000/printlog=True

But the only log detail I get is this:
[DateTimeStamp] Beginning to receive records on connection.

I have uploaded my config and source code to here:
http://www.4shared.com/rar/FzSLuLnF/MvcMonoNginx.html

Given that I can serve a simple 'Hello World' page, I'm pretty sure there
isn't anything wrong with my base nginx/mono installs, but no doubt
something subtle I have missed in my configs. Can anyone (please) shed any
light on this?

Thanks!
G
_______________________________________________
nginx mailing list
nginx@nginx.org
http://mailman.nginx.org/mailman/listinfo/nginx
Subject Author Posted

Mono MVC Timeout

Gee May 26, 2013 10:02AM

Re: Mono MVC Timeout

Jonathan Matthews May 26, 2013 11:54AM

Re: Mono MVC Timeout

zvn May 05, 2014 12:09PM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 371
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready