Welcome! Log In Create A New Profile

Advanced

Re: RHEL 6, nginx and parse fails

Alexandr Gomoliako
April 19, 2012 12:14PM
On Thu, Apr 19, 2012 at 5:46 PM, dignus <nginx-forum@nginx.us> wrote:
> Hi all,
>
> Today I updated 2 of my RHEL 6 boxes to the latest version of all
> installed packages including Nginx from the nginx repository.
>
> Since then both reload & configtest won't work, the error I'm seeing is
> this:
>
> nginx object version 0.8.54 does not match bootstrap parameter 1.0.14 at
> /usr/lib64/perl5/XSLoader.pm line 94.
> Compilation failed in require.
> BEGIN failed--compilation aborted.
> 2012/04/19 16:23:01 [alert] 11485#0: perl_parse() failed: 2
>
> Any idea what's happening here?

Seems like you are trying to load older nginx.so with newer nginx.pm.

_______________________________________________
nginx mailing list
nginx@nginx.org
http://mailman.nginx.org/mailman/listinfo/nginx
Subject Author Posted

RHEL 6, nginx and parse fails

dignus April 19, 2012 10:46AM

Re: RHEL 6, nginx and parse fails

Alexandr Gomoliako April 19, 2012 12:14PM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 77
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready