Welcome! Log In Create A New Profile

Advanced

1.0.5 vs 1.0.10

March 29, 2012 05:09PM
Hi,

I recently copied configuration files that worked correctly in 1.0.5 which no longer work in 1.0.10

I tested using curl: curl -k -H 'X-Forwarded-For: 1.2.3.4' -F data=@1327833493.xml -F username=user -F password=pass https://example.com

The response I get is: curl: (35) Unknown SSL protocol error in connection to example.com:443

Any ideas why this only poses issues in 1.0.10 and not in 1.0.5 ? What changes are required, or is this a bug?



Configuration:

## nginx.conf
server {
...
include conf.d/*.conf
...
passenger module
...
}

## conf.d/ssl.conf
server {
listen 443 default ssl;
server_name _;

ssl on;
ssl_certificate path/to/cert;
ssl_certificate_key path/to/key;
ssl_session_timeout 5m;

ssl_protocols SSLv2 SSLv3 TLSv1;
ssl_ciphers ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSLv2:+EXP;
ssl_prefer_server_ciphers on;
}

## conf.d/app.rb
server {
listen 80;
listen 443;

log_format main2 '$remote_addr - $remote_user [$time_local] "$request" '
'$status $body_bytes_sent "$http_referer" '
'"$request_body" "$http_x_forwarded_for" "$http_x_forward_for"' ;
error_log /home//app/log/nginx-error.log;

server_name example.com;
root /home/app/public; # <--- be sure to point to 'public'!
access_log /home/app/log/nginx-access.log main2;
passenger_set_cgi_param HTTP_X_FORWARDED_FOR $http_x_forwarded_for;
passenger_enabled on;
}
Subject Author Posted

1.0.5 vs 1.0.10

stormflake March 29, 2012 05:09PM

Re: 1.0.5 vs 1.0.10

Maxim Dounin March 29, 2012 11:42PM

Re: 1.0.5 vs 1.0.10

stormflake March 30, 2012 12:33PM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 212
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready