Welcome! Log In Create A New Profile

Advanced

Nginx Doesn't Log FastCGI Errors

March 28, 2012 07:52AM
I have recently migrated my Nginx+PHP-FPM server from a Centos 5 to a Centos 6 server and I basically migrated the whole configuration from the old server to the new one with minor changes. I compiled the newest versions of Nginx (1.0.14) and PHP (5.3.10), Centos 5 had 1.0.2 and 5.3.2.

The problem is that Nginx doesn't log FastCGI errors in its error.log, it's logging it's own errors without a problem. I'm talking about the errors which look like this:

"2012/03/28 07:56:01 [error] 14919#0: *697095886 FastCGI sent in stderr: "CSRF state token does not match one provided" while reading response header from upstream..."

I tried to change many things, but I can't make the FastCGI errors to be logged in the Nginx error.log.

nginx.conf: http://pastebin.com/ABMm0c5h
php-fpm.conf: http://pastebin.com/kFuztqXN
php.ini loggin section: http://pastebin.com/bVWdTgCi
Subject Author Posted

Nginx Doesn't Log FastCGI Errors

kustodian March 28, 2012 07:52AM

Re: Nginx Doesn't Log FastCGI Errors

Maxim Dounin March 28, 2012 08:08AM

Re: Nginx Doesn't Log FastCGI Errors

kustodian March 28, 2012 09:56AM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 69
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready