Welcome! Log In Create A New Profile


RE: nginx Digest, Vol 29, Issue 68

Axel Holscher \(GMAIL\)
March 27, 2012 03:00AM
Hi Maxim,

Wireshark showed it was IE9 that was not sending the URL name, at all, on
first SSL handshake.
Reset IE9 back to factory default and it works now.
(..but have not found the actual IE9 security settings that caused theTLS
SNI request to be suppressed though...yet)


>Date: Fri, 23 Mar 2012 16:23:53 +0400
>From: Maxim Dounin <mdounin@mdounin.ru>
>On Fri, Mar 23, 2012 at 10:22:38AM +0200, Axel Holscher (GMAIL) wrote:

>> My IE9 (on Windows7 64 bit) fails to trigger the correct nginx virtual
>> https server name and SSL certificate (It ignores all except the
>> default -1st server).
>> But It seems to work fine with FF10 and Chrome17.
>> Is this an IE9 issue? or am I missing something from my nginx/openssl
>> compilation options?

>Most likely it's IE issue, your nginx config looks fine. You may try
looking what's happening on the wire (e.g. in wireshark) or just test if you
see the same behaviour on the clean install of
>Win7 + IE9 (google search suggests some incorrect registry settings may
cause problems).
>Maxim Dounin

nginx mailing list
Subject Author Posted

RE: nginx Digest, Vol 29, Issue 68

Axel Holscher \(GMAIL\) March 27, 2012 03:00AM

Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 88
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready