Welcome! Log In Create A New Profile

Advanced

Strange php-fpm problem...

March 14, 2012 10:10AM
Hi folks

Not strictly an Nginx issue, but got some great advice on php-fpm here before so though I'd trade on your generosity...

ISSUE OVERVIEW

1) php-fpm is running fine on Ubuntu 12

2) I stupidly configure xdebug to run on the same port as php-fpm and try to restart php-fpm

3) I correct the misconfiguration, but now php-fpm won't start at all, even after a reboot.

4) The only diagnostics I can find are in boot.log: "Starting FastCGI server: No servers have been defined." No hits at all for this in Google. I have set up a pool which was working fine before the misconfiguration.

DETAILS

1) If I run ">service php5-fpm start" there is a long pause, then the shell outputs "killed"

2) There is nothing in the php5-fpm log, even with log level debug, so it seems to hit the issue early in the process.

3) I've tried restarting with the xdebug config commented out, and with Nginx stopped.

4) I've tried rebooting

5) There's no orphaned pid file in /var/run, and no php-fpm processes running

I've run out of ideas. Any help would be more than welcome.
Subject Author Posted

Strange php-fpm problem...

gcaplan March 14, 2012 10:10AM

[SOLVED] Strange php-fpm problem

gcaplan March 14, 2012 11:14AM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 81
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready