Welcome! Log In Create A New Profile

Advanced

Re: 404 Not Found -- nginx/1.0.10

July 07, 2012 06:29AM
I've had the same sort of issue yesterday with 1.2.2, all of a sudden 404's but with a additional 'No input file specified' coming from the php backend(and 1 sec later from nginx cache 'HIT'), one minute later and everything was normal again. No floods, normal traffic, no additional log entries... Only backend effected, normal static sites worked ok.

Restarts did not help either which is the weirdest, but then again I did change alot recently like using nginx caching with the php backend, php code RC cacher. And I did wanted to update php anyway to the 5.4 branch, so now updated everything to 5.4, changed a dozen php apps to work properly with 5.4 and now waiting to see if the issue happens again.

There are memory corruption issues with php 5.3 which have been fixed in svn but not compiled/released yet, 5.4 does not have these issues so hopefully 5.4 solves this weirdness.

It does sound like a php issue (75% sure) but it could be a nginx issue as well like for some reason not passing data to the backend, however it is extremely weird when restarting nginx and the backends the problem persisted ! either wait without restarting or restart 3-4 times before things are back to normal.
Subject Author Posted

404 Not Found -- nginx/1.0.10

mfouwaaz November 30, 2011 11:26PM

Re: 404 Not Found -- nginx/1.0.10

mfouwaaz December 02, 2011 08:58PM

Re: 404 Not Found -- nginx/1.0.10

Valentin V. Bartenev December 03, 2011 09:12AM

Re: 404 Not Found -- nginx/1.0.10

mfouwaaz December 04, 2011 12:00PM

Re: 404 Not Found -- nginx/1.0.10

mfouwaaz December 04, 2011 12:03PM

Re: 404 Not Found -- nginx/1.0.10

Valentin V. Bartenev December 05, 2011 04:20AM

Re: 404 Not Found -- nginx/1.0.10

mfouwaaz December 05, 2011 01:57PM

Re: 404 Not Found -- nginx/1.0.10

eddz July 05, 2012 11:07PM

Re: 404 Not Found -- nginx/1.0.10

eddz July 06, 2012 01:40PM

Re: 404 Not Found -- nginx/1.0.10

itpp2012 July 07, 2012 06:29AM

Re: 404 Not Found -- nginx/1.0.10

itpp2012 July 06, 2012 12:22PM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 165
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready