Welcome! Log In Create A New Profile

Advanced

Re: nginx 1.1.0 not working on Windows 2000 Server

J2R
November 26, 2011 06:48AM
On 26/11/11 11:29, John Moore wrote:
> A customer of mine is running an ancient Windows 2000 Server
> installation, on which I have been running an old version of nginx. I
> want to upgrade to a more recent version, but nginx 1.1.0 is not
> working for me. I get the following in the error log:
>
> 2011/11/26 11:30:56 [notice] 25552#26824:
> WSAIoctl(SIO_GET_EXTENSION_FUNCTION_POINTER, WSAID_TRANSMITPACKETS)
> failed (10022: An invalid argument was supplied)
> 2011/11/26 11:30:56 [notice] 25552#26824:
> WSAIoctl(SIO_GET_EXTENSION_FUNCTION_POINTER, WSAID_CONNECTEX) failed
> (10022: An invalid argument was supplied)
> 2011/11/26 11:30:56 [notice] 25552#26824:
> WSAIoctl(SIO_GET_EXTENSION_FUNCTION_POINTER, WSAID_DISCONNECTEX)
> failed (10022: An invalid argument was supplied)
>
> No idea what this signifies. Is this fixable, or does anyone know of a
> recent nginx version which does run OK on such an old OS?
>

I installed the Kevn Worthington Cygwin-based build instead and this
time it worked fine, so problem solved.

_______________________________________________
nginx mailing list
nginx@nginx.org
http://mailman.nginx.org/mailman/listinfo/nginx
Subject Author Posted

nginx 1.1.0 not working on Windows 2000 Server

J2R November 26, 2011 06:30AM

Re: nginx 1.1.0 not working on Windows 2000 Server

J2R November 26, 2011 06:48AM

Re: nginx 1.1.0 not working on Windows 2000 Server

Maxim Dounin November 26, 2011 04:00PM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 89
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready