April 26, 2011 02:40PM
Hi all,

I noticed today some weird errors when I tried to refresh a basic php page (phpinfo() function).
The page loads fine when I click refresh several times, then all of the sudden I get a dead page, no 404, no Nginx error, nothing. It looks like someone disconnected the network cable for a fraction of second. I checked both php and nginx logs, nothing is there. I even enabled the debug mode to be safe.

I have a very basic configuration:

upstream fastcgi {
server 192.168.0.2:9000;
server 192.168.0.3:9000 weight=5;
server 192.168.0.10:9000 weight=5;
}

location / {
try_files $uri $uri/ /index.php;
}

location ~ \.php$ {
fastcgi_pass fastcgi;
include fastcgi.conf;
}

Do you know what could generate this issue? The site is closed now so only 2-3 people have access to the setup.
Do you recommend any tools or settings that will allow me to verify if the network is shaky?
Subject Author Posted

PHP dead pages with php-fpm and nginx

TECK April 26, 2011 02:40PM

Re: PHP dead pages with php-fpm and nginx

TECK April 26, 2011 03:06PM

Re: PHP dead pages with php-fpm and nginx

Igor Sysoev April 27, 2011 12:56AM

Re: PHP dead pages with php-fpm and nginx

TECK April 28, 2011 02:13PM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 67
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready