Welcome! Log In Create A New Profile

Advanced

Re: static images 404 on Windows

Chris Cortese
May 14, 2009 05:58PM
Hi,

Problem is I'm only having the problem on Windows--where I'm using the
prebuilt Windows binary.

Is there any way to get a current Windows binary that is built with
debug on?

Thanks,
Chris



Igor Sysoev wrote:
> On Tue, May 12, 2009 at 12:16:25AM -0700, Chris Cortese wrote:
>
>
>> thanks...
>>
>> it seems for me I just cannot trigger anything in that block.
>>
>> Anybody see anything wrong?
>>
>> Can there be a good way to debug which location directive is processing??
>>
>> location ~ (jpg|jpeg|gif|png)$ {
>> root c:/cygwin/home/Chris/www/live/jobsite/trunk/html/public;
>> #anything -- never gets here
>> }
>>
>
> Only debug log:
>
> ./configure --with-debug ...
> error_log /path/to/log debug;
>
> You will see
>
> test location ...
> test location ...
> test location ...
> using location ...
>
>
>> Igor Sysoev wrote:
>>
>>> On Mon, May 11, 2009 at 09:36:22PM -0700, Chris Cortese wrote:
>>>
>>>
>>>
>>>> thanks, I thought about that but the root path is working fine for the
>>>> .php ... just not the /public/css, /public/images, /public/js ...
>>>>
>>>>
>>> location ~ (jpg|jpeg|gif|png)$ {
>>> root c:/cygwin/home/Chris/www/live/jobsite/trunk/html/public;
>>> }
>>>
>>> If php is cygwin application it requires cygwin style paths "/cygwin/...",
>>> Native applications require usual win32 paths: "c:/cygwin/...".
>>>
>>>
>>>
>>>> raptium wrote:
>>>>
>>>>
>>>>>> Note that I have web source under /cygwin for my convenience only but I
>>>>>> am
>>>>>> not using any cygwin components in my stack, all native Windows
>>>>>> components.
>>>>>>
>>>>>>
>>>>>>
>>>>>
>>>>>
>>>>>> root /cygwin/home/Chris/www/live/jobsite/trunk/html/public;
>>>>>> index index.php index.html;
>>>>>>
>>>>>>
>>>>>>
>>>>> Since you are not using cygwin, I don't think
>>>>> /cygwin/home/Chris/www/live/jobsite/trunk/html/public is a valid path
>>>>> on windows, maybe you should change it to c:/cygwin... ?
>>>>>
>>>>>
>>>>>
>>>>>
>>>
>>>
>
>
Subject Author Posted

static images 404 on Windows

Chris Cortese May 09, 2009 04:25AM

Re: static images 404 on Windows

坏人 May 11, 2009 11:31PM

Re: static images 404 on Windows

Chris Cortese May 11, 2009 11:51PM

Re: static images 404 on Windows

raptium May 12, 2009 12:04AM

Re: static images 404 on Windows

Chris Cortese May 12, 2009 12:17AM

Re: static images 404 on Windows

凌晨 May 11, 2009 11:57PM

Re: static images 404 on Windows

raptium May 12, 2009 12:30AM

Re: static images 404 on Windows

Chris Cortese May 12, 2009 12:36AM

Re: static images 404 on Windows

Igor Sysoev May 12, 2009 02:13AM

Re: static images 404 on Windows

Chris Cortese May 12, 2009 03:16AM

Re: static images 404 on Windows

Igor Sysoev May 12, 2009 03:18AM

Re: static images 404 on Windows

Chris Cortese May 14, 2009 05:58PM

Re: static images 404 on Windows

Igor Sysoev May 15, 2009 01:10AM

Re: static images 404 on Windows

坏人 May 12, 2009 03:56AM

Re: static images 404 on Windows

Igor Sysoev May 12, 2009 04:15AM

答复: static images 404 on Windows

kevin May 12, 2009 05:42AM

windows static assets - solved

Chris Cortese May 14, 2009 09:33PM

Re: windows static assets - solved

Igor Sysoev May 15, 2009 01:13AM

Re: windows static assets - solved

Chris Cortese May 15, 2009 02:39AM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 65
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready