Welcome! Log In Create A New Profile

Advanced

Re: Why am I needing to add ampersand manually in rewrites?

Antoine Bonavita
April 05, 2011 09:18AM
Hi,

Haven't looked at your conf, but you likely forgot a ? at the end of
the target in your rewrite statement.
Have a look at http://wiki.nginx.org/HttpRewriteModule#rewrite
(especially the part after "To rewrite a URL with parameters to
another URL, use this instead:").

You could also have a look at the WP configuration examples here :
http://kbeezie.com/view/nginx-configuration-examples/

Good luck with it.

Antoine.

On Mon, Apr 4, 2011 at 7:54 AM, jamz <nginx-forum@nginx.us> wrote:
> Thanks for your help, Cliff. I have a feeling that what you say is
> spot-on. Perhaps from that tutorial I have added in some kind of
> redirect or something that is causing the ? links to not work without an
> appended &. It's really weird. Maybe I should try replacing the & with
> another ?. If I'm removing the first ? by default, that would make sense
> then. Although, I have checked the site across many browsers now, and
> everything is working exactly how it should. Load times are extremely
> fast. Before, I got lots of error messages. So while this fix isn't
> necessarily correct, it seems to be working, and as I've repeated it
> across different links, they all start to work. So I'm going to roll
> with it for now...I'm on a time crunch to get this up. I'll have to look
> more into it later.
>
> Until then, if you or anyone thinks of anything, please make a shout :)
>
> Jon
>
> Posted at Nginx Forum: http://forum.nginx.org/read.php?2,188044,188110#msg-188110
>
>
> _______________________________________________
> nginx mailing list
> nginx@nginx.org
> http://nginx.org/mailman/listinfo/nginx
>

_______________________________________________
nginx mailing list
nginx@nginx.org
http://nginx.org/mailman/listinfo/nginx
Subject Author Posted

Why am I needing to add ampersand manually in rewrites?

jamz April 03, 2011 06:00PM

Re: Why am I needing to add ampersand manually in rewrites?

Cliff Wells April 03, 2011 11:56PM

Re: Why am I needing to add ampersand manually in rewrites?

jamz April 04, 2011 12:39AM

Re: Why am I needing to add ampersand manually in rewrites?

jamz April 04, 2011 12:49AM

Re: Why am I needing to add ampersand manually in rewrites?

Cliff Wells April 04, 2011 01:26AM

Re: Why am I needing to add ampersand manually in rewrites?

jamz April 04, 2011 01:54AM

Re: Why am I needing to add ampersand manually in rewrites?

Antoine Bonavita April 05, 2011 09:18AM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 69
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready