Welcome! Log In Create A New Profile

Advanced

Re: Problem with nginx/0.8.54 and alias

All files from this thread

File Name File Size   Posted by Date  
thunderbird_saved_items_copy.png 83.4 KB open | download Jim Ohlstein 02/19/2011 Read message
google_apps_mail.ohlste.in_screenshot.png 69.9 KB open | download Jim Ohlstein 02/19/2011 Read message
forum_is_awful.png 39.8 KB open | download Jim Ohlstein 02/19/2011 Read message
analytics.png 42.8 KB open | download Jim Ohlstein 02/19/2011 Read message
analytics2.png 62.5 KB open | download Jim Ohlstein 02/19/2011 Read message
February 20, 2011 12:04PM
On 2/20/11 6:49 AM, Maxim Dounin wrote:
> Hello!
>
> On Sat, Feb 19, 2011 at 08:28:27PM -0500, Jim Ohlstein wrote:
>
>> On 2/19/11 6:14 PM, Maxim Dounin wrote:
>>> Hello!
>>>
>>> On Sat, Feb 19, 2011 at 12:05:17PM -0500, Jim Ohlstein wrote:
>>>
>>> [...]
>>>
>>>>> And as far as this indeed affects mailing list and forum,
>>>>> including people in this particular thread (note several messages
>>>>> with incorrect configs due to<NAME> being stripped) - I don't
>>>
>>> Just a side note: you mail client seems to unable to handle<NAME>
>>> correctly as well.
>>
>> Really? Attached are screen shots of the last email I sent which
>> included several usages of that string. I use Thunderbird/3.1.7
>> (Mac) and the mail is sent via Google Apps. Screen captures are
>> attached from both the sent folder from my client and that of the
>> Google web client. They look OK to me.
>
> Really. Number of spaces before and after is garbled.


Please note that my earlier message regarding this rendered correctly in
the forum. Further investigation leads me to understand that it's not a
charset issue at all. Even after switching to us-ascii for sending and
display, turning off flowed format, replying multiple times using plain
text and (gasp) HTML mail, it only happened with *your* email. I even
tried using gmail's web interface and all worked well.

Back to the case at hand.

The problem is that when the "Quote" function is used, it has to parse
HTML, strip out the tags, and format the information properly.

Evidently because the less than and greater than signs are used in HTML
the charset entities for these symbols - "&lt;" for less than and "&gt;"
are used when such symbols actually appear in the text.

The quote function decodes those symbols correctly when the traditional
"forum quoting" system is used but that involves using bbcode and the
formatting will certainly suffer. That would be an unacceptable
solution. I have chosen to use a quoting system that looks more like
that of an email. Unfortunately, those characters are being stripped
when using such quoting. I have put in a support request with Phorum's
developers and will attempt to look at the code myself.



>
> [...]
>
> Maxim Dounin
>
> _______________________________________________
> nginx mailing list
> nginx@nginx.org
> http://nginx.org/mailman/listinfo/nginx


--
Jim Ohlstein

_______________________________________________
nginx mailing list
nginx@nginx.org
http://nginx.org/mailman/listinfo/nginx
Subject Author Posted

Problem with nginx/0.8.54 and alias

Amanager February 17, 2011 08:16AM

Re: Problem with nginx/0.8.54 and alias

Igor Sysoev February 17, 2011 09:02AM

Re: Problem with nginx/0.8.54 and alias

Dayo February 17, 2011 01:09PM

Re: Problem with nginx/0.8.54 and alias

Maxim Dounin February 17, 2011 02:24PM

Re: Problem with nginx/0.8.54 and alias

Dayo February 18, 2011 02:11AM

Re: Problem with nginx/0.8.54 and alias

Maxim Dounin February 18, 2011 07:22AM

Re: Problem with nginx/0.8.54 and alias

Dayo February 18, 2011 11:57AM

Re: Problem with nginx/0.8.54 and alias

Jim Ohlstein February 18, 2011 12:50PM

Re: Problem with nginx/0.8.54 and alias

Maxim Dounin February 18, 2011 05:10PM

Re: Problem with nginx/0.8.54 and alias

Jim Ohlstein February 19, 2011 12:08PM

Re: Problem with nginx/0.8.54 and alias

Maxim Dounin February 19, 2011 06:18PM

Re: Problem with nginx/0.8.54 and alias Attachments

Jim Ohlstein February 19, 2011 08:34PM

Re: Problem with nginx/0.8.54 and alias

Maxim Dounin February 20, 2011 06:52AM

Re: Problem with nginx/0.8.54 and alias

Jim Ohlstein February 20, 2011 09:52AM

Re: Problem with nginx/0.8.54 and alias

Jim Ohlstein February 20, 2011 12:04PM

Re: Problem with nginx/0.8.54 and alias

Ryan Malayter February 21, 2011 04:40PM

Re: Problem with nginx/0.8.54 and alias

Eugaia February 20, 2011 03:36PM

Re: Problem with nginx/0.8.54 and alias

Maxim Dounin February 20, 2011 06:36PM

Issues with proxy cache [was Re: Problem with nginx/0.8.54 and alias]

Eugaia February 20, 2011 08:22PM

Re: Issues with proxy cache [was Re: Problem with nginx/0.8.54 and alias]

Maxim Dounin February 21, 2011 06:08AM

Re: Problem with nginx/0.8.54 and alias

Jim Ohlstein March 13, 2011 09:18PM

Re: Problem with nginx/0.8.54 and alias

Dayo February 19, 2011 01:12AM

Re: Problem with nginx/0.8.54 and alias

Jim Ohlstein February 19, 2011 11:06AM

Re: Problem with nginx/0.8.54 and alias

Jim Ohlstein March 13, 2011 09:20PM

Re: Problem with nginx/0.8.54 and alias

Jim Ohlstein March 14, 2011 08:42AM

Re: Problem with nginx/0.8.54 and alias

Amanager February 18, 2011 02:03AM

Re: Problem with nginx/0.8.54 and alias

Igor Sysoev February 18, 2011 02:24AM

Re: Problem with nginx/0.8.54 and alias

Amanager February 18, 2011 03:04AM

Re: Problem with nginx/0.8.54 and alias

edogawaconan February 18, 2011 03:14AM

Re: Problem with nginx/0.8.54 and alias

Amanager February 18, 2011 03:26AM

Re: Problem with nginx/0.8.54 and alias

Jim Ohlstein March 14, 2011 08:31AM

Re: Problem with nginx/0.8.54 and alias

Jim Ohlstein March 13, 2011 09:25PM

Re: Problem with nginx/0.8.54 and alias

Dayo March 18, 2011 03:37PM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 62
Record Number of Users: 6 on February 13, 2018
Record Number of Guests: 421 on December 02, 2018
Powered by nginx      Powered by FreeBSD      PHP Powered      Powered by MariaDB      ipv6 ready